Genre view(s) broken since 1.7?

I have updated both Roon core and the macOS app about 10 hours ago to version 1.7 and since then my genre view seems to be broken. See the attached screenshot, while 62 albums are tagged as “Pop”, only 4 artists show up. I thought I had figured out that the first genre that’s in the tags (ID3 2.4) has to be the top level genre for the artists to appear, because when I updated the tags of “The Queen is Dead” by The Smiths, they showed up, but then just a millisecond later so did Blur although I didn’t change the tags of any of their albums. When I click on “View all 4 artists”, the Focus view even shows me 175 artists (I suppose sub genres are being included there?). Before the update everything was fine. I don’t know if any more information is needed, but bot the Core and the Mac are connected via Ethernet. I guess the audio setup doesn’t play a role here.

[Some more information that I figured might be helpful - I’m running the Core on my unRAID server, my library consists of 1149 albums with 13613 tracks in total. The number of genres I would have to count, but I can say at this point that I mapped most of them to original Roon / Allmusic genres. Which brings me to another thing that’s currently not working on my end, I can not edit my mappings currently, Roon just doesn’t save it.]

Does anyone else have this issue? As you can guess by the genre being Pop, I use my own genre categorization, although, as I said, before the update that wasn’t a problem.

As you can see in the other attached screenshot, this leads to an especially unpleasing overview of the genres. Not much too be inspired by there.

Thanks for any advice! I couldn’t find anything recent with the search, if I overlooked anything I’m sorry, please point me towards there. :slight_smile:

Hi @aureus,

Since noticing this have you tried rebooting your Core? Any change after doing so?

Haha, as I’m currently writing a thesis that obviously leads to me not seeing simple solutions anymore. Rather than looking for an option to force Roon to re-build the library or genre tree I could have just restarted the Core. That fixed it, thank you.

1 Like

Glad to hear that worked, @aureus! If you have any other questions or issues please feel free to reach out in another thread here in #support.