Graphics problems on an old Mac Mini running Windows 10

(Richard Ewing) #1

Core Machine (Operating system/System info/Roon build number)

2008 Mac Pro / MacOS 10.13.6 / Roon 1.6 build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired Gigabit Ethernet, Netgear GS116 and GS105

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Oppo 205 via USB from 2010 Mac Mini (dual boot MacOS 10.14.6 & Windows 10 1903 fully patched)

Description Of Issue

I’m seeing a strange problem with Roon’s GUI running on an ancient Mac Mini in my home theater room. I use older Macs in my house that would be obsolete otherwise and three of them serve as Roon kiosks and a fourth (2008 Mac Pro) runs the core. All of the kiosk Macs can dual boot either MacOS or Windows 10 and I mainly use Windows 10 for the sake of ASIO going to USB DACs. The 2008 iMac running Windows 10 runs Roon GUI just fine, as well as a 2009 MacBook. But the 2010 Mac Mini in my home theater has a strange problem. If I run Roon GUI on it via Windows 10 (fully patched and latest Nvidia drivers), the interface has lots of visual errors, mainly with the track display on the bottom of the window or if i choose to change the audio zone (among other places). It’ll still play music through it if controlled elsewhere but it’s hard to play it through it’s own interface since it’s tough sometimes to determine what’s on screen.

But if I boot to the MacOS side (and I’ve hacked this machine to run MacOS 10.14.6), Roon GUI runs perfectly. I don’t run many applications on either OS but if I run the Chrome web browser on Windows, I don’t see this problem at all with it or any other program. The graphics chip in this machine is a Nvidia GeForce 320M.

I know these machines aren’t new and not supported, but any ideas what might be going on?

(Henry) #2

Is this the graphics issue with Windows, Roon and older graphics chipsets?

(Mr Fix It ) #3

You might try the 32bit windows version of Roon to see if that helps.

(Daniel Beyer) #4

The latest version of Nvidia drivers have had some issues. I had to down grade to an early 2019 version. You might try that.

(Richard Ewing) #5

What’s interesting is that Nvidia specifies that you download a version of the drivers from 2016 for this chipset. Maybe I should try a more recent version.

(Daniel Beyer) #6

Not sure a recent version will work on that chipset.

After driver issues, the most likely culprit for graphic corruption is failing graphics memory. Roon runs its graphics just like a video game. You could try loading a graphic intensive game and see if you get similar corruption…

(Richard Ewing) #7

I suppose graphics memory could be an issue, but if that were the case, I think I’d have seen problems with other programs, or with Windows itself. And the problem is specific to certain parts of the interface, not a general bunch of screen crap. And booted from MacOS, the problem goes away.

I did try to see if I could load a more recent version of the Nvidia driver rather than the one from 2016 but Nvidia doesn’t allow you to since the 320m isn’t supported in the latest drivers anymore. I also tried the 32-bit version of Roon and the same problem occurred.

(Dylan Caudill) #9

Hi @Sevenfeet,

Can you share some screenshots of what you’re seeing?

(Richard Ewing) #10

Hi Ryan. Sure. I took some pictures of the TV the Mac Mini is attached to. Roon seems to be suffering from whatever code draws three things that I can determine:

  1. The menu bar when you click the glyph in the upper left corner

  2. The Audio Zone bar on the right side of the screen

  3. The track information on the bottom, but only if it’s playing something local where there is specific sound information for the progress bar. There does not seem to be a problem with the progress bar with cloud based content from Tidal, which doesn’t give that information.

  4. The Settings screen

There may be others but this is what I’ve seen. It doesn’t matter if it’s light or dark mode. What happens is that the information in question blinks in and out and when it’s “out”, usually the text and other information is partially or badly drawn, then it winks in and out, often several times a second, sometimes waiting several seconds to do anything.

Again, this happens in Windows with Nvidia drivers 342.01. It doesn’t happen in MacOS at all.

IMG_5841 IMG_5843 IMG_5839

(Richard Ewing) #11

Sorry, those files were two small. Let’s try again:

(Mr Fix It ) #12

This could maybe a be a graphics memory issue too is there anywhere in bootcamp to adjust the screen memory allocation? Been a long time since I used bootcamp

(Daniel Beyer) #13

I thought bootcamp was just a dual boot option, not running Windows in a virtual mode but on bare metal.

(Mr Fix It ) #14

It is but perhaps on an older Mac there might not be enough graphics memory allocated to support windows max screen sizes.

Perhaps try a lower res screen size will help…worth a shot.

How much memory does the 2010 mm have?

(Daniel Beyer) #15

Yep, that could be it. That graphics chipset shares system memory.

(Richard Ewing) #16

4 GB of RAM. But again, this doesn’t happen on the MacOS side running Roon.

(Noris) #17

Hi @Sevenfeet,

If you run a OpenGL Benchmark test does it display any similar behavior? Roon uses OpenGL for rendering, so I would be curious if this also displays remnants.

(Richard Ewing) #18

Well I ran both the FurMark 1.20.7.0 and MadShaders 0.4.1 (64 bit). Neither set the world on fire considering the age of the hardware:

Full screen: 1080p
FurMark Score = 139, 3 fps average
MadShaders Score = 79, 2 fps average

That being said, the demos ran without problems. I did notice occasional artifacting in the progress bar at the top of the screen for FurMark but not for any of the demo itself or for MadShaders. FurMark did note about 75% memory utilization while running its test.

(Noris) #19

Hi @Sevenfeet,

Thanks for sharing those test results. It does look like a GPU issue and that Roon is running out of Graphics memory resources causing the artifacts. Also, according to Apple Documentation, Windows 10 is only supported on Mac minis introduced in 2012 or later so this may be an incompatibility issue too.

(Richard Ewing) #20

Well I knew I was running an unsupported OS (both Mac and Windows). The point of all this was using an old machine for a single purpose…that is a Roon kiosk. So far this has worked well with two other machines in Windows 10.

A friend of mine has 8 GB of RAM that this machine can take so I’m going to see if a memory upgrade will help. I’m not optimistic but who knows? And I’d run this machine in MacOS full time were it not inability to run native DSD via CoreAudio. Of course, I guess I could do DoP…

(Noris) #21

Hi @Sevenfeet,

Sure, you can try the RAM upgrade, but this does seem like a GPU issue and not one due to limited RAN resources. A few other ideas:
You can try installing RoonServer and use only other Roon Remotes to control that Core

  • You can try rolling back to older GPU drivers
  • You can try performing a fresh Roon install to see if that changes anything (as in perform a backup and reinstall the Roon app + don’t preserve the old database)

At the end of the day, Apple does mention that this is unsupported so it may not end up working out, but if you want to experiment further go for it, although do keep in mind that this is an unsupported platform and I along with other Roon staff won’t be able to help much further.