Group Zone Problem

Core Machine (Operating system/System info/Roon build number)

Nucleus (Version 1.7 build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Eero mesh WiFi network. Endpoints are a combination of ethernet connected and WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node 2i, B&W Formation Flex, B&W Formation Flex (stereo pair), B&W Formation Wedge, Pro-Ject Stream Box S2 Ultra (2) - All endpoints are certified “Roon Ready” and on their latest firmware version

Description Of Issue

I just purchased a B&W Formation Wedge for my dining room. My goal is to create a group zone with my Kitchen (2 Formation Flex speakers that have been stereo paired), Dining Room (new Formation Wedge), and my Great Room (Bluesound Node 2i). All of these devices are Roon Ready and AirPlay 2 certified.

When I group zone the 3 rooms together and begin to play a playlist (from either Tidal or Qobuz), the first song will play fine, but then when the track changes the Kitchen speakers (stereo paired Formation Flex) will no longer play. The other two endpoints will continue playing fine, but the Kitchen endpoint just stops altogether.

Interestingly, if I create a group zone with these 3 endpoints and begin playing a Live Radio station, it will work fine for hours. If I change radio stations, the Kitchen endpoint will no longer play. Sometimes, Roon just freezes up and will not allow me to change the source of the content at all.

Initially, I was using upsampling via Roon DSP to each of the endpoints but thought that a possible source of the problem could be my WiFi and not having enough bandwidth. My home WiFi is a mesh network with 75 Mbps download speed. I turned off all DSP and volume leveling, etc. to each endpoint but unfortunately the problem remains.

As an alternative (temporary) solution, I enabled each endpoint to work through Roon via AirPlay. If I create a group zone the way I want through AirPlay the problem goes away… for a while anyway. I did this for 3-4 hours yesterday for Thanksgiving and things worked fine until Roon just “froze” and wouldn’t let me play anything to the AirPlay group zone.

Ultimately, my problem resides with the RAAT technology not allowing me to include a stereo paired endpoint within a group zone. What I don’t understand is Roon “sees” my stereo paired Kitchen Formation Flex speakers as one, and works fine if I stream directly to them outside of a group zone, but when I include them in a group with other endpoints they just stop playing after one track.

I would appreciate some help in getting this resolved. If I forego Roon completely and just stream from my iPad or iPhone to each of the 3 rooms using AirPlay 2 everything works as I want it to.

I realize that playing to stereo paired Apple Homepods via Roon is not possible… but this is different as the Formation Flex product is certified Roon Ready and already works with Roon as a stereo pair. Just for whatever reason it is not working for me when I want to include it in a group zone.

Looking forward to some help…

Bump for help

Hi @Riviera_Bluesman,

Thank you for your patience here while your case reached my queue!

Is there any pattern as to the content when this occurs? For example are the tracks that you have queued up the same sample/bit rate or do they differ and the device is playing different content?

What happens if you try to un-group the Flex stereo zone and play to them individually as a group, does the issue still occur?

Are the Flex speakers connected via Ethernet or WiFi?

Hi @noris:

Sorry for my impatience :blush: and thanks for your help!

I generally make playlists on either Tidal or Qobuz so I can also use their native iPhone apps when on the go. For the most part, tracks are 16 / 44.1, but I will also include higher rez MQA or FLAC when they are available.

Over Thanksgiving, I combined a couple of albums within my Roon queue and put them on shuffle. I honestly don’t recall if each of the albums were 16 / 44.1, but I believe that they were.

I don’t exactly understand what you are asking here… Do you mean “unpair” the Flex speakers to make them two separate mono endpoints? Then group them together?

If so, I thought about trying that but there is no clear way how to “unpair” the Flex speakers within B&W’s set up app. So I have not pursued that… I would of course prefer to leave them as a stereo pair as that is the reason they were purchased.

… Forgot to add, the Flex speakers are connected to the network via WiFi.

Bumpity Bump.

@noris any chance I could get some assistance?

Hi Riviera,

Not Roon support, but, I saw your bump.

The next diagnosis I would suggest is to connect the kitchen speakers via ethernet, removing them from WiFi will help focus where the issue may be occurring. If they work on ethernet, then you know the Wifi is the issue.


1 Like

Thanks for the suggestion. I don’t have a way to get them connected to ethernet where they are located… but I will try to figure out how to temporarily move them and get them plugged in to see if that helps…

1 Like

No problem. One of the mantra’s of troubleshooting is to simplify to the point the issue disappears, then add things back in to pin point the issue.

Kitchen’s are especially hard as things like Microwave ovens can interfere with the signal.


Hi @Riviera_Bluesman,

Apologies regarding the delay in getting back to you here and thanks @Rugby for jumping in!

Yes, testing the speakers on Ethernet is a great next test to run here. WiFi interference often can occur in a kitchen when there is a microwave in the mix as well.

I understand that using the stereo pair is the end goal, but if just one of the Flex speakers impacted by this behavior, but the other one is not, then we have a great data point and we know to troubleshoot the specific speaker more closely.

One other test here that you can use to determine if sample rate plays an effect is to use Roon’s DSP Engine to up-sample all the content for this zone to the Max PCM rate:

If the issue does not occur with up-sampling turned on, then it is possible the issue only occurs when switching sample rates between tracks, which would be another great data point to have.

So I have changed the DSP setting to “Max PCM” on each of the 3 endpoints that I want to group together (Formation Wedge, Formation Flex - stereo paired, and Bluesound Node 2i). This seems to have resolved whatever the issue was.

It is now working as it should, even when switching tracks with varying sample rates. I am a much happier camper!

1 Like

Hi @Riviera_Bluesman,

Thanks for letting me know that turning on up-sampling resolved this behavior!

This confirms my suspicion that the issue only occurred during sample rate switches, strange that just the Formation Flex is impacted here.

I’ll check in with our hardware team to see if we have a stereo Flex in-house and if they’re seeing the same behavior.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.