Half my music no longer shows up and new additions also do not show up

I recently fired up my Roon app on the Ipad (Roonserver is on my Synology) after a trip abroad. I used to have over 100,000 tracks and now I only see 53,000, even after several forced rescans.

I also added a dozen new albums over the past two days, forced more rescans and nothing changes the track count. No changes were made to the system or to the folder structure on the NAS. What happened??

Hi @Patrick_Van_Osta ---- Thank you for the feedback and my apologies for the inconvenience here. I am certain we can get this issue figured out for you and would like to gather some information from you first.

Can you please describe in detail, as seen here, your current setup. The more detailed you are the easier time we will have evaluating the problem. Thanks!


Current setup:
Roonserver installed on Synology 1513+
Single volume of 5x6TB in hybrid raid (22TB or so)
Music directory is approx 9 TB and sits in volume1/music

Synology is connected via Ethernet to Gb switch
Switch is connected to Oppo 105 via Ethernet
Roon app runs on Ipad

No changes have been made to this setup.

Two weeks ago I saw approx. 21000 albums and 200,000 tracks.

Now only 6400 albums and 53,000 tracks.

I also added new albums in the past two days and none of them show up despite repeated forced rescans. Let me know what other info you need.

As an example, Roon shows my DSD albums (using focus) as 28, while the files on the NAS show 82.

I just removed the library folder and re-added it, forcing yet another rescan. Still only showing 6938 albums instead of the more than 20,000 which are in this directory…

Hi @Patrick_Van_Osta ---- Thank you for the follow up and the input, both are appreciated! I would like to gather some logs from you so our developers can take a look into this issue. I will be contacting you shortly via PM with instructions. Thanks!


I grabbed some logs from my Nas Roonserver directory. They are about 8MB each. Let me know how to get them to you.

Hi @Patrick_Van_Osta ---- Thank you for the follow up! I had contacted you privately via PM with instructions on how to send logs over to us via a support ID. Did you not receive the message? Just want to make sure something isn’t going on with our system. Thanks!


Thanks, I followed the steps and the data did not send. Message on the Ipad: ‘We couldn’t connect to our server’. Tried twice with the same result.

Interesting tidbit:

I rebooted my NAS and now Roon sees most if not all of my music again…
I have no idea what happened but I’ll take it :slight_smile:

@Patrick_Van_Osta ----- Sorry for the trouble with upload, but glad to hear that you music has returned. Keep me updated if anything else comes up and I will be glad to help :slight_smile: Happy listening!