Having Issues with New Pro-Ject Stream Box S2 Ultra

@Andreas_Fruehwald - What is Volumio and who am I sending the logs to?

Hello @Marcus_Guerrero,

In the “Playback Options” menu on the Stream Box S2 Ultra, what do you have configured for the “Mixer Type” setting? Try setting this to “None” and then clicking the “Save” button.

When you are playing MQA content, what sample rate is the Pre Box S2 Digital showing on the display?



@John - Oh my effing God! Are you kidding me? It’s working!!! All MQA files playing from TIDAL and on USB drive including DSD files! Had 1 second of white noise when I started to play DSDs but they are all playing perfectly now. Pre Box is lighting up MQA indicator and the dots are changing colors to indicate resolution; Pre Box is also displaying the correct resolutions i.e. 48k, 192k, DSD64, etc.

This is all via Pro-Ject Play iOS app so I have yet to try this at home with Roon.

Please tell me what that setting is all about???

What a breakthrough. Hallelujah!!! Thank you @John. I’m keeping my fingers crossed and hope it works with Roon at home tonight.

I had just given up and requested an RMA to return the Stream Box. Truth.

1 Like

@john - Home now and connected to Roon with the applied setting you suggested. It’s working! What more can I say? Overjoyed. Finally!

Thanks a million!


1 Like

Hello @Marcus_Guerrero,

I stumbled across this thread when searching for someone experienced with either Mac mini AND Pro-Ject stuff in a Roon environment. Bingo. :wink:
My question ist how would you rate the ProJect Stream Box S2 Ultra vs. the Mac mini as a Roon endpoint feeding an USB-DAC? Have you ever tried this out? Do you hear any difference? Plainly spoken I am very suspicious about these overpriced audio-only boxes just for the sake of hopefully jitter-reduced USB output. Would be very interested in your findings/opinion.


Hi there - My Mac mini was previously my Roon Core. I built my own ROCK (Intel NUC) which is now my Roon Core.

My ROCK, Pro-Ject Stream Box S2, and Pro-Ject Pre Box S2 Digital are all hard wired to my network. My Pro-Jects are my endpoints to my stereo system in my office/man cave and I have an Oppo 203 as endpoint to my living room Home Theater system.

The Pro-Ject combo has performed flawlessly and I’m very happy with the audio quality. I don’t consider them “overpriced” at all. I think they are “competitively priced” and are a great value. The Stream Box can be used with Roon and also be controlled separately with an app on your iPhone or iPad to stream Spotify, TIDAL, Qobuz, etc. and can access DLNA-enabled media servers on your network. Also has Bluetooth and Airplay and can play files from USB drive connected to it.

You can read this review and decide for yourself, https://darko.audio/2019/03/have-your-pi-eat-it-pro-jects-stream-box-s2-ultra/. The Stream Box has been criticized for being a high-priced Raspberry Pi.

Based on my experience though, I have no problem recommending it.

1 Like

Hello Marcus,

I agree with you - the Pro-Ject Stream Box S2 Ultra, is excellent value for money. I have one since over a year which I use as a Roon Endpoint to drive my SGCD + S300.
Those who call it an overpriced Raspberry Pi, have most likely never listened to one.

Hans Beekhuyzen has an excellent more technical review: https://www.youtube.com/watch?v=7CX-pZRhbtI


1 Like

Yes! +1 for Hans. I trust his reviews and I subscribe to him on YouTube. Thanks for the reminder.

Here is a link to another post documenting my Streambox setup:

I’ve been trying to play DSD64 on the Ayre QB9 Twenty via the S2 Ultra but it keeps defaulting to DoP 352kHz, tried a few of the fixes in this thread but to no avail. When I try to set Mixer to “None” in Playback Settings it doesn’t seem to consistently save, for what it’s worth.

Has anyone encountered this on their devices, either through USB playback or Roon?

Hello, I have a similar problem with Nuprime DAC 10, is not detecting DSD capabilities. This is because a mistake in older kernel used, and was corrected by ropieee and even on new versions of standard volumio.
I contacted Volumio, Project and dealer without any response.
Maybe Roon guys will have more success.
In mean time, I use another Raspberry pi CM3 module loaded with ropieee (they don’t provide recovery image to custom volumio installation).
Thank you

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.