Having Issues with New Pro-Ject Stream Box S2 Ultra

I have a brand new Pro-Ject Stream Box S2 Ultra which is not performing as expected and looking to hear from others and share their experiences.

This is my current setup:

ROCK (Ethernet)


16GB RAM Crucial (2X8GB) DDR4-2400 SODIMM

Samsung 970 EVO 250GB - NVMe PCIe M.2 2280 SSD - RoonOS

Samsung 860 QVO 1TB 2.5 Inch SATA III Internal SSD - Internal Storage

Mac Mini Running Roon Bridge

Pro-Ject Pre Box S2 Digital connected to Mac Mini via USB (no separate power supply)

MacBook Pro is my Roon Remote

New setup:

The Stream Box has replaced the Mac Mini in my setup; it is connected to my network via Ethernet. My Pre Box S2 Digital is connected to Stream Box via USB (DAC) port.

The Stream Box set up process was done using Safari browser and is updated to the latest firmware; easy-peasy. Everything was working fine on the first day of using it. I also used the Pro-Ject Play app for iOS to stream TIDAL. All my music stored internally on my ROCK played fine including DSD files. TIDAL MQA tracks played well too. The Pre Box MQA lit up and showed correct resolution when playing MQA tracks; I confirmed this by looking at the Source/Path displayed in Roon.

On the second day, none of my DSD music files would play; sometimes I would just get silence, sometimes static. Also, the Pro-Ject Pre Box would not light up to indicate playing MQA files and the full resolution was not being displayed on the Pre Box either.

I’ve power-cycled everything; no issues with any other devices on my network; reset Stream Box to factory settings and applied firmware update again — everything I can think of. Nothing has worked. FYI, this is my 2nd Stream Box. The first one was already returned as defective; had the very same issues but it also kept disconnecting from my network frequently.

All indications point to the Stream Box because I can take it out of the chain and replace with the Mac mini and all in the world is right again.

This little box is aggravating me and I just want to give it a chance before giving up completely and returning for a refund.

Any others out there who have a similar setup or have had success with the Stream Box, please share your experiences and knowledge.

Thank You!

Hi Marcus,

I’ve closed your other thread. Let’s just deal with this one. @john will be along to help you.

Cheers, Greg

OK. Thanks, Greg!

Hello @Marcus_Guerrero,

Here are two troubleshooting procedures that should help us determine why you are seeing this behavior with your setup:

  1. What firmware is your Pro-Ject Pre Box S2 Digital currently running? I believe the most current version of the Pre Box S2 Digital firmware is 1.12.

  2. Do you see similar behavior when you have the Pro-Ject Pre Box S2 Digital connected to the NUC running ROCK? I would make sure to test DSD playback from Rock to the Pre Box S2 Digital as well.


Software version on Pre Box S2 is 2.12.

I’ve never connected the Pre Box S2 directly to NUC running ROCK. I’ve never used it that way. I seem to recall reading a topic that recommended not connecting a DAC or endpoint directly to ROCK. Is it possible to do that when connected to ROCK as my core and MacBook Pro as Roon Remote? It’s late now so I will try this in the morning.

Are you leaning towards the Pre Box as the cause of my issues and not the Stream Box?

Thanks, @john. I will report back in the morning.

You can also confirm that you can play files incl. DSD directly from a USB stick connected to the S2 Ultra to confirm that it works.
You play it from the Pro-Ject IOS app.

Do you now what formatting USB drive should be? I rarely play from thumb drives.

Just choose default which I think is exfat/fat32 on both osx and windows

Hi @john, just reporting back to you. Pre Box S2 Digital is connected to my NUC ROCK and using MacBook Pro as Roon Remote. All DSD files are playing perfectly! Pre Box MQA indicator lights up while playing MQA tracks and the colored dot changes to indicate file resolution. Works as expected. In fact, it sounds amazing when compared to Pre Box connected to Mac Mini OR even my new Stream Box, which I still think is the problem. Not an official A/B comparison though. Just a first listen this morning.

@Rune - just transferred 2 DSD64 albums (Cat Stevens “Tea for the Tillerman” and Weather Report “Heavy Weather”) to exFat formatted USB thumb drive plugged in to front USB port on Stream Box. Properly recognized but files played no music; just loud white noise.

Edit: I just tried again and noticed that when I hit PLAY, a message pops up in browser “Error Failed to open ALSA device - No such file or directory” and then USB/PC blue light turns off on front of Stream Box.

Try to go into settings and the menu playback options and make sure you ave selected your DAC as output device.

Already done. When Pre Box is connected to Stream Box, it is already recognized as the output device. I checked again just in case and Pre Box is selected.

My Playback options look like this:

Exactly like my settings! Hey, @Rune. What is your setup? Would you mind sharing? Or is that something I should be able to see in your profile? Pardon me, although I know how to post stuff, I haven’t been on here long enough to know all the features of this Community.


Edit: BTW, thanks for keeping up the interest. I have yet to hear anything back from the Roon folks; the Stream Box is Roon Certified. I was able to make contact with Pro-Ject Support-US (via Sumiko Audio in Minneapolis) yesterday but the guy I spoke to needed some time to set up Roon. He admitted that I probably knew more stuff about Roon than he did. They have my phone and email are are supposed to get back to me soon.

Hi @Marcus_Guerrero - I’m not sure if this will help at all, but I am also using a Streambox S2 Ultra / Pre Box S2 Digital, although my Roon core and library are running on a NAS.

I just found a free DSD download (as I don’t have any) to try and it all seems to be working fine here.

The only setting I have that is different that I can see compared to Rune’s post is the “DSD Auto Volume Level” as shown:

That seeting does seem to have a “Warning” associated with it if you click the help sign - so might be worth ruling out?

Not sure if that helps you at all - but good luck with it, as it sounds pretty damned good if you get it working!

Hi @Marcus_Guerrero, maybe the logs could shed some light on your problem. You can get them by following the steps on https://volumio.github.io/docs/User_Manual/Sending_logs_for_troubleshooting.html

Hello @Marcus_Guerrero,

Thanks for your patience while we investigate this issue.

What I’m going to do is go ahead and enable diagnostics on your account. The next time that your Roon Core contacts the Roon servers, a support package will be uploaded containing advanced diagnostic logging.

The next time you have trouble with playback, please reply back in this thread with the local time that this occurred. What we will then be able to do is request a new set of diagnostic logs and focus in on the events occurring at the time of playback failure.


Hello @John,

I wish you would have informed me sooner. I’ve been working on it every evening this week when I get home from work. I’m just about to give up on it and return it to Audio Advisor and get a refund. I’ve not received any help from Audio Advisor or Pro-Ject US. I’m an audiophile, IT Guy, and tech nerd. It’s rare that I cannot get anything to work.

I even brought it to work today to do some troubleshooting; I also have a Pre Box S2 here on my desk attached to my work iMac and listen to TIDAL while I work. However, I don’t have a Roon license or core here at the office.

Hi @Andreas_Fruehwald, I’m at work right now with my Stream Box connected to the Pre Box. I’m on my iPad using the Pro-Ject Play app and streaming from TIDAL. I am playing tracks that are MQA and the MQA indicator is not lighting up on the Pre Box. On the front of Stream Box I have my USB drive connected and I’m playing MQA 24bit/192 album of Aretha Franklin’s “Young Gifted & Black”. No MQA indicator light on Pre Box. On same USB drive I have DSD64 of Cat Stevens’ “Tea for the Tillerman”. When trying to play, the only sound coming from speakers is loud white noise. Mind you, I’m using a 2nd Pre Box which I have at work. Same Pre Box, just different color.

Edit: Just wanted to add, when playing Cat Stevens DSD, although I heard no music just white noise, it was still displaying DSD64 on the Pre Box.

Thanks, @Dave_Kitson. I’ve already played around with these settings and have ruled them out.