Help: DigiOne/RoPieee/Mac/iPhone

I’m running the latest RoPieee and Roon.

I’m not getting any audio out of the DigiOne.
When using the Roon app on my Iphone, it displays as though it’s playing a track for about 20 seconds and then moves on to the next track for the same amount of time and this continues for all tracks…but no sound comes out and my DAC never seems to get any data.

I have the Core running on my Mac, but if I click the find Core button, it never finds it. In the Roon app on the mac it says I’m logged into Core.

All three devices show up in the Roon app on the Mac and the Iphone as enabled. The DigiOne is on the network.

What am I doing wrong?

Core machine: Mac Mini M1 OS 12.4
Roon 1.8 build 1021

Remote: DigiOne (Pi4)
Roon 1.8 build 943

Networking: Wireless USB on the DigiOne: Alfa AWUS036ACM
I used the default config
It shows up on my router and in the Core app.
I’m running it on 5ghz and I have turned off the 2.4ghz router.
Note that I’m getting a long ethernet cable today and I will test it…hopefully it will reach…

Audio Devices: I’m using a Denefrips Ares II DAC
The DAC is not receiving any data…yes I’m using the correct input and all the cables are tight.

Library: I’m trying to stream from Tidal and I have not set up any local files yet.
Screen Shot 2022-07-29 at 12.54.53 PM

Welcome to the community, @Eric_Hodges.

Your post is best if in the #support category, so I have asked for it to be moved.

In the meantime, please provide more details about your setup including network. The following post describes the information needed to assist you.

type Ropieee.local in the address bar you should get this (this is RopieeXL but its the same)

Is the HAT configured correctly , as in mine?

Are you running the pi with Ethernet or WiFi, this sounds like a network drop on wifi ?

Hi Mike,

Yes, it’s set up that way except for the USB since I’m not running the signal via USB.

I think your problems may be related to networking, i.e., using Wi-Fi with the DigiONE. Please let us know how you get on with the Ethernet cable.

I set up the ethernet and turned of the wifi, then rebooted.

The issue is not resolved and the behavior is the same. The iphone is showing that each track plays for 20 seconds or so and then it jumps to the next track but there is no signal to the DAC.

Okay, at least we’ve ruled out Wi-Fi.

Can I suggest another test: Enable USB in Ropieee, and connect a USB cable to the Ares II. I think it would be useful to confirm everything except the DigiONE works together.

1 Like

Hey Martin, I set up the Digione to use USB. Then Roon could see the DAC and I selected the DAC as an output device. This works but the coax is still not working. Any ideas there? I have a really nice cable, supposedly, for the coax, so I want to test that output.

Also note that the behavior of playing a bit of a track and then skipping to the next track stoped when I set up the USB.

Okay, so we now know Roon and Ropieee are working correctly.

Is the DigiONE new, or has it worked previously? Did it work prior to the new cable? Can you describe the cable. Is the cable 75 Ohm BNC to BNC?

I bought the DigiOne used so this is the first time I have gotten sound out of it. The cable is RCA to RCA 75 Ohm. I double checked to make sure it is tight at both ends and to make sure I’m selecting the correct input on the DAC.

Unfortunately, the USB output is from the Raspberry Pi, not the DigiONE. The cable should be fine, so I’d like to confirm that Ropieee is setup correctly, and you have set the hat to DigiONE / DigiONE signature as depicted in @Mike_O_Neill’s screenshot. Make sure that Ropieee configures the hat, and then reboot as instructed.

If it is setup correctly, Roon will see the DigiONE, and provide the settings and artwork since it is a Roon Ready device (your screenshot of the signal path did not show the DigiONE.)

You may need to go to Roon Settings > Audio to enable the DigiONE.

hmmm, I have the DigiOne enabled:

I completely forgot that the USB comes from the Pi, lol. So roon can see the DigiOne, or is that just because I told it there is a Digione?

Okay, that’s good. However, the signal path you posted earlier doesn’t look right. This is my DigiONE…

Can you provide a screenshot of Setting > Audio plus the complete Device Settings for the DigiONE.

Where do I get “complete Device Settings for the DigiONE”

Is Ares the USB output?

Advanced settings is below the fold, so scroll down (there’s no slider bar) and click on Show Advanced.

Also, when playing to the DigiONE, do you have the Allo logo as in my screenshot?

It looks that way.

I don’t see the Allo Logo anywhere…wondering if the DigiOne is toast…

Oh, and yes, Ares is the DAC.

2 Tests to check the Coax out of the Digione , (it is looking like the card is the issue !!)

1 - do have you any other way of connecting the cable to test it ?

2 - Or better still, do you have a RCA to RCA cable to replace it. Even a bog standard audio cable will prove the coax output is good and eliminate the Digione

I assume you are going coax from the Digione to the DAC ?, if the USB is still connected then disconnect it .

The Digione icon is


I’d agree that it is either the card or the cable.