Help Needed on Various Issues

Roon very likely messed something up in rolling this update out, as I have the same problem as reported vy another user with an Apple Iad (Core roon 2.0 - pc roon 1.8 incompatible, no access to core via ipad): Everything worked perfectly for me (apart from Roon not recognizing a lot of albums from classical composers in my library, but that is another problem) before that (cursed) 2.0 update. Details as follows: Roon 1.8 ran on ROCK (Operating System Version 1.0 (build 227), Roon Server Software updated this morning to Roon 2.0 (build 1128). After that, the 1.8 version installed on my Lenovo Laptop running Windows 10 Professional would not update to 2.0 (as also reported by other users, see Core roon 2.0 - pc roon 1.8 incompatible, no access to core via ipad). I deinstalled Roon completely and reinstalled version 2.0 (build 1128) production (64bit). Now, the laptop sees and runs the ROCK core again. However, the Roon Remote on my (new) Samsung Galaxy TabS6 Lite does not see the core after the 2.0 update. I deleted it and reinstalled the newest version of Roon Remote (2.0, build 1127). Still does not work: The Remote gets stuck with “Looking for your Roon Core”. Even when choose “Help” and give the IP address and order “Scan”, nothing happens. Help also gives the recommendation to go to settings-Setup-General and see if “Accept connections from remote” is switched on. However, on this 2.0 version there is no such possibilty indicated.
Unfortunately, I also went for a lifetime licence before I discovered the many misfits of Roon with not recognizing classical albums (from my Gustav Mahler recording, about 15 turn up in the library, about 25 do not). Now, this badly prepared 2.0 rollout.

I’ve moved your post from out of another (solved) Support thread, since it seemed to me that you required explicit assistance on a number of issues.

The primary one being that because of the upgrade, your Roon Remotes are no longer talking to your Roon Core.

A secondary issue is connected with metadata - for some reason your Mahler collection is not being catalogued correctly in Roon.

A third issue is that a Help article is now outdated with the recent releases of Roon.

Let’s start with the primary issue…

Can you please let Roon Support know these details so that they can better assist you? Thanks!


Roon Core Machine
Roon 1.8 on ROCK (Operating System Version 1.0 (build 227), Roon Software at Roon 2.0 (build 1128) - Correct?
Roon Remote devices
Lenovo laptop running version 2.0 (build 1128) production (64bit)
Samsung Galaxy TabS6 Lite running Roon Remote (2.0, build 1127)

  • Correct?

Networking Gear & Setup Details
Your network gear (model of routers/switches) and if on WiFi/Ethernet - Please give details. Also useful to give the IP addresses of your Core and Roon Remote devices

Let’s get the connectivity issue sorted first. We can tackle the Mahler collection issue in a separate post in the #support:metadata category of the forum.

@support please take note that this Help article is now outdated with the newer Roon releases - it needs updating. Thank you.

Hey @Florian_Hassel,

Ben here checking in on this thread, are you still having issues getting your roon remote to connect to your core? If so, please fill out the information that @Geoff_Coupe highlighted above.

I’ll be monitoring this thread for your reply :+1: