Help, please, my Ropieee does no longer recognize my audiophonics AES-EBU hat

This hat;

works with the same hat config in Ropieee as Hifiberry Digi/Digi+/Digi+ pro.

Suddenly it does not. I updated to final XL 2019/11/17, and no it does not work anymore. I thought I blex my hardware, so I have purchased both a new HAT and new RPi 3B+ final revision. Finding out this did not was the cause got me a bit mildly exited. Is there any chance that this final revision, where specifically Audiophonics audio kernel is changed, is the root cause for this malfunktion? Just got to ask for rescue, cuz my entire system depends on that small endpoint for any source. I have re-installed ROON numerous times, also Ropieee, switching between Ropieee and XL. Both my studio monitors indicate no lock-on sync and the optical output never lights up. I have tried every psu.
Pls. help me guys. This is a disaster for my entire audio infrastructure.


Sorry to hear that.

So, you have been using this HAT by configuring it as an Hifiberry Digi?

Can you send me feedback? You can find that on the advanced web page.

Hi again and thanks for your prompt reply! :slight_smile: I do not understand what the “advanced web page” is. Been surfing across Roon community, but obviously I am blind (or a plain stupid noob) or both …
I am not a user at all of Linux, so unless things are simple plug and play, I am completely lost.
Just be patient with me please, I am getting there, but the pace car is on the track and thing’s just are not moving as fast as when 20 years old anymore …

Don’t worry, it is plug-and-play :wink:

RoPieee has a web page where you can configure the necessary stuff (like which HAT etc.).
There are numerous tabs, and one of those is named ‘advanced’.

Over there you see a button labeled ‘Send Feedback’. Hit that button and I’ll receive feedback.
You’ll be shown a rando string of characters, that one you should report here so I can identify your feedback.


Hi again and once more thanks for the patience :slight_smile: and kind attention


Kindly, Stefan

My choice is RopieeeXL since we cannot agree on one streamer service. My wife is a headstrong redhead, she does not mess around and if she wants Spotify, she gets spotify.
Me I only run Roon, it is just excellent as is also your software. Once in a while, I will with XL be able to play and compare the JRiver installation that still remain in my computer. The DLNA part, will be of interest to further scrutiny.
So, there you have the outlines of my music listening. Can this be solved, I now have two sets of RPi3B+ and Audiophonics HATs, I will probably get me a good external DAC/headphone amp for the occasions I want reality to f*ck off … :wink:

Hi @Computer_Audioholic,

Problem is that for some reason the HAT is not properly initialized, hence no audio device, hence no output.

You always used it with this HAT config? Have you tried with the ‘RPI-DAC (I2S)’ as HAT configured?

Nope, have not. Should I try? I do it anyway …

Hi again, no respons with the suggested alternative. Does appear as a network sound device i Roon, but will not, as you say, kick off the hat output itself. No sync from optical or AES-EBU.
May it be harmful to try other “digi” devices?
Kindly /Stefan

Hi again … here’s screen captures from Roon when using Hifiberry Digi+. Completetly visible by Roon, but no action in the HAT.

Now, the last mess for today … :joy: Got to admit I am a persistent bastard …

You got to see this; I selected Justboom Digi Hat and, voila, sound there is. I made a feedback for you to check; code: 6b66d41d04ea721d.

I am very curious about your findings … What the heck is the difference? Is this a good driver soundwise? Looking forward to your reply. Computers may never win the battle against my stubbornness!

Kind regards and a happy saturday night!

Hi, it is sunday. :slight_smile:

Want to give you some additional info about the above mentioned experiment. The HAT does not work with the power supplies separated. It has to be either the Raspberry feeds both, or all power inputs feed everything. The HAT stops working if I add a Ifi DC iPurifier in the power line. Why? Only God knows, I guess. This is for the JustBoom Digi HAT. I have not tried any further HATs now. Will continue. One step, I do not like to take is to test piCorePlayer software. It is mentioned as example together with Volumio in the e-trade retailer Audiophonics product page for the HAT.

I like Ropieee! Want to stay with Ropieee and be a possible contributer. You should se the procedure for just installing the piCorePlayer … my God


the last I did yesterday was to install and hopefully, because that was a completely new level of OS, configure DietPi. There was sort of plugins (additional DietPi software) once the DietPi was installed to choose among. Kept it simpel and just installet a desktop leightweight and ROON bridge as well as Raspotify Connect. I was able to start ALSA and to choose exactly the right HifiBrry soundcard/HAT suggested, but NO. NO action.

I am completetly out of ideas.

Have you been able to figure out why JustBoom Digi HAT worked nstead of the intended HifiBerry Digi+? Any help here would be highly appreciated. Really would like to stay here with Ropieee, who seem to have the most userfriendly and most plug and play UI of the one’s I have tried and tried and tired … :slight_smile:

No didn’t find anything, because there’s not enough information to figure out why it works with the Justboom driver and not with the Hifiberry one (except that there inner workings are quite similar, hence the ‘it just works’ :wink: )


Since you have both drivers included in your Ropieee distribution, would it be possible for you to make one that works? It just has to be something around some initializing as you mentioned, becasue it will not support the stand alone power supply either. It seems somehow need some trigger from the RPi in order to “open” or sync or what ever one should call it. Are the parts that handles the bit perfect stream alike? Can I assume the JustBoom Digi HAT driver sound as good as the supposedly HifiBerry dito should have? It is highly disturbing not being able to separate the power supplies. The Card I have are transformer balanced to separate bitstream from RPi to the output and also it allows with jumpers to separate the power between the RPi and the HAT, but when I do that jumper config, the HAT stops working, hence my suspiscion about a necessary trigger signal sort of hidden in perhaps the power supplies. Well I am not the magician. Would be interesting though to make the HAT work with all features operational.

Spockfish … there was an update in Roon this morning.

Suddenly the card works like a charm as a HifiBerry Digi+ as it should according to Audiophonics.

And it sounds way better than the JustBoom Digi HAT driver. Further, it allows separated feed of power to RPi and the HAT.

Magical …


Sorry, slipped in via a wrong user name here; I am is still Computer_Audioholic writing this answer:

Have been able to kick-off the HAT in the right mode of operation av endless tries, but I do not know what made it kick off. I’ve sent a feedback summary: 67f8b2c763e38b0f
This is the state, when the hat is working with separate power sources for computer card and HAT. Is there perhaps anything in this file that can explain the highly erratic behavior?
Been trying with which card to fire upp first and go via Just Boom Digi HAT first and then change to HifiBerry Digi HAT, but there is no way that has been proven successful all times. Audiophonics does not give a shit it seems, because I do not get any answers on the questions. It would be so very fruitful to understand what triggers orrect function and what is not. hey are logic units, so it should be a logic answer in there somewhere.

As of now, when working, it sound really good. The galvanic isolation from power from the Raspberry makes miracles …

Thanks and regards.

I had an infra issue, hence your feedback did not arrive at RoPieee HQ. That has been resolved now.

But what is the exact problem? AudioPhonics devices are not the most easy ones to support, and I’m afraid that’s where the issue lies. Do you have a Pi 4? At least on a Pi 4 it uses it’s native driver instead of a generic driver.


I think I figured it out by trial and error. It seems very sensitive to powering up. It works when HAT and RPi3B gets power from the RPi, a highly unwanted situation, hence not benefit from sperated power sources. But now hen the HAT and RPi is installed with a power source that kicks in on both power inputs simultanously it boots and worksflawless. It seems my speakers are very sensitive to the time between sync signals, it closes with a thump in audio system. Very amatuerish … Will ask my friend to check receiver circuit and settings there. How do we contact you if we want to build a commercial streamer using Ropieee builds? We would like to discuss the possibility for a custom software and pricing off course including very clear PR for you and Ropieee. The sound quality is now among the best ever heard and I am playing directly to pro studio monitors via AES-EBU. Very satisfactory indeed. We will build yet another prototype post-Santa Claus and if that turns out even better, we would like to present the idea and ask for quotation for our contribution.

For your info, I would like to inform about the very fi sensitivity both the RPi and HAT display, and that goes for most Raspberry and also HifiBerry products. A lot of faults and drop outs seem to simply depend on the crappy plastic cabinets, transarent not only for eye, but also for massive noise impact in normal homes today. In addition any application sounds crappy in comparison even if working.

Thanks and regards.Merry Christmas.

Hey guys,
just installed one of the AES Hat from Audiophonics.
The Optical out works perfect… But the AES doesn’t . It is connected to an ALLDSP Unit.
Maybe I do something wrong…
All the best…