History: odd behaviour [Resolved build 200]

At the beginning of the history list there is a long list of items played “just now”. Except that none of them were played just now. I have to scroll through them all to get to items play a few minutes ago, which are then listed as played x minutes or x hours ago.

The long list of “just now” items seems to be the same as the temporary Christmas playlist, which I deleted a couple of days after using it. So I’m not sure why it is sticking around… This list of just now items appears on both my regularly used remotes, an ipad and a MacBook Pro. I have Roon core server running off a sonic transporter.

Hi @Anthony_Langlois ---- Thank you for the feedback and my apologies for the troubles here.

Can you verify for me if you have tried reinstalling the remote application on any of these devices yet? If so, did you notice any changes in behavior here?


No sorry, I haven’t tried that, although now I will. In the meantime, I can report that on my remotes I now have no history at all! I’ll reinstall both and report findings…

On the iPad, the reinstalled app is working better: the last couple of day’s worth of history shows again. But there is still a long list of items which were played “just now” about 36 hours into the history list, that come from that playlist on xmas.

On the Mac, it was listing some history, but going back to say 18 hours or so, it then started listing the previously played music using “just now” instead of using a time reference. I reinstalled the Mac remote, but it engages in the same behaviour. Stuff I played lat night or the day before is listed in the right sequence, but is listed as “just now”.

I went to the ipad to check if this was happening to the same items, as I thought the items on the ipad were from that now delated xmas play list. Now, whereas in my earlier response I said the ipad remote was working fine… now it has gone blank, with no history being recorded at all.

Hi @Anthony_Langlois ----- Thank you for the follow up and trying the proposed test, both are appreciated. I touched base with one of my developers today to discuss this issue and get some feedback as to what ay be causing you to experience this behavior.

Before we go ahead and collect some logs, I would like to gather a bit more information from you as per my discussion this afternoon.

  1. Can you please provide screenshots which display this issue you have been experiencing.

  2. Can you verify if at any point your DB was migrated or restored from a backup?

  3. Are there any patterns in behavior here or steps you can provide to us so we may try to replicate this in house?


Hi @Eric

I’ll attach a couple of screen shots. One from my MacBookPro, which is currently showing no history at all, but indicates 5656 plays. I’ll also attach to shots from my ipad. One shows the top of the history list (which a different number for the number of plays - this may be a clue??); the other shows the point where it transitions from all the “just now” items which were in fact not played just now, to the items which were played a few minutes ago.

The “just now” items are no longer from that xmas playlist that I deleted, but from subsequent listening sessions. It seems that there may be a problem with updating the history list between remotes (and the core?), or perhaps some sort of sync conflict depending on which remote is being used, that then ends up with a time-confused set of records which are labeled “just now”…??? I have no idea really! :slight_smile:

I doubt this has any relevance, but I have noticed that when I turn my VPN on when Roon is playing, it stops (I have to then hit lay again and it continues from the point it left off). This, despite the VPN being only on the MacBookPro remote. Mention it just in case…

When I set Roon up on the sonic transporter, I think I just started again from scratch (not having invested much time in playlists or history or tagging in roon at that point). I think… not 100% sure. It has not been subsequently restored from a backup etc.

Beyond what I have said above, I have not noticed any specific steps which could be used to try and replicate the behaviour.


While I wrote the above, and in the hour or so since, I have been listening to music via Roon. I just picked up the iPad remote to see where I was up to on the album playing, and noticed that in history it was accurately recording the last few tracks (track x, so and so minutes ago), although the “just now” listings were following on from the the last couple of hours of listening (I suppose, the two or so albums I’ve had play in this session).

Then, however, the album finished and the queue came to an end, with golden silence, and suddenly the history went empty. There was nothing listed at all.

That situation persisted for a few minutes, but now when I return to the history it has my last session of listening logged correctly, before going on to the “just now” list, comprised of albums from some days ago, before picking up the history list correctly again at the 2nd most recent album I played and back to last night, etc.

On the MacBook Pro at the moment, there is nothing showing at all under the history list. It still says 5656 plays. The iPad is saying 5810 plays. Edit - I then log out and back in on the MacBook pro and it brings me to the same as what I get on the iPad, with the same play count too. My last two albums are listed correctly, and then it goes off to the “just now” list, before returning to the album from one hour ago and back to last night etc.

Hi @Anthony_Langlois ----- Thank you for the screenshots and your continued feedback! Both are greatly appreciated.

Moving forward, I would like to grab some logs from you but first I would like to have you please provide me the following information so I have a complete report for my developers:

  1. Please provide a brief but accurate description of your setup as seen here. The more detail you can provide, the better.


Sorry for delay. Will try to get this to you tomorrow.

Hi @Anthony_Langlois ----- Not a worry :wink: I will be on the look out for your feedback, thank you for the follow up!


Hi @Eric

Setup: Please see the following screen shot of Roon Details.
More generally, I have the Roon Core running on a sonic transporter from little green computers. That is attached to router and Synology NAS, which stores the bulk of the music in watched folders. There are also watched folders on two MacBook pros. The two macbook pros, two iPads and an iPhone all have Roon as remote controllers.

The Roon Server sends Roon by wifi to an older Macbook pro which runs Roon bridge and is attached to my NAD M51 by USB. This then feeds a NAD power amp and floor standing Jamo C809 speakers

The MacBook Pro and Ipad remotes on which the reported

problem appears are both running the most up to date Mac OS and IOS.

Roon has 9760 Albums and 89142 tracks.

The problem as reported persists.

Hi @Anthony_Langlois ----- Thank you for the follow up and taking the time to answer my questions.

Just to verify, can you please confirm that all the clocks across your devices are set to the same date and time? Items being played/queued from devices are clocked in Roon based off of this information.


Yes, can verify that. The only device which wasn’t was the router, which has now been rectified. Changing the time on the router does not seem to have had any affect on the problem. :slight_smile:

Hi @Anthony_Langlois ----- Thank you for the follow up and verifying that information for me.

Before I grab some logs from you, and my apologies for not mentioning this in my last update :dizzy_face: Can you verify that your SonicTransporter (RoonCore) has the same date and time set as your other device as well.


Hi Eric. I already checked the time zone. I don’t see any way of more specifically checking or setting the date. Can you advise?

Hi @Anthony_Langlois ---- Thank you for the follow up and my apologies for the slow response here.

In regard to confirming the date / time on the SonicTransporter…

  1. Update the device using the following:

sonicorbiter.com -> manage -> apps -> software manager -> update

  1. Once the update has been completed please find the RS diagnostics page:

sonicorbiter.com -> manage -> apps -> Roon Server -> Roon Server Diagnostic

  1. At the top of the page there will be a date field which will look like this:

Date and time on server: Mon Jan 30 19:58:27 EST 2017


thanks. SO, we are all good. All on the same time and date.

Hi @Anthony_Langlois ---- Thank you for following up and confirming that for me. My apologies for the slow response here.

Has 1.3 improved any of this behavior for you or are you still experiencing this issue with “history”? If you are, I would like to collect some logs from you.


Hi @Eric. 1.3 is great! But no, it had not resolved the issues, which persist.