How do I run HQ Player when I have a Sonore UltraRendu?

Hey all,

Maybe I’m overthinking it but …

I’m currently running a SonicTransporter i5 with HQPlayer embedded and then a Sonore UltraRendu. Things are great, but I recently upgraded to a new PC with an i9 9900k and a 2070 Super.

I want to take advantage of DSD 512 etc. This would require me to use it over my SonicTransporter i5. That’s where my question comes in.

How do I run HQP through my new computer while still using the UltraRendu?

Basically I’m trying to replace my SonicTransporter with my new computer but want to keep Roon and my Ultrarendu in my chain.

Any help is appreciated!

To add on,

Currently my sonictransporter is being used as my Core. My two outputs in Roon are Ultrarendu playing lossless and then my HQPlayer Desktop playing my DSD 512. So my HQplayer desktop output is connected by USB from my computer.

Is there no way to run HQPlayer desktop so that it is ran through the network to my Ultrarendu?

Im just trying to allow my Computer to handle HQplayer rather than my sonictransporter, while leaving my sonictransporter as my Core.

Is this possible or am i stuck using HQplayer embedded as my only option to run HQPlayer isolated?

You can readily run HQP on your new computer, continue using your ST as Roon Core and output via network to the ultraRendu.

First, make an HQ Player Zone in Roon for your new PC (you may have already done so). Remember to click the Network Control icon (last icon on right in HQP desktop icon bar) so HQ Player turns on the software to receive Roon commands via network.

Next, close HQ Player and go to the SonicIrbitor software in the ultraRendu and update it to latest version. You can access the software by browsing to and selecting to manage the ultraRendu. Once updated and restarted, select the NAA app, rather than Roon Ready.

Provided everything is on the same network, when you restart HQ Player you should be able to go to HQP/Settings and select NAA in Backend and the ultraRendu in Device.

The only problem with the above is that the NAA is not a Roon Zone, so can’t be grouped in Roon.

Hey, thank you for your response and guidance.

Unfortunately, I did everything you said but when I go into HQPlayer to change my backend to NetworkAudioAdapter, the Device is blank.

When I added HQPlayer to Roon, it asked me to input the IP of HQPlayer or to leave it on the localhost.

First i tried leaving it on localhost but it still didnt work. Then i went into command prompt to grab my ipv4 address and i used that. It still didn’t populate an option under Device in HQPlayer Desktop.

My Sonic Orbiter is 2.7 and I switched to HQPlayer NAA under the Audio App Switcher setting.

The sonic transporter, ultrarendu, and my new computer are all connected to the same router/modem. i verified this through my network management.

Any other ideas?

There are two network hops. First is between Roon and HQPlayer and that’s where you configure HQPlayer’s address, depending whether they are on the same (localhost) or different host (IP address).

Second is connection between HQPlayer and NAA. This is something where the available DACs show up on HQPlayer device list, when network audio backend is selected.

When you are selecting device on HQPlayer side, your DAC must be available to the NAA. It is important to ensure DAC is powered up and correct input is selected in the DAC when booting up NAA and selecting the device at HQPlayer side.

If the NAA + DAC combination doesn’t show up on the list, check that you don’t have software firewall on HQPlayer computer blocking the communication. And that there are no additional extra network interfaces enabled in the OS (otherwise multicast packets may end up routed to wrong network interface).

1 Like

Localhost is a networking shortcut that is used when HQ Player and Roon Core are on the one machine. It enables the programs to communicate directly, rather than through the router.

The IP address you want is that of the new PC where HQ Player Desktop is running, not the SonicTransport Roon Core. More details here.


So I started off my restarting my computer, then i restarted ultrarendu and sonic transporter. Then i disabled all of my firewalls.

I opened Roon. Added HQPlayer in Roon settings. I used my ipv4 address from command prompt.

I opened Hqplayer 4 desktop. I clicked the network icon in the top right of the toolbar.

I went to my ultrarendu settings and checked the DAC diagnostics to make sure the ultrarendu was picking up the dac. Its the mytek brooklyn DAC.

Then i went to Ultrarendu apps, then App switcher, and set it to HQPlayer NAA. It got a green check mark.

I reopened HQplayer DEsktop and went to settings. Im able to select NetworkAudioAdapter under backend, but the Device is blank.

The only network i have on my windows 10 is the ethernet port.

All network devices. (ultra rendu, sonic transporter, computer) are connected to my ethernet switch and all show up as wired connection in my netgear settings. then i have my iphone and smart tv connected wirelessly.

that is all on my network. I believe i understand now how its supposed to be connected but as far as i can tell i did everything right.

is there any screenshots that would show some important info thats maybe skipping by me?

I really want to get desktop hqplayer working because i dont want to use the embedded version in my sonic transporter anymore.

Use the IP address of your new PC as shown in the router.

Does Roon show an HQ Player Zone on your new PC ?

If so, shut everything down and then start it up again, starting HQ Player last of all. It should find your NAA.

Also with IPv6 backend (backwards compatible with IPv4)? In Windows Control Panel -> Network and Sharing Center -> Change adapter settings, you have only one network adapter listed? And Windows shows the network as Private network?

Yes, I used the ip address ipv4 as shown from my router. Roon does show up as an HqPlayer Zone and it is correlated to my ipv4 address.

Yes both normal NAA and NAA ipv6 backends show up blank in hqplayer desktop.

The networks i have available in my netowork and sharing center are my Ethernet 1 and Ethernet 2 and my Virtualbox Host network.

Wait!!! As im writing this i fixed it! I disabled my virtualbox host network and my mytek brooklyn shows up now!

Thank you both for the help!

1 Like

4 posts were split to a new topic: No Sound in HQPlayer zone