How to install Roon Server, sh file in Ubuntu?

Core Machine
Ubuntu 18.04.

Network Details
WIFI Dlink dwa 182

Description of Issue
I don’t know how to execute the installation command for the roon server executable file .sh. Is there a step by step instruction somewhere?
I managed to install the drivers following step by step instructions.

After the Roon server is installed I plan to use Bryston Pi on the network.
Executing an installation command in Terminal is the issue.

Roon Knowledge Base - LinuxInstall:

The Easy Installer (Recommended)

The easy installer is a simple way to install Roon Server or Roon Bridge on Linux with our recommended settings. The installer will identify missing dependencies and/or compatibility issues before attempting to install the package. If you run into compatibility issues, see the Dependencies section above.

Our recommended settings are:

  • Installation in /opt/RoonBridge or /opt/RoonServer
  • Data is stored in /var/roon/RoonBridge or /var/roon/RoonServer
  • The app will run as root
  • The app is launched immediately, and will relaunch automatically at boot.

We’ve tested this installer on several recent distributions including:

  • Arch (current)
  • Fedora 23
  • Ubuntu 15.10

If it works well on other systems, please let us know so we can add them to the list.

Roon Server x86_64

$ curl -O
$ chmod +x
$ sudo ./


Log File Location.

If you used the easy installer , log files can be found in /var/roon/RoonServer/Logs , /var/roon/RAATServer/Logs , and /var/roon/RoonBridge/Logs .


You can reverse the steps of the easy installer by running it with ‘uninstall’ as a command line parameter. For example:

$ sudo ./ uninstall


Configuring Roon Server or Roon Bridge to run at boot

Our easy installers do this for you. If you are curious about how to do this by hand, feel free to poke around in the scripts–the information is in there.

Otherwise, follow your distribution’s instructions, keeping in mind that is a long-running script that you will need to start + terminate at the appropriate times.

1 Like

Followed the instructions, but getting this error massage:

Unable to locate alsa packages even though the apt update executed successfully.

In current ubuntu the package is not called alsa-lib. try:

sudo apt install libasound2

Also, I love this idea of an “error massage.” What a great way to make recalcitrant computers easier to cope with. :slight_smile:

Hi David,

Hope those new error message will help again:

sudo apt install curl

When I tried this command with “-0” such as:
sudo apt install curl -0

I got message "dont understand -0 option.

when I tried just curl command I got suggested “apt install curl”


P.S all the other steps preceding steps as per instructions were successful

# You need to install curl before you can use it
sudo apt install curl
# Now you should be able to use it
curl -O

The roon is installed, now I am trying to install the Wine GUI interface.
I cant get the i386 architecture installed. Tried all the commands I could find in the forums to no avail.

Have you already seen this thread (and followed it to the end for latest update)?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.