How to run Roon 1.8 Legacy on Nucleus?

I was busy yesterday so missed the “Big Leap Backwards” information. Thus my iOS devices upgraded overnight. But Roon on my Nucleus is still 1.8. I’ve installed the Legacy 1.8 remote on one iPad but it still doesn’t connect. See photo

Looking at this forum, it seems like 2.0 isn’t ready to be released. And I don’t need to play Roon elsewhere.

Add im


What is my next step to return to 1.8? Thanks ![IMG_0786|666x500](upload://ziQ9e8pSUuSV9lbQgkpkkutmXTJ.jpeg)

Basically your core is on a stable production release. You need to change/downgrade to 1.8 legacy.

I don’t think this is what I’m after. Core is 1.8. Remote is 1.8. But they don’t see each other.
I presume I’m missing some kind of subtlety.
Do I need to reboot something?

I believe your Nucleus needs to be 1.8 LEGACY now going by what the guide says. From your screenshot it’s 1.8 stable. If you want to stay on 1.8 they all need to be on the legacy version and, not on the 1.8 stable release version.

Surely not. I never asked for this update. I just want to be where I was last night.
Can I not load Roon Remote 1.8 (not legacy) and all will be well?
There must be a fiddle.
I’m dealing with a bereavement and just don’t have time to play around for hours.
But music would be very welcome right now. Somehow someone in Roon has made it impossible for me to play music.

Could I politely suggest you roll everybody back to 1.8
Then send out a message about 2.0 with a week’s notice so that we can all switch off updates, upgrade OS etc.
This has seemingly done without any thought or planning.

It seems that Apple and their auto app update has caused you this problem. Not Roon. Simply disabling auto app updates would be wise for all software/app to avoid situations like these.

I’m sorry you’ve got this going on now with everything that is happening. But, Roon did communicate and there are posts and guides in the FAQ.

Others have had the same issue and they have fixed it by downloading the legacy version.
See here:

Take some time out and come back to this when you’re ready. And, remember to the the guide!!

Please try rebooting your NUC. It worked for me and others.

Now the nucleus sorts of flickers on the remote.
I give up. I’ll upgrade to 2.0
How do I upgrade the Nucleus given that I can’t access it from my remote?

I’ve gone to web access, but that doesn’t give me the option to upgrade to 2.0.

I was talking to others in posts about the 1.8 issue on Macs 10.14 or earlier. I downloaded the Roon Core 1.8 Legacy build 1126 app. I first installed the Legacy 1.8 iOS app on my iPhone and iPad. Then I closed out of Roon on my iMac core. Installed Legacy 1.8. Only took about 2 minutes to fully open. Worked OK and my remotes with Legacy 1.8 app connected. Seems like all OK. But Wow, Roon could have done a much better job communicating on this situation. Hope this helps.

1 Like