[How To] Securely access Roon Core with Fritzbox

Roon Core Machine

  • MacBook Pro 14 inch from 2021
  • Apple M1 Pro
  • 16 GB
  • MacOS Monterey

Networking Gear & Setup Details

  • Fritzbox 7590 AX
  • WiFi
  • No VPN

Connected Audio Devices

  • none when error occurs

Number of Tracks in Library

  • 1758 albums

Description of Issue

I try to connect to Roon ARC. Within the Roon 2.0 program on my mac, it gives the following error message: “Roon ARC was unable to securely access your Roon Core”.

According to the Roon Troubelshooting button I checked if upnp is activated in my FritzBox. It is, as far as I can see.

Here is a copy from the diagnostics data if that helps:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“x.x.x.x”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<?xml version=\"1.0\"?>\n <s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“>\n<s:Body>\n<s:Fault>\ns:Client\nUPnPError\n\n<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">\n403\nNot available Action\n\n\n</s:Fault>\n</s:Body>\n</s:Envelope>”}

What is your ISP? As it’s often an ISP problem

1 Like

It looks from the diagnostics that upnp is not active. You can also see that your actual external ip address is found but not the internal one. I had this problem when I deactivated upnp and didn’t have the port forwarded manually.

Bear in mind that you might solve this internally only to find that your ISP uses CGNAT and you won’t be able to connect anyway, but in the meantime make sure you have upnp activated and maybe reboot the router and wait for it to connect before trying again.

1 Like

Thanks for the response, dear Andy.

This topic of upnp and the router settings is completely new to me, so I dont really understand much. I have also never heard of CGNAT (but tried to google it just now).

I feel as if I lack so much knowledge, I dont know how to follow your advices.

Thanks for your response. It is German. Would it help in any way if I post the name? Or are you refering to something else?

It is quite complicated to understand in the beginning. If you are based in an english speaking country there may be other terms but I would search something like CGNAT community fibre, where community fibre is the name of my Internet Service Provider or ISP. It is very likely that you would find someone talking about that supplier and CGNAT if they use it. CGNAT stands for Carrier Grade NAT, you might have more success searching for that.

Essentially it’s a way of sharing addresses on the internet which ISP’s have adopted to save money (and addresses which are numerically limited).

If you can establish whether your ISP is using CGNAT you can save yourself looking for any other problems in your setup.

upnp can be enabled for just one host in a fritzbox
see the checkmark

Cheers, Bob

1 Like

Yes the name please :slight_smile: Vodafone by any chance?

1 Like

It is Telekom :slight_smile:

Hi Bob, thanks for your input! How do I get the ROCK to show up? I really lack the basic knowledge on how this works…

Ok, then you may have a chance :slight_smile:

As Andy has said above, it looks in the error message that the UPnP on the router is not enabled. You would have to enable this (and as Bob wrote, this can be done per device in the Fritzbox) or configure port forwarding manually on the router:

It may or may not work after this. If not, there will be a new error on the ARC tab in the Roon Remote. Post this one, too. It’s possible that you may have to call Telekom and ask them to enable an IPv4 address for you that is suitable for port forwarding. But let’s try and see


Once again, thanks for taking the time. I am using Telekom in Germany and tried to google to provide an answer to your proposal. I am not too sure though, what the answer might be.

I know its not super helpful when I post a German screenshot, but I have deactivated, saved, reactivated, safed the following setting "Statusinformationen über UPnP übertragen:

It would translate into something like this:

“transfer status information via IPnP”

However, I still get an error message in Roon.

Would you say that is the setting you are refering to?

Hi Snow,

not sure what you mean, my NUC running ROCK had DHCP enabled and shows up in the list under network devices when booted. Your machine could have another name but that is just guessing.

So, when you add a port forward, fist pull down gives you the known hostnames and you have to chose the name running Roon.
Then you can enable the option for UPNP just for that host.

or leave it disabled and copy the port number from the Roon/settings/Roon ARC page

Cheers, Bob

so, only these options, wrong device name here because my rock already has a port forward and is not visible then anymore

Cheers, Bob

1 Like

It’s fine for me, I am Austrian and living in Berlin :slight_smile: But the screenshot you posted is not it. This Fritzbox help page explains how to enable port forwarding (Portfreigaben in German) automatically with UPnP or manually by entering the port number (which you get in the ARC tab in the Roon Remote):

After this, the ARC tab in the Remote may show that it is working, or it may show another, different error. If there is an error, copy and paste the error message again


Wonderful, that solved it :slight_smile: Thanks so much to you and all the others of this great community.

I am now listening with Roon ARC for the first time. Really cool.

I am living in Berlin as well by the way :smiley:

1 Like

Great, enjoy! Greetings from Stralau :slight_smile:

1 Like

Right back from Neukölln :slight_smile:

1 Like

I can nearly see you :wink: My speaker builder is in Neukölln, highly recommended if you ever need new ones