HQP, uR, i7 8700. DSD 512 ...the long and winding road

For those of you who haven’t been paying attention…

I purchased a Dell 17 8700 with CUDA suitable graphics card primarily for DSD512.

I previously was experiencing pops with Roon up sampling to DSD512

Initially I could upsample to DSD512 with HQPlayer in all but the extreme where I had to use the -2s.Strangely with Roon i still had clicking so as I now knew this wasn’t the PC so I re-read the previous post I updated my ultraRendu and it brought me to the latest version of the sdk which solved the problem, (I hadn’t realised that one could update the Rendu even when it said you were on current firmware.)

I had settled on Roon as my main up sampler but got itchy feet to try out some more of HQP’s filters. This time however the clicking is evident in HQP upsampling. It’s for all intensive purposes like clicks on vinyl playback, only noticeable in quieter passages.

The only things I have changed (AFAIK) were I updated the ultraRendu to 2.6 which updated the NAA?

Roon and HQP are on the same machine >Singxer SU >HoloSpring DAC.

Issue doesn’t occur with DSD256 in HQP and the clicks will not occur in the same places if one repeats a track.

Any Ideas?


What if you shut down Roon and try it with HQPlayer only?

I’m presuming that if Roon can send a stream successfully for 256 upsampling the issue is not with Roon.


That’s not the purpose of my suggestion. Reducing load and logically working backwards to find the problem point.

First thing I’d do is restart everything, including DAC, and increase headroom in HQP. I run with -7 to -9 dB with upsampling and convolution.

I did the full restart alright (I am paying attention!) , when you say increase headroom in HQP what exact setting are you referring to?



Max Volume.

I have that set to -7dB.



The volume control. I set min to -16 and max to 0 and use -8 which is in the middle.

What buffer size are using? Can’t remember if that’s configurable in the NAA as well?

default at the moment but did try 100 and 250ms with no effect on the issue.


Multicore full check mark or set to auto? Try it with cuda off and on?


Havn’t tried CUDA off and On as things were fine only a month ago with the same settings.

I suppose from my experience with Roon it was a firmware update that seemed to sort the issue. @jussi_laako could the latest NAA or @Jesus_Rodriguez SO 2.6 be implicated?


Try multi core set to auto, gray box instead of check mark. Try with cuda off.

Windows updates? They could have installed a new nvidia driver.

Jeff I appreciate your help but rather than just ticking and unticking every available option I’d like a reason proffered for why this might make a difference?

At least this was what I was going to write but sat down again, put on the reference track for all my clicking troubles


it seemed the issue had been resolved by the greying of the multicore DSP -when I realised I had the settings still at 256 DSD.

However when I reset things to 512 there were no clicks. I tried the second main culprit


there was also a distinct lack of clicking.

Hopefully this is not just a man momentary lapse.

Any ideas why this fade to grey with multicore DSP would impact though?


1 Like

I understand the grey option is an “auto” setting that enables multicore capability where it is detected rather than assuming multicore capability. On its face this shouldn’t have any impact on audio artefacts, yet here we are.

People using the same software and hardware sometimes seem to have different outcomes from the same settings. Brian mentioned in the other thread that the Holo Spring is sensitive to buffer discontinuities and it may be that somewhere in the passage of the signal between HQP, the uR, Singxer SU and the Spring that something was misaligning. Maybe Jussi or Brian could track it down but to the rest of us it’s not much more scientific than banging the side of the box to fix a loose connection. All we can do is bang in different places and check the results.

Someone on the forum once told the story of a user who went to a software developer and asked him to add a feature exactly replicating a bug that he was experiencing - can’t be done he was advised.

I was about to suggest checking if there was any difference between 48k multiple source or output and 44.1k material because my Spring has a problem with 512 DSD and 48k. If I use the multisync filters and set HQP to the 44.1 multiple output everything works fine.

It really shouldn’t be as complex as it all is. Reminds me of a Heath Robinson machine at times. But now that it’s working properly, for gods sakes don’t breathe on it !

Edit: If you are using the I2C HDMI output from the Singxer SU into the Spring then as short a cable as possible is best. The l2C protocol was designed for internal connections rather than longer external cable lengths.

1 Like

I’m not much for sitting still when encountering an anomoly, I start trying things knowing what my baseline is.

I’m not sure but the auto might have a little more intelligence to how it uses the cores in relation to Cuda as Jussi usually recommends it. I’ve had it fix weirdness for me in the past.

1 Like

I have it set to 512 44.1, unworkable at 48.

There is something akin to manic or voodoo about all this really isn’t there?


1 Like

Best way to figure out is usually connect the DAC locally to remove NAA from the picture and see if it makes a difference.

If you don’t have “Limited” counter incrementing from 0 in HQPlayer, then any clicking is likely not overload issue. But instead some transfer glitch somewhere. I have not heard such in relation to Rendus, but typically RaspberryPi’s at hires are plagued by such…

Regarding CUDA, depending on GPU model and other applications performing graphical tasks, such activity can cause processing delays because the GPU is “multitasking”. Newer Nvidia GPU models have improved on multitasking a lot so they are less likely to have problems. There are also other aspects, like amount of PCIe bus traffic to the GPU and to the network interface and whether they share same PCIe lanes or not. So lot of complicated hardware details… (socket 1151 CPUs typically have 16 PCIe lanes, while socket 2011-v3 CPUs can have for example 40 PCIe lanes, GPUs use 16 lanes alone)

@jussi_laako I’m still getting the pop and click issue on quiet music and have been following a thread here and another on CA with a similar issue with HQP embedded. There seemed to be an update to the HQP embedded (4.1.1) that allowed play without clicks with all but the 512 modulator. Has the desktop version got this same update?

If the update is due in the desktop I won’t start testing various other combinations or removing the NAA.