Upsampling to DSD512 in Roon - where is my clicking issue coming from?

I am currently upsampling to DSD256, utilise the parallelise sigma-delta monitor and all is good and the processing speed hovers around 2.

When I try 512 DSD I get intermittent clicks very like vinyl pops and clicks and the processing speed is hovers around 1.4.

Intel Nuc

to ultra Rendu

to Holo spring DAC (2.0 firmware).

Does anyone know where the issue with DSD512 is emanating from?



I’m pretty sure it’s Roon, DSD512 is too much for your machine by your 1.4x number.

You could try increasing the playback buffer on the ultraRendu just to see what happens.

I would have thought that would give drop outs similar to when HQP overextends the NUC?

Could @support confirm if this clicking could be resource related?


Hi John,

The KB DSP page has a CPU usage section which states that 1.3 is about as close to peril as you want to get, so 1.4 should be OK.

Have you upgraded SonicOrbiter in the ultraRendu to pick up any new version of Roon Ready ?

The Spring is a bit notorious for making sporadic odd noises. I found that playing with the buffering timing in Roon (try both higher and lower values than default) and rebooting the microRendu (in my case) and the Spring (leaving it off for 10s between turning it on again) helped make pops go away.

In addition to buffer tuning, you may also try headroom management and see if it makes any difference.

1 Like

The HOLO spring can be picky about buffer sizes when the sample rate is turned up to the maximum. These clicks (in my experience) are not dropouts from Roon’s perspective–we are delivering audio to the driver in time, but it isn’t always making it into the device cleanly.

I have usually been able to make it stable by tuning buffer sizes. More experience with this on Linux than Windows, but it is probably the same stuff.

Other HOLO Spring owners who have spent more time with it may have more specific settings in mind, but I would try the “Use Max Buffer Size” option in Roon first. There may be more buffer size options in the HOLO Spring’s ASIO control panel, too.

I have a feeling I might be doing something silly but can’t seem to find any option on buffer size. I’m looking at the device setup screen?


Not silly on your part, I think I’ve confused things by referring to a buffer in HQP.

When I swap the mR to Roon Ready then in Device Manager I set General/Resync Delay to 100ms and Playback/Max Bits per Sample to 24 (this shouldn’t affect DSD ) and Max DSD to 512. In the DSD Engine I give Headroom between -6 and -9 dB (depending on whether I’m convolving also) when upsampling to DSD512.