HQPlayer Desktop thread

Hi @jussi_laako ,
the new version of hqplayer4client crashes on ubuntu 22.04.

Qt WebEngine resources not found at /share/qt6/resources. Trying parent directory...
Qt WebEngine resources not found at /share/qt6. Trying application directory...
Qt WebEngine resources not found at /usr/bin. Trying fallback directory... The application MAY NOT work.
Path override failed for key base::DIR_QT_LIBRARY_DATA and path '/home/$USER/.HQPlayerClient'
Installed Qt WebEngine locales directory not found at location /share/qt6/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /usr/bin/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
Path override failed for key ui::DIR_LOCALES and path '/home/$USER/.HQPlayerClient'
[1115/075003.371623:ERROR:resource_bundle.cc(911)] Failed to load /home/$USER/.HQPlayerClient/qtwebengine_resources_100p.pak
Some features may not be available.
[1115/075003.371670:ERROR:resource_bundle.cc(911)] Failed to load /home/$USER/.HQPlayerClient/qtwebengine_resources_200p.pak
Some features may not be available.
[1115/075003.371680:ERROR:resource_bundle.cc(911)] Failed to load /home/$USER/.HQPlayerClient/qtwebengine_resources.pak
Some features may not be available.
[1115/075003.371699:WARNING:resource_bundle_qt.cpp(119)] locale_file_path.empty() for locale
QQmlEngine::setContextForObject(): Object already has a QQmlContext
[9651:9651:1115/075003.497934:ERROR:extension_system_qt.cpp(121)] Failed to parse extension manifest.
Segmentation fault (core dumped)

ii  hqplayer4desktop                          4.20.0-97                               amd64        Signalyst HQPlayer 4 Desktop

See here:

The main instruction to fix it is:

  Do "sudo ln -s /usr/share /share" and then it should start just fine.

So Good!
Many thanks! Works perfectly!


Highly recommend:

I would estimate 30% performance improvement as I was not able to use Sinc-M with 7ECv2 filters @512x48

On previous version of HQplayer I was already able to use 7ECv2 @512x48 with poly-sinc-hires-lp (better than running Windows 10 now same machine using Ubuntu)

Ubuntu with DeskMini B660 intel i71200K /16GB RAM/250SSD dedicated Hqplayer DSD512 + noctuna fan.

Genius! So F@$# good!! Sinc-M 7ECv2 @512x48
CPU is fresh!! Not hot alt all!


First post on this forum. I’m having trouble with HQPlayer 4.20.0: every time I try to launch it, the program freezes my computer briefly before crashing. I have no chance to interact with the program. Version 4.19.3 works flawlessly.

System specs
OS: Windows 11 Home x64 (updated with Windows Update to version 10.0.22621)
CPU: Ryzen 7 3700X
GPU: Nvidia GeForce GTX 1070

Troubleshooting steps:

  1. Update Windows and all hardware drivers through Windows Update, Nvidia GeForce Experience, Microsoft Store, and so on.
  2. Update Windows Visual C++ Redistributable files (from the official website).
  3. Verify installation files by running DISM and sfc /scannow (following these steps) until no errors are found.

The Windows Event Viewer says the crash is caused by ucrtbase.dll, a Windows system component. Between updating Windows and scanning the file system, there is no reason for me to believe that the DLL is defective (especially since HQP 4.19.3 works fine). The last few lines of the HQP debug log are as follows:

2022/11/14 14:10:39 Volume min: -60
2022/11/14 14:10:39 PCM gain compensation: 1 (0 dB)
2022/11/14 14:10:39 Set volume: -60 +
2022/11/14 14:10:39 Automatic rate family enabled
2022/11/14 14:10:39 Full pause processing

I emailed the dev for support, but Jussi is “not sure what else could be the problem” (which is fair; I have a history of weird computer problems). Does anyone here have suggestions for further troubleshooting? In the meantime, I’ll keep using 4.19.3.

I figured it out with help from Jussi on another thread. Uninstalling HQPlayer through the Control Panel and then deleting the folder C:\Users%USERNAME%\AppData\Local\HQPlayer before installing HQPlayer 4.20.0 was the solution.


Finally I am also a full regsitered HQPlayer user. Like it a lot! :smile:

Quick question/suggestion.
How about introducing a storage option for a subset off filters, instead of allways changing 4-5 parameters for SDM and 4-5 for PCM, so that one can easily switch between different setting e.g. for different DACs. Really, really great would it be to be able to switch between these settings from within Roon, but I am not sure if this is technically feasible. As I am using a headless MAC Mini M1 for the Roon core and HQPlayer, it is always a bit of a hassle to change settings, by using VNC Viewer.


Technically, Roon could do that. But they have not implemented it.

What are you using for controlling Roon?

1 Like

I am using an ipad usually.

I believe you could switch the filters using HQPDcontrol app.

1 Like

Thanks, will check it out. :slight_smile:

Hi guys,
I have tried to setup HQPDcontrol app but unfortunately with little success.

They app won‘t connect to the HQPlayer.
I entered the IP address of my Mac Mini and I started to stream music via HQPalyer to my DAC. When I open the app this power cable plug symbol should switch from red to green, but is stays red.
I know net failure analysis is always difficult remotely but maybe you guys here can give me hint in the right direction? :slight_smile:

First thing to check is that you have the “Allow network control” button pressed in the toolbar. It is the right-most button in the toolbar.

1 Like

That was easy. :rofl:

Seriously, many thanks. :beers:

1 Like

Hi! Just updated the last HQplayer 4.20.2 avax Unbuntu version and before and after I still have an issue that it switches to PCM, although I selected SDM before.

NAA last version

DAC ifi Neo iDSD

I have enabled 48x512 as always, even if I select 512dsd same problem, it switches to PCM settings

On my HQplayer on Mac OS, no problem

Any suggestions?

The only thing that change is I moved to a new place and connected all back as before

Many thanks

I don’t believe it would make it switch to PCM, but in addition to selecting a 48k rate, make sure 48k DSD is checked off.

Also make sure Default Output Mode is SDM (DSD).

If you’re using using HQPDcontrol, remember that the changes it makes are not permanent. The settings will reset to whatever is shown in hqplayer if you restart the hqplayer app or directly access the settings from from hqplayer.

You have to make changes you want to stick directly in the hqplayer app.

1 Like

Hi @ffk thanks for tip, I also tried it but no success, I had this settings before without any problem, trying to find what’s causing the problem. Source is correct, I even press the stop :stop_sign: button and I see it. But when I play it switch to PCM

Output is to NEO, not Accuphase DAC?

Is this with NAA OS running on something? Or what is the NAA in this case?

1 Like

Output to NEO using miniPC as NAA, booting from NAA software on USB card using naa-425-x64ramfs.img

1 Like

Did you disable all audio sources in Roon except for HQP?

I had that problem for a minute before I realized that.

1 Like

The app doesn’t allow the SDM options also