HQPlayer OS Raspberry PI USB Input

Hi I hoping someone can help me. Up until now Ive been using HQP on a Ubuntu server with Roon core and a Mutec MC-1.2 USB interface that allows me to connect my CD Transport. On the Ubuntu version of HQP you can select Mutec MC1.2 under the input selection. I want to move my HQP OS to a raspberry pi 4, but there is no input selection for Mutec MC1.2, nor is there as far as I can see an accessible hqplayerd.xml file to add the Mutec. How can I add USB input devices to the Raspberry Pi version of HQP OS.

btw I’m using this with HQP NAA that is built into my Gustard R26 dac

1 Like

Does the server portion run on a Pi, I thought only the endpoint software ran on it.

HQP OS has been running on RPi4 for a long time now. Obviously limits to what it can do.

Jussi’s testing of RPi5 show much more capability but you need seriously good cooling to get the best of it.

Yes there is an image specifically for Pi4 not for Pi5 yet but people have installed everything manually. I am only using PCM so the Pi5 will be sufficient. On the x86 Linux version there is a file called hqplayerd.xml which you can edit for inputs etc. on the Pi version there is a config file but shows nothing to do with inputs. Hoping someone may have an idea

Thanks

The same hqplayerd.xml is there on the RPi4 HQP OS

Have you tried the same command?

nano /etc/hqplayer/hqplayerd.xml

Ok So now I see, if there is a hqplayerd.xml file under /etc/hqplayer I can’t see it as I’m viewing it with the SD card in my laptop and I don’t have root privilege. I’m gonna have to enable ssh so I need to add a user and password. But I have to find a mini hdmi adapter to connect to monitor. TY! Lets see how I get on.

OK I managed to edit the hqplayerd.xml file and add Mutec MC-1.2 to the inputs list. But now I can’t access the webpage. I’m guessing it doesn’t like what I added. Is an input on the x86 version the same as raspberry pi. This is what I added.

<input channels=“2” device=“hw:CARD=M20,DEV=0” name=“Mutec MC-1.2 @44.1k” nperiods=“4” period_time=“100” samplerate=“4100”

Did you forget the end > to close the line

and webpage is IP:8088

2 Likes

For this case with RPi4 input, using HifiBerry Digi+ I/O is better option. HifiBerry also sells a nice steel case for this combination.

On the side, you also gain USB audio input if you use HQPlayer OS or NAA OS.

1 Like

OK You were correct I did forget to close >. I added that but I still can’t access webpage. I will have to try again tomorrow I have to work early tomorrow morning. If you or anyone has anymore ideas I will try again… TY and very grateful for your help.

1 Like

Hi Thank you for your reply. At the moment I only have an old Denon broadcast transport with AES. So with that HifiBerry board I can directly connect a CD Transport to HQPlayer OS on a raspberry pi with either Toslink or Coax? Can I still up sample PCM to 76800KHz?

For AES, you’d need a media converter to coaxial/optical S/PDIF. There are many such devices on the market.

Thank you for your help. I bought the hifiberry hat and a used Bel Canto cd3t transport which has s/pdif and should be much higher quality. I was planning to upgrade but didn’t want to till I knew which route I was going to take. I was wondering though is it suggested to use the NAA built into my dac or ALSA usb output from the raspberry pi?

I’m interested in this configuration, does NAA work “out of the box” with spdif input or some changes are needed? … the idea is to use NAA/rpi4/digi+ i/o for spdif input only (not usb input)
Thanks

Does adding the right overlay to the config.txt file

dtoverlay=hifiberry-digi-pro

make the trick?

I don’t think the network implementation in your DAC supports NAA protocol, so that’s not an option unless they add such support.

Only thing you need is to add two lines to config.txt, rest is out of the box.

That overlay is output only, for the Digi+ I/O you need:

force_eeprom_read=0
dtoverlay=hifiberry-digi

Thanks Jussi

Hi Jussi,

I am trying to get a Toslink audio input to HQPlayer [WiiM Toslink → rpi4 with HiFiBerry Digi+ I/O -(ethernet) > HQPlayer embedded]. I can’t get it to work yet.

Details:

I am running HQPlayer 5 Embedded 5.5.0, and just got another rpi4 with HiFiBerry Digi+ I/O hat (with the metal case) to run NAA 5.0.0 on it.

I modified the NAA config.txt adding the overlay:
force_eeprom_read=0
dtoverlay=hifiberry-digi

In /etc/hqplayer/hqplayerd.xml, added

<input address=“naa-xxxx” device=“hifiberry-digi” ipv6=“1” name="NAA Toslink Audio"samplerate=“44100” short_buffer=“0” type=“network6”/>

When I select “NAA Toslink Audio” from Input, it seems to timeout.

Examining the log, it seems that HQPlayer found the “NAA Toslink Audio”, but have a message:

“NAA input clNetEngine::Connect(): initialize: clALSAEngine::Initialize();snd_pcm_open(): No such file or directory”

I must have done something wrong. Please advice.

Thanks.

This should be “hw:CARD=sndrpihifiberry,DEV=0”

Thank you, Jussi.

That did the trick.

Hao

1 Like