I get tons of Tidal unavailable errors

Exact same issue. Everything worked fine for a long time. But now I get tons of Tidal unavailable errors. Search for albums, artwork, etc work fine, playing from local storage work fine. Just streaming from Tidal that is bjorked.

I played around quite a bit with iPad, iPhone remotes and Brooklyn Bridge, Homepods and Muso destinations, as well as Tidal direct to those devices. It seems clear to me Roon to Interconnect to Tidal is having issues lately.


I forgot to mention. It seems like logging out and back into Tidal service from Roon app on my iMac resolves issue for a bit. But eventually it will break again in same way.

1 Like

Hi @Nicolaas_Verheem,

Can you please try clearing out your TIDAL cache?

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to /Library/Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Hi Noris

Update #1: This morning before leaving for the office (yes I can still work in the office in spite of Covid), I tried to play to my Roon core (on iMac) direct to system output to eliminate any LAN/DAC issues. Tidal kept on puking on me. Really bad. I was quite depressed about the situation…

Update#2: As soon as I got home, I cleared the cache and restarted as you suggested. Tidal loaded without the typical pink warning box, and I didn’t need to login and out 5 times like this morning. Played a few tracks and… So far so good!! Yay!

BTW I looked at roon_log files. Huge with many warmings/errors/exceptions in it - happy to email it to you if that’ll help. But for now it seems working again. I will update if there is anything new to report.

Thanks much

Update #3, after flushing cache, and just for sh_ts and g_ggles, I played 6 unique TIDAL feeds to my 6 zones at the same time, because why not? It normally makes no sense outside of testing since I can’t be in all places at once, but I wanted to stress the system. Actually pretty awesome! So far so good still.

Update #4. Over the last hour, all six zones quit playback. I was listening to (and watching the UI) of the Brooklyn Bridge when it happened. It popped up the orange on black “track not available from Tidal”, and “Too many errors, quitting playback” errors.

Separately, but possibly related. The system output had already quit by now, but interestingly so did the iPad mini connection to my Roon core (iPad mini was “Waiting for Core”). I have been suspecting that the iMac going to sleep had something to do with it. Once I woke iMac, the iPad control came back, but still couldn’t play with “track not available from tidal”. Interesting coincidence ? I dunno. No firewall on iMac; prevent sleeping enabled; wake for network access enabled.

On the core iMac, if I go to Tidal screen it says “Error loading page, please check your connection”. A browser reaches and logs into Tidal fine. Reloading page finally loads artwork, but streaming still says track not available.

If you tell me where to, I can email log_files while they are fresh.

System conked around ~830pm PST.

I’m not going to try and parse those log files or pretend to know what it means, as they are very verbose, but the regular cadence of warnings/traces/etc gives way to one that seems relevant:

08/03 08:29:31 Debug: [easyhttp] [244] POST to https://metadata.roonlabs.net/1/albums/translate?c=tidal-us
08/03 08:29:31 Critical: [easyhttp] [244] Post https://metadata.roonlabs.net/1/albums/translate?c=tidal-us web exception without response: : System.Net.WebException: Error: SecureChannelFailure (Unable to write data to the transport connection: The socket is not connected.) —> System.IO.IOException: Unable to write data to the transport connection: The socket is not connected. —> System.Net.Sockets.SocketException: The socket is not connected
at System.Net.Sockets.Socket.EndSend (System.IAsyncResult asyncResult) [0x00012] in <81ba78c8dc794b7f9f7b530c53db0f84>:0
at System.Net.Sockets.NetworkStream.EndWrite (System.IAsyncResult asyncResult) [0x00057] in <81ba78c8dc794b7f9f7b530c53db0f84>:0
— End of inner exception stack trace —

Hope this helps!.

1 Like

I haven’t gotten this error on Roon yet but I also use HEOS (Marantz and Denon system) from time to time and I never had issues then today I started getting the “This album/song is unavailable on Tidal”. I’m not saying it isn’t Roon but it is odd that I am getting a similar issue but on a different platform. It may be on Tidal’s end?

Good luck.

Hi @Nicolaas_Verheem,

This trace does help a bit, this means that issues are on the network side of things. What kind of router are you using? What is it’s model/manufacturer? Do you have the latest firmware installed on your router?

I’ve created an account for you on our servers, I will send info via private message. You can upload the current logs there if you wish or any other documents as we progress trough troubleshooting.

Thanks Noris, I will upload log files tonight when I get home. Maybe I’ll repeat last nights experiment too to give you more info.

Recall that I could recreate errors playing from Core on iMac to it’s own system output. So it’s not a LAN issue between Roon Core and DAC. Also recall that I can reach Tidal and play the songs from a browser on same iMac, so it doesn’t seem to be Tidal / network/ DNS either. It seems to be Roon Core App / Tidal specific. Another reason I suspect that is how flushing the cache helped (for a bit).

But to be complete my iMac Pro is hardwired to an AmpliFi Alien #1 in RAMP mode, that is hardwired to Amplifi Alien #2 which I use as edge router (both with newest Ubiquity firmware). AA#2 is directly hardware to Arris Surf cable modem, which is on 1Gbps/40Mbps to Cox cable. I regularly run speed test and get at least 800/30 Mbps and 7ms ping from the iMac too speedtest.net or fast.com. There is a pi-hole on the same network but that has been there quietly and well behaved for much longer than the problems. I did upgrade that to Ubuntu 20, Pi-hole 5.1, as well as disable to test. I suspect newest Roon or newest MacOs updates made it worse, but can’t be sure of that.

If you want me to do any other network tests happy to, JLMK.

Maybe I should sign up for Quobuz just to test?

Thanks for the help.


Hi Noris,

Thanks, I uploaded logs. I couldn’t quite get the hang of the uploader in time so I made a bit of a mess organizing but you should get the hang of it.

I’ll rename log folder, and start a new test to see what happens. I’ll upload later tonight.


1 Like

Testing on a different network would be good, it would help eliminate the current setup/pi-hole as being part of the equation. If you have a hotstop available to you, that would be an easy test.

As for Qobuz, yes you can give that a try as well, or try streaming some internet radio stations and be on the lookout for any issues there.

Update #5. Very interesting. It ran for 2.25+ hours on all 6 zones, no breakups that I know of. I did have to hit play again on a few instances but that could be because Roon Radio timed out after no activity. Normally once it break it won’t play again without error. I didn’t see any errors on screen, but I haven’t looked at log files again.

It does seem as if either Tidal fixed it on their end or…

…the only difference between last night’s experiment and tonight’s was tonight I renamed (effectively deleted) all three of …/Roon/Cache, …/Roon/Logs, and [drumroll] …/Roon/Database/Cache. Last night I only did #1. Could logs be overflowing (there were a lot) ? Or database corrupted ?

I will leave running overnight, except Muso which is in my MBR.

I did upload that I sus[ect a clean log file just now with a timestamp.


Hope this helps.

its not on TIDALS end. I am using the Lightning DS from Auralic and works perfectly. This is a Roon glitch.

David I agree: Not Tidal per se, I don’t have any issues playing Tidal direct either. But could be Tidal’s end of the Roon-Tidal integration. I’m leaning more toward Roon itself too.

Not easy for me to test on another network. Since I’m OCD the gear is pretty bolted down. But I’m convinced it’s not network, as that hasn’t changed for months and issues are recent. I got another very similar looking error last night. I’ll upload log file.

Doesn’t look like Tidal but Roon metadata server?

08/05 01:27:49 Info: ComputeSwimType(LimitToSeed=False, PerformerIds.Count=0, ComposerIds.Count=0)
08/05 01:27:49 Debug: [easyhttp] [2759] POST to https://swim.roonlabs.net/1/session/begin
08/05 01:27:49 Trace: [Mytek Digital Brooklyn Bridge @] [raatclient] SENT [8]{“request”:“update_artwork”,“mimetype”:“image/jpeg”}
08/05 01:27:52 Trace: [Mytek Digital Brooklyn Bridge @] [raatclient] GOT [5] {“status”:“Success”,“controls”:{“volume”:{“value”:7,“info”:{“config”:{“device”:“default”}},“mute”:false,“type”:“number”,“min”:0.0,“step”:1.0,“max”:100.0},“source”:{“value”:“selected”,“info”:{“config”:{}},“is_standby_supported”:true}},“action”:“Changed”}
08/05 01:27:52 Trace: [Kitchen Homepod] [HighQuality 19.4x, 24/192 FLAC => 16/44] [100% buf] [PLAYING @ 2:47/6:21] Well, You Needn’t - Miles Davis Quintet
08/05 01:27:57 Trace: [Mytek Digital Brooklyn Bridge @] [raatclient] GOT [8] {“status”:“Success”}
08/05 01:27:58 Trace: [Kitchen Homepod] [HighQuality 19.5x, 24/192 FLAC => 16/44] [100% buf] [PLAYING @ 2:52/6:21] Well, You Needn’t - Miles Davis Quintet
08/05 01:27:59 Trace: [Office Homepod] [HighQuality, 16/44 TIDAL FLAC => 16/44] [PLAYING @ 0:00] Genie in a Bottle - Scott Bradlee’s Postmodern Jukebox / Brielle von Hugel / Steve Kipner / Pamela Sheyne / David Frank
08/05 01:28:03 Trace: [Kitchen Homepod] [HighQuality 19.2x, 24/192 FLAC => 16/44] [100% buf] [PLAYING @ 2:57/6:21] Well, You Needn’t - Miles Davis Quintet
08/05 01:28:03 Info: [stats] 13694mb Virtual, 2749mb Physical, 711mb Managed, 1670 Threads, FDs
08/05 01:28:03 Critical: [easyhttp] [2758] Get https://metadata.roonlabs.net/1/tracks/168:0:147944255/lyrics web exception without response: : **System.Net.WebException: Error: SecureChannelFailure (Unable to read data from the transport connection: Connection reset by peer.) —> System.IO.IOException: Unable to read data from the transport connection: Connection reset by peer. —> System.Net.Sockets.SocketException: Connection reset by peer
at System.Net.Sockets.Socket.EndReceive (System.IAsyncResult asyncResult) [0x00012] in <81ba78c8dc794b7f9f7b530c53db0f84>:0
at System.Net.Sockets.NetworkStream.EndRead (System.IAsyncResult asyncResult) [0x00057] in <81ba78c8dc794b7f9f7b530c53db0f84>:0
— End of inner exception stack trace —
at System.Net.Sockets.NetworkStream.EndRead (System.IAsyncResult asyncResult) [0x0009b] in <81ba78c8dc794b7f9f7b530c53db0f84>:0
at System.IO.Stream+<>c.b__43_1 (System.IO.Stream stream, System.IAsyncResult asyncResult) [0x00000] in <71f4e3d7d65e42b0a699d02e59766d3c>:0
at System.Threading.Tasks.TaskFactory1+FromAsyncTrimPromise1[TResult,TInstance].Complete (TInstance thisRef, System.Func`3[T1,T2,TResult] endMethod, System.IAsyncResult asyncResult, System.Boolean requiresSynchronization) [0x00000] in <71f4e3d7d65e42b0a699d02e59766d3c>:0

— End of stack trace from previous location where exception was thrown —

Hi @Nicolaas_Verheem,

I would disagree, this is most certainly a networking related issue:

Are you using a VPN or anything? I have seen Pi-hole cause issues with Roon in the past, I would check the DNS configuration.

I’m not seeing any outages reported and certainly haven’t seen widespread reports of TIDAL issues. I would try a hotspot or different network temporarily.

Hi Noris,

I should have quantified better. I agree it definitely is a networking issue, but I’m convinced it’s not my (LAN) network causing the issue.

No VPN. I noticed other pi-hole post, so I’m already pointing DNS to so it shouldn’t be that. Besides it doesn’t complain about not being able to resolve DNS or connect a socket, but rather about a connection that was established successful eventually dropping (socket reset by peer). Pi-hole is sidelined by hardcoding DNS, and even if it wasn’t, it is not “inline” with the http traffic once the DNS was resolved.

If you look at my logs there are many critical failures caused by http connection errors to Roon server. Sure the UI on iPad says it’s Tidal, because that was what was playing, but might it actually be just the meta data failing? It does seems as if there are others with somewhat similar Tidal and Quobuz issues right now on the forum…

I haven’t had a chance to test last night. Failing any other ideas I’ll plan to rip up wires in my closet on the weekend, just to make 100% sure, but I’m not very hopeful that it’ll be a solution.

Hope this helps!

I uploaded some more log files. Hope this helps.

Hi support

I physically removed my pi-hole from network. As before DNS points to, and As expected it made absolutely no difference.

Several tests including fast.com, speedtest.com, Netflix, YouTube performed to confirm my network fine.

I reinstalled Roon, just to check if that could be a fix (it wan’t). I removed most audio devices to try and keep things simple.

I also subscribed to Qobuz, just to see if that’s better than Tidal (it wasn’t)

I still get tons of networking issues from within Roon, but not from the proprietary Tidal or Quboz apps, or any other networking service including those above but also Xbox, iCloud etc…

From the UI tracks stop playing, or I get the pink Not Logged In box. Restarting the door fixes it momentarily.

I uploaded another log file just now (Roon_log_08.08.20). There are hundreds of Critical: [easyhttp] errors, pointing to metadata.roonlab.net, discover.roonlabs.net, tidal.roonlabs.net, qobuz.roonlabs.net.

Probably unrelated but I also noticed there are also tons of “Critical: scx: System.FormatException: One of the identified items was in an invalid format.” errors against my two HomePods even though they are disabled in Roon.

I’m now suspecting it’s a build 571 issue. Is there a way I can revert to older versions ? I have invested many hours into troubleshooting this one to no avail. I miss 2019 SO MUCH!

Thanks for any help.


Uploaded another folder with log files, Roon Logs 08-08-20 pt2.

Hope this helps!