I lost every thing I edited/ input to my album collection when I changed my router


I have ripped about 800+ CDs form my collection, they are old from the 1980s and could not be identified by roon. Therefore, I input almost every metadata they need by my self. Unfortunately, my routers crashed twice in this process, every time when I change a new one, they just give my NAS (QNAP TVS-882) a new IP address. Then my roon on Nucleus+ cannot find the original storage path(not available…blur). As I try to redirect the storage path along the new path (although they still in the same place), everything I have done has missing: my hand input metadata, CD merging edits… et. c…
I have tried to restore by my roonbackup, but it apparently redirects the storage path to the original IP address…still shows not available.

Give the QNAP a static IP address.

If you have a Nucleus+ you should store the media on this rather than the NAS. I’m looping in @support since this concerns potential data loss.

I suggest you hold fire until they respond.

In the meantime it would be really helpful if you described your setup in a little more details as set out this post:

1 Like

Hey @Kunchung_Lin – all the metadata you’ve entered will still be in your database, but the changing IP address may have confused Roon, which probably thinks this is “new” content – that’s why your edits are not showing up.

But fear not – the edits should still be in your database, and most likely @support will be able to get everything back for you.

First question is do you have any backups from before the router change?

YES, I do have backup just before I change my old router.
But that pointed to the old storage path which shows not available now.


Hello @Kunchung_Lin,

Thanks for confirming that you indeed have a backup saved, this is good news.

I would proceed with the following steps:

  • Open Roon and go to Settings -> Backups -> Find Backups -> Select the backup location (the one before changing routers)
  • Wait for the restore to complete
  • After the restore is completed, then go to Settings -> Storage -> Press the 3 dot drop-down menu and select Edit -> Browse. (Do not press Add Folder)
  • Provide Roon the path to the media files -> Select This Folder -> Save

Please let us know if these steps worked and the music & edits appeared as expected again.


1 Like

It still shows: Error Loading Folder
Not Available

Seems it still tried to access old IP address of my folder.

Hello @Kunchung_Lin,

You would need to change the IP address of your NAS to reflect the current IP address in this step:

You can go ahead and click “Add Network Share” while in the Choose Music Storage Folder page and point it to the QNAP:


1 Like

Thanks to your kindly help!!

I’ve got everything back by following the suggested steps form Noris.

Thank you again!

Have a nice weekend.

KC Lin


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.