I need step by step instructions to update my NUCLEUS + to 2.0 from 1.8

Roon Core Machine

I have a new Nucleus +. I use an iPad as the Remote. I also have a Mac mini which I use as a remote.
I have tried 10-15 times and no dice.
Can you tell me how to update my NUCLEUS+ without making me look at other documents that require a shift in focus? You didn’t sell me a Mac or a PC, you sold me a NUCLEUS+. I expected better.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi Steven,

Fellow user here.

When you open the app on your Mac Mini, and go to Settings/About, does it indicate that an update is available for the unit.

Support will be by as soon as they can as they are a bit busy.

If you don’t want to wait, there are the manual steps they have posted s in the Roon 1.8 <> 2.0 Migragtion FAQ.


I have copied the relevant information from the FAQ below which uses a different PC like your Mac Mini to connect to the Nucleus PC data share:

RoonOS Core 2.0 (Nucleus / ROCK)

The names below in (red) BOLD are case-sensitive, capitalization matters, [changed it to bold since the red didn’t copy over]

  1. Go to the /Data/ share (instructions) and create a folder called branches

  2. Download the following file: roon_2-0 (It should be named roon_2-0 and saved with no file extension)

  3. Copy the file into the branches folder previously created

  4. Rename the file to roon (instructions on how to rename files: Windows / MacOS)

  5. In the Web Interface, click “Reinstall” under Operating System

When you are done, you should have a file called roon in the branches folder like so:

Sorry, but this is not always working, at least not for me, still stuck on a downgraded 2 to 1.8
Any other solutions?

Ditto. Have tried multiple times this evening with no success.

This morning my Nucleus+ was loaded with 2.0 and everything works smoothly.
During the last few panicking days I reread what Roon is ABOUT, where it came from and how its going ahead and I’m along for the ride.

Thanks community and staff. Stephen G.

If I go to Settings in my iPhone Legacy 1.8 controller, it says my Nucleus core is Roon version 1.8 (build 1126) and “You have the latest version installed”.
If I open my Roon 2.0 controller app on the iPhone, it asks me to connect to a core, notes than an update is available, but gives no option to initiate the update. This is before it shows me the menu that includes “Settings”. If I select the core available, it shows me an incompatibility screen allowing no further action except going back. I never see an update option.
Looking at the migration instructions, they are written for ROCK users, but I’m Nucleus. I haven’t been able to access the Data file at all so I’m stuck on step 1.

Have you see this post?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.