iFi Zen Streamer - Initial comments

Comments to date on the iFi Zen Streamer:

Out of the box, the unit had a “quick start guide,” a card with the features of the device (semi) identified.

A review of the quick start guide seemed to indicate that it (the quick-start guide) was for enablement of the wireless features of the streamer. I don’t want to use my streamer with wireless, so instead I connected my Ethernet cable, my USB cable, and the power supply to the Zen. Power on - looks good - the LED on the front indicates “high speed connection.”

So I’m sitting back ready to listen and… Nothing. Roon says my selection is playing - Roon sees the iFi Zen streamer - It is selected as the active audio zone - The DAC is set to USB input & variable volume - The power amps are on - No sound.

The first step of troubleshooting (since this rig was working before I substituted the Zen for my previous Apple TV) was trying to determine whether my USB cable to the DAC is plugged into the right USB port on the Zen. The Zen has two. One is an input only for a data HDD (won’t be using this one at all). Second is an output only for the DAC. But although the information from iFi calls them “Port A” and “Port B,” the features card fails to say which (top or bottom) is which. Further, the ports aren’t labeled on the device.

Long story short - I try switching ports on the Zen. Result: Still no audio.

Second step of troubleshooting (since this device will be working ONLY with Roon), I’d set the mode switch on the Zen to “Roon only.” When I turned the Zen on, the front panel LED lit up to Indicate “high speed connection.” Thought I was good to go. No dice. No music.

Third step of troubleshooting (after viewing a YouTube video for setup as Ethernet only), I turned the mode switch back to “All In One” (AIO) turned the Zen off, and then turned it on again. No music.

Fourth step of troubleshooting - I entered "http://ifi.local into my MacBook Pro’s browser (Safari). I’m supposed to get a Zen setup screen. No dice - the page won’t load. Period. I double checked - the MacBook is on the same Ethernet network as the Zen.

Fifth step of troubleshooting - I scraped off the “stuck on for life” cover off of the Zen’s reset button & pushed reset. Zen came up - “high speed” light lit - tried ifi.local in my browser again. Nothing.

Stopped & drank an adult beverage. Left the Zen alone for long enough to calm down. Wrote this post to blow off steam.

Opened a new browser window - tried again to access the setup page - Nothing again.

Replaced the USB cable just to ensure that I hadn’t installed a bad one - Nothing again.

Hardware Conclusions -

  1. The Ethernet IS working since Roon can see and identify the iFi Zen.

  2. The USB connection from streamer to DAC is not the problem since I’ve replaced it (and tried it in BOTH of the Zen’s USB ports.

  3. The problem isn’t with Roon or my NUC since my copy of Roon Remote can see the ROCK server.

  4. The Zen’s power supply isn’t the problem since it lights up and responds to button pushes.

  5. iFi’s documentation for this device is deficient in multiple ways.

Initial iFi Zen Streamer impression:

THOROUGHLY fed up with iFi. If I get it working, I’ll let ya know. The irony of this is that I paid (significantly) extra for this over other options for simplicity of use. I was HAD…

1 Like

take a look at post #2400 by Steven_Klemen; in Roon, under Audio Settings page go to zone’s Device Info section and select desired output for the streamer.

for a few visual tips (screenshots), check Traian_Boldea’s post #2594 from same thread


Glenn there is a reason that there are close to 3000 posts in the the Zen Stream thread I started almost 2 years ago :roll_eyes:
Though not many people have your level of issues. The documentation is deficient and probably cover’s the device at day 1 not the device at day 650 as it has changed a lot in use, though not really initial setup.

Go to Settings->Audio and Click on the device info text as the device defaults to SPDIF after the Roon Ready update for some reason.

The click on configure device

Then set the device output to USB and save


For the first hour I felt the same… I connected usb and ethernet and power. Nothing playing. I do not know why Only SPDIF is default and there is no way to know how to turn USB from that little piece of paper. And the ifi.local never worked for me, but if it is visible in roon settings you get your ip from there.


The SPDIF change only happened for some bizarre reason at the beginning of 2022 (with Roon Ready certification, though maybe not linked) and caused a huge level of issues for user’s.
What a terrible decision from iFi and before that you could use both devices as Roon Endpoints independently as both USB and SPDIF showed up in Roon, but back then it used Roon Bridge to work.

The iFi.local registration is network dependant and could be caused by @Glenn_Young DHCP server/DNS servers features. All my devices work with a .local registration but some setup’s do not and I have seen that before. It requires a certain level of knowledge that cannot be assumed by brand’s like iFi to exist. Not everyone would know to look for the IP address to get to the server.

Hopefully Glenn can get this working and enjoy the device once he has gotten over his initial annoyance at stupid quick start guides that only contain a part of the information required.


True, I think with the in mind everybody is building a phone app to get you connected to the device without using ips in browser.

I really like that in roon the ip is so visible


The options you show do not appear in my Device Setup options. I see no “Device Info” (as opposed to “Device Setup”) option anywhere in my Roon Audio Settings. My Zen does show up in the “Roon Ready” section, but I get no screens anything like your screen shots.

Potentially Relevant Factoids:

My Roon Core is a ROCK installation running on a NUC
I am accessing Roon through an install on my MacBook Pro (the core is identified as ROCK on the NUC)
In my listening room, I control Roon via Roon Remote on my iPad mini
The external Library HDD is connected directly to the NUC
The iFi Zen is connected to the core over Ethernet (wired)
The MacBook Pro is connected to the core over Ethernet (same network)
My iFi Zen Streamer is a brand new unit bought from an authorized dealer
The streamer is powered by its factory 12VDC wall wart
The streamer has the left front LED showing green
Wi-Fi is not enabled on the streamer and the antenna is not connected
The mode switch on the streamer is set to AIO (all-in-one) - the factory default setting
The owner has now reached full boil…


WHICH of the two USB ports on the iFi Zen Streamer is “audio out” to the DAC - the top one or the bottom one? The “owner’s manual” doesn’t say and they’re not marked on the actual device. Doesn’t iFi realize that clairvoyance costs extra? Anyone? Anyone?


Glenn that suggests you have not yet updated it as you cannot get to the ifi.local page (though you say they are Roon Ready which the original devices were not).

Look at the IP address on the Roon settings Audio page and put that into your web browser and then go and update the firmware from there.

The next question is Why are you not seeing the Device Info above the Roon Ready devices on your network as all of mine see them and all of mine are running on Ethernet on a ROCK based NUC the same as you and I can see them from a Mac and PC, and my Android phone (all the devices in front of me).

Once again you should see this when you go into Settings-Audio on the Roon app and not anywhere else


1 Like

Thanks, @Michael_Harris - WHAT, please IS the URL for the iFi Zen device? It is shown on the Roon Settings Audio page of my machine as “” But when I load that URL into my Safari Browser, I get the message “Safari can’t open because the address isn’t valid.”

I’ve tried the naked URL, the URL with the prefix “http://”, and with the prefix “www.” Same result with every attempt.


Glenn it would just be

We might need to move a step back here, do you have 2 networks set up on your home router?

What is your Rock IP address and what IP address does your MacBook have?

The only times I have seen problems like this is where there are two distinct networks set up, or the device is not in AIO mode which is no 1 on the dial (I seem to remember the first documents being incorrect)

1 Like

Thanks, @Michael_Harris -

To answer your questions:

  1. There are two networks on my router - the Ethernet wired network and a wireless one

  2. The IP Address for my MacBook Pro is
    The IP Address for my ROCK I’m not sure how to identify

  3. My iFi Zen Streamer IS in AIO mode

  4. In my Safari URL line I am entering “” but when I hit the Enter key to access the URL, Safari is changing the entry to “www.” and then won’t find anything.

Have a look at your router’s DHCP page. All devices having obtained an IP address can be found there.
Start with

Do the WiFi network and the Ethernet network share the same IP range?

You can find the IP of your room core under settings ->About

Glenn Do you have Chrome installed?
Also are you typing this in the top bar or a search bar, sorry I do not use Safari and I am away from my Mac now.

It should not add www to it, unless it is going through a plug-in or something else

My Safari installation is stock. I do have Chrome installed as well - I’ll try it.

My router is a NetGear Orbi. It does show attached to the Ethernet network - it’s identified as “Jiffy” - don’t ask me why… Since the URL matches, I’m assuming that “jiffy” is the iFi Zen Streamer? Why in the world would those idiots give the Streamer the network name of “jiffy?”

Both wireless and wired connections are shown as going through the Orbi router at 08:36:C9:A3:11:42

All of the devices on the network (wireless and wired) have unique names and IP addresses.

My ROCK is identified as

Glenn This is getting stranger as that sounds like you have Wired and Ethernet on the same network which is normal (I also use Orbi and it works perfectly with all the devices and is one of the best WiFi systems around).

Not sure where the jiffy came from an maybe something old from the DHCP or DNS.
if you put into Chrome see what happens.

Can you also send a screen shot of your Settings->Audio Roon Ready device settings so we can see what is being see at your end


Thanks Glen for posting that.
This is the setting here. Click on the Device Info text, it is a button (Stupid I know with no indication). I have my :crossed_fingers:


Will do - In the meantime: I downloaded Google Chrome and tried “” and got this:

This site can’t be reached refused to connect.


  • Checking the connection
  • Checking the proxy and the firewall


This is suggesting that the web configuration on your device is borked (not something we have seen posted before).

Another option is to try Roon only mode where is creates a private web server on a different port. Remember to reboot after you change this setting. You will see the same information but it will give you a mini web server with only output configuration options.