Installed OS X Mojave, now No Remote iPad Access

I recently upgraded to OS X Mojave on my 6-core Mac Pro (64 GB RAM< 1 TB SSD). My Roon music files are on my Netgear NAS. I have a Sonore Systems UltraRendu playing into a Lyngdorf TDAI 2170 amp. (I can play music on my Mac Pro, either on my desktop speakers or on the upstairs system, but I need the iPad app to work to keep from running downstairs to change the music.) All has been working well prior to the OS X Mojave update. Now Roon on my iPad doesn’t connect to Roon on the Mac Pro - they don’t see each other. I have checked everything noted in the Knowledge Base article on OS X connection issues. The firewall on my Mac Pro is off at the moment, too. I’m stumped as to what to try next.

Try quitting the iPad Roon app by double tapping the home button, and swiping the Roon screen up. Then relaunch it. Hopefully the automagic discovery will work this time.

Hi @Michael_Bade,

Have you checked that Roon is added as an exception to the OSX system firewall using these instructions? If Roon is already listed there I would try adding it again.

You mentioned that you have the main system on one floor but are using the iPad from another floor. How is the Core and iPad connected to the network in this case? Is there just one router in this setup or are you making use of range extenders/powerline adapters?

Please let me know the model/manufacturer of all your networking gear and then I would go ahead and reboot your Roon Core, iPad & all networking gear to see if that helps. I would also make sure that there is no VPN active on the iPad. Hope this helps!

– Noris

Done, no effect. I’m working through Noris’s suggestions (next Reply). Will report back on those when complete.

So far, I have quit the Roon app on my iPad per MJB’s suggestion and relaunched, to no effect. I have addressed the firewall issue per instructions, and when I rebooted Roon I was asked if I want to allow incoming network connections, t which I replied YES. The iPad app still doesn’t see the Roon Core. I have NOT used the blue button on the iPad to select a different Core.

At this time I can use Roon and Tidal to play music on my Mac Pro desktop. What I can’t do is use the server functions in Roon to feed my upstairs system to play music in distributed fashion. Here are the components in the signal chain:

  1. Motorola NVG 589 router at the point of connection to our ISP.
  2. Netgear GS 116 gigabit switch, 16 ports. This has been rebooted.
  3. Two Actiontec MoCA network adapters. I am running ethernet over coax between the ethernet switch (downstairs) and the UltraRendu (upstairs at the point of connection with the stereo). One adapter is at each end of the run of coax - ethernet in downstairs and ethernet out upstairs, coax in between.
  4. Sonore Systems UltraRendu. I have unplugged and re-connected the UltraRendu to cause reboot.
  5. Lyngdorf TDAI 2170 amplifier, connected to the UltraRendu using USB

All this worked like a charm before the upgrade to Mojave.

Perhaps you could try this, and see if your new Mojave Roon Core is listed/available for selection.

Tried it. The iPad app sees the Core but there is a red dot and Connection Failed is noted.

I’d suggest two additional troubleshooting steps.

First, reboot you iPad (hold down the power and home buttons until the apple logo appears).

Second, disable the firewall on your Mac - just hit the Turn Off Firewall button in the Privacy tab of Security & Preferences.

Also (and you may have already mentioned this), check that both devices are definitely on the same wireless network.

The first rules out a glitch on the iPad, while the second should help isolate any network issues.

EDIT: should have read your original post properly before posting - I see you already disabled the firewall.

@Michael_Bade Are you running the latest version of Roon on all devices, for example on the iPad are you running IOS 12.1.1 with Roon version 1.5 build 360?

Thanks, guys! I’m updating the iPad to 12.1.1 now, and will make sure that the software on the iPad is the latest once I’m done. I reinstalled Roon on the Mac Pro yesterday (so the latest version is there). I only recently updated to Mojave because my workplace has to test a sea of applications before we upgrade anything; that go-ahead was just given last week, hence I’m just starting this process.

Once I have updated the iPad I will check the wireless network - the Mac Pro is connected with an ethernet cable, while our iPads and phones connect wirelessly.

1 Like

I have checked the iPad software version: it is Roon 1.5 build 360. I have checked the network settings and both are using the same router. The Mac Pro is connected via cable, and the iPad via wireless network. I use Apple AirPort wireless base stations - I have an AirPort Extreme downstairs, and an AirPort Express upstairs. Both are working normally when I check them in the AirPort Utility software.

I have tried this both with the Mac OS firewall off and the Mac OS fire wall on with Roon enabled.

I have checked the Motorola router, which connects only via ethernet to the gigabit switch, and from there to one of three branches: to the Mac Pro via ethernet cable, the MoCA coax connection to the Airport Express and the UltraRendu, or to the AirPort Extreme. The main router sees the following devices:

  1. my iPad
  2. the UltraRendu
  3. the NAS
  4. my Mac Pro
  5. both the AirPort Extreme and the Airport Express

Basically, everything that should be seen is seen.

Hi @Michael_Bade,

Just in case you haven’t already tried this, does reinstalling the Roon app on your iPad help? Also what is the exact error message presented (you mentioned a red dot next to the Core on the iPad)? Or does it just say “Connection Failed”?

Can you try installing Fing on your iPad and try pinging the Core’s IP address? Does that work? I would also be sure that everything is on the same network segment.

– Noris

Is the ipad on the same subnet as Roon Server?

When I ‘Choose your Roon Core’ I see my Mac Pro core listed with the correct Mac OS (OS X 10.14.2, Roon Version 1.5 (Build 363) stable, and on a line below a red dot and Connection Failed. The Connection Failed cycles between Connecting and Connection Failed on my iPad. I can delete and re-download a new version for my iPad if you recommend it.

I’m not a networking type - I have one home network with a router at the point of ISP connection. The router is connected to a gigabit switch, and everything else connects to the switch - my Mac Pro (via ethernet cable), the AirPort Extreme (via ethernet cable), and the upstairs Airport Express (the MoCA coax to the Airport Express, and the UltraRendu then from the Airport Express via ethernet cable. It’s not divided into subnets to the next of my knowledge. The wireless is only used to connect our iPads, phones, and laptops to the network. The music playback does not run on wireless except for using an iPad or iPhone running the Roon app to select music on the server. The pathway the music takes is wired from end to end. Both my iPhone and my iPad see the Core but the connection fails.

I saw that Roon 1.6 was released less than 30 minutes ago - should I install that?

Hi @Michael_Bade,

Yes, give Roon 1.6 a go and let me know how it goes. I would also reinstall the iPad app as I mentioned to see if it helps. Please let me know when possible.


I have installed 1.6 on my server (Mac Pro), iPad, and iPhone, Nothing is changed. I still get the same ‘Connecting,’ then ‘Connection Failed’ messages. The network topology and components are the same as before I installed OS X Mojave on my Mac Pro. The only change is Mojave (and now upgrading Roon to 1.6).

Here is the site of the network adapters for running ethernet over coax:

Any ideas?

Hi, again - I just spend 90 minutes with Apple Support. The support engineer and I were able to (under certain specific and temporary circumstances) get the Roon Remote software to connect with the Roon Core and play music. Here’s what we were able to do:

  • If I reset the PRAM by turning the Mac Pro off, disconnecting the power for >1 minute, then holding down the Option, Command, R, and P keys when booting the Mac Pro and holding these through a second boot chime, then allowing the computer to boot up, AND closing out of the Roon Remote App, then booting the Roon Core on the Mac Pro and once that is fully booted up and all the tracks are checked, I re-start the Remote App. If I do all that, I can select the Core in the Remote App, connection is successful (it seems to take a while - like a minute) and I can play music from the Remote. If I close the Remote App and reopen it, everything breaks and connection between the Remote app and the Core fails again. The only way to get the Core and Remote to reconnect is to go through the steps of resetting the PRAM on the Mac Pro and rebooting the computer and opening Roon Core into that environment.

The Apple Support Engineer gave me some links to Apple articles:

  1. Using Safe Mode:
  2. Resetting the System Management Controller:
  3. Reset NVRAM or PRAM on a Mac:

I suspect that the handshaking that goes on between the Core and Remote, as well as the way that the PRAM or other OS components that are flushed out when I go through the reset process needs to be attended to. Please let me know if this is helpful.

Hello Roon Support: Any ideas in regards to my last post (above)?

Hey @Michael_Bade – Noris asked me to take a look over this thread and I just read over what you’ve tried so far.

First off, thanks for your patience here. I can see you’ve done quite a bit of troubleshooting here, so I want to try and get this resolved as quickly as possible for you.

My take based on what I’ve read here is that something about the network is preventing the iPad from connecting properly to the Mac Pro – I don’t know if that’s due to a networking change in Mojave or something else that changed on your network around the same time, but it’s likely that’s what’s happening here.

I say that because your iPad is seeing the Core – they are just failing to connect properly, as described here:

The first thing I would do here is simplify the network completely. Get the Mac Pro, the iPad, and the Airport Extreme in the same room, with nothing else connected besides the internet, and see if things connect. If that works, we know we need to troubleshoot after your switch. If that doesn’t work, we can focus on the Core, the router, and the iPad.

This kind of process-of-elimination troubleshooting really helps move tricky networking issues like this forward, so thanks in advance for giving this a shot. I’ve also set up our servers to request some diagnostic information from the Roon installation on your iPad the next time they connect – if things do work on the simplified network, the iPad logs may help us understand the failures you’ve been seeing.