Intel 4770k based PC. OpenGL Error

Ill try one more time to get ROON to install on my PC. My PC features an INtel 4770k proceesor. I have a free trial. Ive downloaded ROON. But ROON refuses to open giving me the message OPen GL 3.0 error. However the 4770k processor uses the Open GL 4.3 which i would think should surpass the Open GL 3.0 spec.

Once before I’ve posted about this problem and was told to consult a thread concerning NUCs. I have a full ATX motherboard, 16 gb ram, hdplex Linear Power Supply, fanless case, SSD, dual booting with both Windows 10 and Windows Server 2012 v2, and 8 tb of music files on a seperate server.

I have downloaded the latest drivers rom Intel, but still norhing

I dont want to told that my proceesor is not adequate for ROON. Ive seen others use a less powerful CPU and run ROON fine. I use Windows Server 2012 as do many other users on this site. I use the AudiophileOptimizer, jPlay, Fidelizer, dbpoweramp, and jRiver.

I’m certainly not a PC expert, but i have been using Windows PCs since Windows was just a glimmer in Microsoft’s eye. I’ve been a Beta tester for Ps Audio and a couple of other companies. I believe ive been streaming music since jRiver 13 and have trouble shot several software packages used for music playback and have fixed many other software inconsistensies.
But i cannot get past the Open GL 3.0 error. I do not believe this is an Intel CPU issue. I believe it is some strange ROON issue that perhaps the busy code writers need to take a look at and solve.

I have a 60 day frree ROON trial that gets closer and closer to terminating without getting any closer to using Roon than thje OPenGL 3.0 message. I’m certainly glad i decided to wait on purchasing the $500 lifetime membership which has been my plan all along.

Obviously I’m not spending my money until this problem is resolved. And I’m not gong to buy/build a new pc because of thos issue.

Im now a jRiver user but am anxious to give ROON a mouse click or two.
I’d be delighted to have a ROON expert troubleshoot this problem on my pc by remote.

Sorry if this sounds negative but ive spent several hours for several weeks tryng to find a solution.


Hey @Sgr – sorry for the trouble here. We can add some time onto your free trial once we get this resolved, so no need to watch the clock for now :smile:

Can you try running the utility linked in this post:

Just let me know what you’re seeing and I’m going to check with the team as well, since I agree that I’d think that GPU should be good to go.

Thanks for your patience Steven!

Hi Mike,
I’m away from home today. But im not usimg a grphics card. The Intel 4770k has graphics built into the CPU. I’ve not tried the utility you mentioned to find out about the graphics capability but I’ve gone to the intel site and tried to load the latest drivers. According to Intel, i do have the latest drivers. I’ve also checked with Gigabyte who made my MOBO. No luck there either. All drivers up to date.

Thanks for offering to reset my free trial.
I’ve had enough of jRiver and want to try something new. HQ player and ROON seem like the ay to go.

I provided a link earlier to the Intel site where the specs for the Intel CPU 4770k are located.


Hi, Steve, Are you having the same issue with both Win 10 and Windows Server 2012 v2? I would suggest working on solving the issue with Windows 10 first, getting that going, and then Server 2012 v2, as Sever 2012 v2 is going to need more tweaks than just the video to get it going. @Andybob can help you with that.

I have two suggestions off the top of my head:

If you haven’t done so, I suggest downloading and installing RoonServer, the non UI server interface, on your 4770k PC, and then install Roon on a separate PC for setup and control. That way video is not an issue on the server machine.

  1. But if you really want the graphic interface on the 4770k, then, even though I know you have the latest drivers, to make sure there isn’t a corrupt driver issue, I would uninstall the drivers, registry clean and then re-install the graphics drivers.

My PC dual boots for both Windows Server 2012 and Windows 10. I installed the ROON trial on the Server 2012 drive. I dont have a Roon trial for Windows 10. Ive used and installed many Windows programs on the Server 2012 without a hiccup.

So to me ROON programming must have a bug issue with the built in Intel Graphics in the 4770k CPU. And it is Open GL 4.2 i belive which should be better than 3.0.

Understood, but the utility will let us determine what version of OpenGL your system is reporting to Roon – that’s going to be the key factor here, regardless of the specs of your GPU.

Let me know when you’ve had a chance to run the utility, and feel free to follow @Rugby’s advice above as well. I’m sure we can get this working!

The trial is not tied to the machine really, it is tied to the log in. You can install Roon on 4 different computers and change which is the server and which the client.

I really suggest you attempt to get Roon going first on Windows 10. Windows 2012 v2 is not a straight forward install especially with all the software that you have currently loaded. The forums have several threads on how to get it working, but it is not a “run install and point it at the music” install that Windows 10 would be in comparison.

Please review this thread:

Just noting from the reference in Daniel’s (@Rugby) post that Server 2012R2 running in full GUI or Minimal Server modes ( and after installation of the Media pack) is quite stable with Roon with few issues reported.

Running the Audiophile Optimiser software added some real complexity and going to Core mode was difficult (I never managed it). I understand that AO have now published a version and process to get AO optimised Server2012R2 into Core mode with RoonServer, but I haven’t tried it out (waiting for Linux RoonServer).

These issues are unlikely to be the cause of the current OpenGL problem.

The utility found i was using Microsoft Graphics Processor. Which apparently doe not honor or work with Open GL 3.0. Intell thinks The 4770K chip spec sheet claims Open GL 4.2 I’m not sure there is such a thing yet.

The 4770k machine is my most powerful. That’s why i wanted to install ROON on it. My other pc has an AMD chip and basics graphics card which i use as my server. I don’t believe ROON would work on my AMD based server at all.

My next idea is to buy a graphics card to install on my 4770k machine.
What would you recommend? I’d like a card that has supports Open GL3.0 or whatever the latest spec is. I want no fan on board but plenty of heatsinks to keep it passively cooled.

I also needs to be compatible with the HD Plex H5.

Id welcome suggestions and thanks for all the help so far.


The 4770k is a 4th Generation Intel® Core™ Processor with Intel HD Graphics 4600. Did you install the Intel Graphics Driver from Intel. I think you might be using a generic microsoft driver.

Try the driver from Intel: Intel® Graphics Driver for Windows® 7/8.1/10* [15.40]

It should work great with that processor. I have my Roon Server on a Hackintosh that has a Core i5 2500k 2nd Generation Intel® Core™ Processor with Intel HD Graphics 3000 and it works fine.

Edit: My apologies, I overlooked the OS version: Windows Server 2012 v2.

Yes, I have several 4770s running the just the Intel HD graphics with Roon with no problem.

@Sgr You need to be running the Intel Graphics Drivers, which will give you Open GL 4.2. The Issue I think is Windows Server 2012 v2 with AO. Part of what AO does is turn off or remove pieces of the OS which are not directly involved in the Audio Chain. That is why I suggested you install Roon on the Windows 10 boot side. After you have gotten Roon running on Windows 10 and it is all great, then, we can have a conversation about what it takes to install it on Windows Server 2012 v2 alongside AO.

I also suggest you might want to run RoonServer (basically Roon with no graphical UI and because of that no graphical requirements) on that machine and then run Roon client to configure on another PC.

Hi all,
I did boot into Windows 10. The correct drivers are there. So Windows Server 2012 was the culprit. I plan to evaluate ROON using Windows 10 and then if still interested in using ROON work on the Windows Server 2012 installation.

Of course I wanted to start Roon right away. But have found that my 60 day trial via Audioquset has run its course. The ROON team has stated that they would reactivate my 60 trial.

I’ve emailed ROON support and not received any confirmation that my 60 trial is reactivated. I’ve not received any communication.

Is there any other way to get to get the ROON teams attention so I can embark on my trial and see what all the ROON interface brings to the table for myself?


I did try the link you sent me. It seemed to work but then I got a message from Intel stating this driver was incompatible with Server 2012.

Thanks for your help.


@kevin will follow up with you today @Sgr – glad you made some progress here!

Hi @Sgr, just followed up with you via email!