Intel NUC HDMI output suddenly gone silent [Resolved]


After weeks of flawless play through the HDMI output on an Intel nuc6i5syh roon server (Roon-identified as HDA Intel PCM MI 0 in Settings/Audio/ConnectedToCore), pressing Play this morning made no sound, with the play head never advancing past 0:00. Playing to other outputs (Airplay, or a laptop endpoint) works fine.

A Disable/Enable of this output via Settings led to a hang on the controller. After a server reboot the play head on this output now advances, but still no sound appears from the HDMI output. Volume control mode is DSP (changing to other settings has no effect), no crossfade no volume leveling.

Any log info I could peek at for a clue, or send to you?

Hi @will_welch ----- Thank you for the report and my apologies for the troubles. To help me better evaluate what may be going on here may I ask you to please provide the following information:

  1. A brief but accurate description of your setup as seen here. The more detailed you can be, the better :sunglasses:

  2. Besides rebooting the server, has the rest of your equipment been power cycled as well? If not mat I ask you to please do so and let us know if there are any changes in behavior.


I was able to bring sound back by clicking the volume icon on the controller to get the volume slider popup (which showed a healthy level), and wiggling that back and forth. Sound began after the wiggle.
On the way to doing that, I had tried disabling and re-enabling the output in audio settings (this had
solved a similar no-sound problem back when I first set up the system).

Config, for the record:

Roon V1.2/165 on core and controller
core is Intel NUC-6i5SYH running Ubuntu server 16.04.1 LTS
Music is stored on an internal 2TB drive.
controller is Mac Airbook OS 10.11.5

Hi @will_welch ----- Thank you for the report and sharing your observation with me :+1: Very glad to hear stability has returned to your setup, happy listening!


Oh no. Two years later and I’m back with the same problem
(I’d forgotten all about this, searched the internet with a description
and this article came up with my name on it!). I do not think this
is related to a Roon version change; I had simply not been using
the HDMI output for awhile until airplay became completely unreliable
and demanded a switch.

The latest version of this:

  1. Reboot the server.
  2. Playing music to the HDMO0 output makes no sound, but
    the playhead moves and level meters bounce in the UI.
  3. Wiggle the output level slider
  4. Music resumes, then goes silent after 10 minutes or so.
  5. Nothing I’ve tried brings it back except rebooting the server.
  6. Rinse lather repeat.

Reiterating my setup (nothing has changed except software versions)
Roon V1.6/416 on core and controller
core is Intel NUC-6i5SYH running Ubuntu server 16.04.1 LTS
Music is stored on an internal 2TB drive.
controller is Mac Airbook OS 10.14.2

What audio hardware are you using? I.e. what is the HDMI output connected to?

HDMI to a Panlong HDMI audio splitter. Verified this part of the chain by hot-swapping my Blueray HDMI output while a CD is playing.

Hmm. I just wonder if that test really rules out an issue in the HDMI chain. HDMI handshake issues, particularly if you’ve got a chain of HDMI devices (e.g. a NUC to an AVR to a TV) can easily arise. And hot-swapping will just cause a new handshake between the blueray player and the rest of the chain to occur. Let’s see if @support can suggest some further tests.

It’s a good theory, wish I had a better way to test it. Power-cycling the splitter had no effect. There’s no HDMI out of the splitter, I take optical audio out of that.

Meanwhile, when preparing to catch anything in the logs today, I found myself unable to reproduce the problem. Been playing music all day without interruption. Maybe reporting it to the support forum fixes the problem. See y’all in a coupla years.

Hi @will_welch,

Have you tried a different HDMI cable? Sometimes these cables can become defective due to bending them so it would be good to get that aspect out of the way first.

I would also take a look to see what the behavior is like with the HDMI splitter out of the mix. If you connect the cable to direct HDMI endpoint such as a TV or receiver, does it still display the same issue?

Since the issue resolved itself the above suggestions are just something to consider if it pops back up again, and if that is the case do let me know. If not… then happy listening :slight_smile:

– Noris