Internet radio not functioning properly


I have a Roon Core installed on QNAP TVS 471. The Version is “1.5 (build 334) stable”. I have a DAC “Chord Qutest” connected directly to the USB out of the QNAP.

Until today, I was able to listen to internet radio properly (i.e. with sound coming out from both sides of my speakers). However, since today, I am only able to hear sound coming from one side of my speakers (left side). There is no sound coming from the other side (right side).

Also to add, for playing normal music file residing in the QNAP, I have no issue in the past and also now. So the problem appears to be isolated to only internet radio streaming and only started today.

Would you be able to advise on what I need to do to resolve this issue?


1 Like

Thanks for reaching out, @Mong_H!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

May I also ask that you please verify the following:

  • Does this happen for all endpoints, or just the DAC mentioned above?
  • Have you tried rebooting your Core machine, networking hardware, and endpoint?


1 Like

Network setup as follow

  • Asus Router (AC88U) connected by lan cable to the QNAP NAS (TVS 471)
  • Roon Core is installed on the QNAP NAS
  • USB output of QNAP NAS is connected by usb cable to the DAC (Chord Qutest)
  • Asus Router is also connected by lan cable to another integrated amplifier with DAC (Hegel H160)
  • Control point is using Roon on an iPad and connected to the network via wireless


I can confirm

  1. Only internet radio streaming has issue (i.e. only sound out from one side of speaker). Playback of music file (e.g. flac) in the NAS will have no issue.
  2. This happens for the other endpoint as well, i.e. using internal DAC of an integrated amplifier and connected to the network via wire.
  3. Have rebooted or reset the Core machine, networking hardware and endpoint and the issue still persist.

Let me know if there are other information that you will need.


It might be useful to narrow down whether this is happening on just that station, or other stations with different streaming formats. The one you posted is an AAC stream

Try this one and see if it is still only 1 channel, It is a mp3 based stream.

I have tried the internet radio stream you have provided (Linn Classical) and it is working fine, ie sound coming out from 2 channels.


Thanks for the info, @Mong_H

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Additionally, may I ask that you include a screenshot of the signal path when this is occurring?



I have just tried 5 minutes ago and the same error occurs (sound from left side only).

The attached screenshot on the signal path as follow.

Thanks, @Mong_H! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to pass the diagnostics over to the team for further analysis.


Hey @Mong_H ,

I wanted to touch base with some good news, we were able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and we will keep this thread up to date as the team passes along feedback and work begins to get this resolved. Thanks again for the report!


Hi @Mong_H,

We’ve just released Roon 1.7 (Build 500) which includes changes that should improve this behavior. Please give it this a try and let us know how it goes!

You can read the full release notes here:

The Team at Roon Labs