Internet Radio stops playing on Linux [reproduced; fix in progress]

When I play a radio station Roon stops playing when it temporarily looses the connection to the stream.
This is quite annoying because each time I have to press play again.This happens frequently about every 5-10 minutes.

The behavior I would expect is that Roon restarts the stream automatically so I only hear a small dropout instead of having to run back to the remote and press play.

Other than that the internet radio functionality is just what I hoped for.

1 Like

I haven’t experienced this myself. Do you have any thoughts about why the stream is being interrupted ? Is there an underlying network issue ?

Not sure where or what to look for. I am not ruling out that it could be network related, but I can play music from both Tidal and my NAS without any dropous.

My Setup consist of a (35 Mbit) broad band connection into Router -> GS108T switch-> GS108T switch-> intel NUC with Linux Core -> Chord Hugo DAC.

Playing the radio steam on a SB Radio is much more stable here it rarely only stops playing.

What radio stream (or streams) are you having this issue with @Rune?

I get this too. It’s with the bbc radio streams here in the uk.
I have steam powered Internet, my router never gets beyond 3mega bits per sec. So in my case I put it down to the connection.

I am streaming local streams from Danish Radio this is an example:
DR P7 MIX and it stops playing after 10 minutes

I was able to play this station for over 5 hours straight yesterday. Any change on your end, or are you still having the same issues?

After your report of successfully playing for 5 hours I suspected my network so connected the server directly to the router instead of going through two switches.But that did not help so I installed the Roon Core on my desktop windows PC and it worked.
Then I suspected that it was the Vortexbox 2.4 install, so I installed Arch linux exactly as in the Howto guide.

But ended up with the same problem that the stream now stops after about 8 minutes instead of 10 minutes.
I also tried streaming Radio Paradise with same result stopped playing after 8 minutes.

The error message shown in the UI:
“Radio: Unable to playback this channel. Its address may have changed, or it may be temporarily unavailable”

So my conclusion is that it is either a Linux or a Roon Core on Linux issue.
I don’t have a clue what to do to narrow it down from here.
Any ideas?

Tried pinging google from a ssh session to the Roon Core server while playing the radio streams and while the streams stopped after about 8 minutes there where no packet loss or increase in response time from google.
There is no dropouts while using Tidal from Roon which point to that it is not a network problem.

Yesterday I have noticed also that my radio stream ( ) via the roon stops after few minutes . Had not chance to run the same stream directly via my other chain (minimserver+bubbleupnp+psa ds dac with bridge) in the same time as via roon, to make sure this is not the issue with specific stream, however i’m almost sure it’s more related to Roon itself (never had this issue before with the other setup before).

I have noticed that when stream stops Roon still report’s should be playing. Checking processes after few such stops and triggering Play again i have seen several avconv processes hanging around (possible one process per each hit “Play” for the stream.

I’m runnig Roon in the docker on Ubuntu 14.04.04 (64bit), then enpoint for this stream was piCorePlayer (Squeezebox ).

Here is the ps i have just ran - you can still see the avconv processes still hanging there from yesterday:

root@junk:~# docker exec -it roon ps axuwf
root 11424 0.0 0.0 15560 1116 ? Rs+ 12:26 0:00 ps axuwf
root 1 0.0 0.0 17956 944 ? Ss Apr24 0:00 /bin/bash /tmp/
root 50 0.0 0.0 17980 996 ? S Apr24 0:00 /bin/bash /opt/RoonServer/
root 55 0.0 0.7 548608 23792 ? Sl Apr24 0:12 _ /opt/RoonServer/Mono/bin/RoonServer --debug --gc=sgen --server RoonServer.exe
root 71 5.4 21.8 3061748 674768 ? Sl Apr24 67:28 _ /opt/RoonServer/Mono/bin/RoonAppliance --debug --gc=sgen --server RoonAppliance.exe
root 114 0.6 0.9 859240 28808 ? Sl Apr24 8:34 | _ /opt/RoonServer/Mono/bin/RAATServer --debug --gc=sgen --server RAATServer.exe
root 240 0.0 0.2 182300 8456 ? S Apr24 0:22 | _ /usr/bin/avconv -f mp3 -i - -f s16le -acodec pcm_s16le -
root 1812 0.0 0.2 182300 6416 ? S Apr24 0:21 | _ /usr/bin/avconv -f mp3 -i - -f s16le -acodec pcm_s16le -
root 1825 0.0 0.2 182264 8440 ? S Apr24 0:20 | _ /usr/bin/avconv -f mp3 -i - -f s16le -acodec pcm_s16le -
root 1865 0.0 0.1 182264 4680 ? S Apr24 0:20 | _ /usr/bin/avconv -f mp3 -i - -f s16le -acodec pcm_s16le -
root 2166 0.0 1.0 211612 33564 ? S Apr24 0:00 | _ /usr/bin/avconv -f aac -i - -f s16le -acodec pcm_s16le -
root 2679 0.0 0.2 182300 8708 ? S Apr24 0:20 | _ /usr/bin/avconv -f mp3 -i - -f s16le -acodec pcm_s16le -
root 78 0.0 0.0 7280 420 ? S Apr24 0:00 _ /opt/RoonServer/Server/processreaper 71
root 84 0.0 0.0 4376 308 ? S Apr24 0:00 tail -f /dev/null

I too have been having trouble with Internet Radio streaming just… stopping after a few minutes, and only when the Core is the Linux flavor.

I’ve confirmed this most recently streaming from RoonServer v1.2 (build 128) atop a Linux Mint 17.3 install (kernel 3.19.0-32, 16GB of RAM, Xeon E3-1225 V2 processor) to a Roon v1.2 (build 128) client on a Mac Mini running Mac OS 10.10.5. Available DACs are a couple of USB-connected ones on the Mac (a Schiit Bifrost Multibit and a Meridian Prime); the problem occurs with both DACs. I’ve been playing non-streamed library music from from this Linux server to the same Mac Roon instance, and it’s kept going fine for an hour so far.

The stream I tried most often is the WFMU 256k AAC stream, which I can play reliably to the same DACs using, say, a JRiver player on the Mac Mini.

I also experienced this same problem trying to play Internet Radio streams in an entirely different building, from a Linux RoonServer 1.2 instance to a Mac Roon 1.2 instance. In the latter case, I haven’t yet gotten around to trying again since build 128 came out, but with the original Roon 1.2 build I was having this same problem between Linux-hosted Core and… anywhere. When RoonServer v1.2 is running on a Mac and streaming to a number of endpoints around the house (Roon on the same Mac, any of four Squeezebox devices, an MS200), Internet Radio streams keep playing reliably for hours on end, just as they’re supposed to. It’s just the Linux port which seems to be particularly fragile.

Is there any log or other debugging info I should be looking for to forward to you?


Ok guys, I suspect this is a Linux issue, but @vova and I need to run some tests to confirm. @evand @Rugby feel free to let us know your experiences as well.

My theory is that something about our Linux builds with regards to networking or codecs is causing them to be less stable when playing back internet radio.

I’m going to set up two (or maybe three) Cores here tonight, one Windows, one Linux, and one OSX. I’m going to kick off playback of the same stream on all the platforms, and hopefully we’ll see differences between the platforms.

Stand by guys, we’re looking into it.

I’ll kick off an overnight test yet of windows 32 and linux.

Will do the same and revert.

I think we’ve reproduced this guys. With the station above playback seems to stop after 10 minutes. We’ve opened a ticket and we’re looking into it.

Thanks for the report guys!

1 Like

Can confirm same here, cuts out after 10 mins or so.

same here, stops after 10.05 :frowning:

RoonServer on Synology DS716+


Hey guys – thanks again for the report. This is fixed for our next release.


@mike, any eta for the next release?

The devs don’t usually give ETA for releases because so many things can change that then result in disappointment if an expectation is not met.

The best guide for bugfix releases is to look at their past frequency and note that the cadence quickens to a week or so between them after a major release like 1.2 in order to tidy up things that the Alpha testers let through (hangs head in shame ).

1 Like

Hello, I use Roon with an Antipodes DX. When I want to listen to the radio ( after 10 minutes the signal was cut. The following message is displayed : Unable to playback this channel. Its address may changed,or it may be temporarily unavailable. It’s the same with all the radio… Why ?