iOS devices crashing shortly after startup [See staff post]

It fine for a day or so. Then goes crazy. Tonight it was quitting after playing for 10-25 seconds. Power the phone down and back on was the only fix.

The app keeps crashing on my iPhone 11 Pro. Is this something happening to others ? I deleted and reinstalled the latest version today but the problem continues.

Same specs here…same crashing every 10 seconds or so when using the updated Roon app on my iPhone X. Renders app unusable and user experience horrible.

When I have the iPad language set to Polish, failures are very frequent. After changing to English, it is rare, but it does happen.

Still crashing…

I reinstalled Roon on my iPhone Xs then it worked, but after a week the issue returned.

Could this be related?

well possible. My iPad crashes have actually increased in 764 over 763

Hi @support any update on this? I’m still having the same issue with the latest version of the ios app - after running the roon ios app on my phone for a while it begins crashing, then continues to crash every minute or so, making it basically unusable (as I previously reported in a separate message that got merged into this thread on Feb 13).

Any update you can provide would be helpful.

Roon Rock on NUC5i5

Ethernet for Roon Core

Roon Remote app crashing every time on my iPhone 11 Pro.
It loads up fine and then 5-10 secs later it just crashes (even when leaving it idle, not doing anything).
The Roon Remote app is working fine on my iPad (or Mac), this is only an issue on my iPhone.
This is only an issue since updating to 1.8. Also, it was fine initially after updating but then a few days later it started to crash.

Same problem here with the following configuration:
iOS 14.4, iPhone 12
Roon App: 1.8 Build 764
Core 1.8 Build 764 running on macOS
RoonBridge 1.7 Build 571 on RasPi 3
No specific action needed, just start the app, after 10.20 seconds it crashes, music continues to play. No log files in iOS analytics found. iOS language is German, but crashes also under English.

My iPad Pro with the most recent iOS with Room version 1.8 Build 756 works perfectly - and I will not update it.

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

My iPhone app continuously crashes with rune 1.8 latest update. I’m not experiencing the same behavior on iPad.

The iOS app (on iPhone, not iPad) still crashes after just 10secs.
This has been an issue since the launch of 1.8…and is well documented on the community forums.
1 month on and it hasn’t been fixed. The updates to the app haven’t helped at all.
Don’t want to fuel more « outrage » but it’s just not acceptable.
I like the new layout and all, but the bare minimum is to have a stable, reliable app.
This is not the case

1 Like

Try this. The reboot has worked for others.

Thanks Slim. I’ve tried this already but unfortunately this isn’t a proper fix.
It solves the issue momentarily but then the app starts crashing again eventually (same for other people on this community)

Any news on this? I’m having the same problem rendering the iOS app unusable. It seems baffling that this hasn’t been addressed yet.

The storage usage of the Roon App is just crazy, no idea whats going on. see here:

I can confirm this: the app itself is about 380 Mb of size, but uses Gbs of “Documents and data” storage. I’m on iOS 14.4 with Roon app on version number 1.8.00764. Is anybody working on this?

Hi @dylan - just to add to everyone else’s comments - my app too crashes almost instantly upon starting it (say, within 20seconds).
I’ve tried re-installing it - no change.
I’ve tried re-starting the phone (iPhone 11pro running iOS 14.4.1 in English) - no change.
I do not have the same issues on my iPad.
Any news gratefully received.

Adding another report of this issue. This is my second time down the app crash road. Originally I experienced this same issue in v1.7 but that was resolved quickly by removing then reinstalling the app. This time I have had no luck fixing it. Even the new Roon versions that were released over the past few days (both app and core) had no effect. Strangely my iPhone, an iPhone 12 Pro, suffers from the instant crash on every launch. My wife’s much older iPhone (not sure the exact model but it does not have Face ID nor any sort of “notch” but it is not an SE) has experienced zero crashes. The same is true for her recent generation iPad Mini.

If you’re seeing this with a specific action, please describe the actions that reproduce this in detail

No specific action. In fact if I launch the app and just leave it there untouched it will crash in 10-20 seconds. If I shutdown Roon core, the app still crashes even if it never connects to a Roon core.

If the crash happens seemingly at random, how often does it occur

Crashes as I experience them are not random. They occur every time I launch the app within 10-20 seconds of launch.

Phone / iPad model

iPhone 12 Pro

iOS version


Core type

Roon Server on Intel NUC NUC10i7, Ubuntu 20.04.2 LTS, no GUI (nor any other frills for Ubuntu — this box is a Roon box and that is it)

OS Language

English (US)

Roon Language


One last thing I will add about language is that I do have a handful of tracks that contain non English characters (Russian and Japanese). Those characters do not have to be on screen for the crash to occur and I do not see any correlation. But language has been raised as a possible cause so I am mentioning it.

Hi, this is the same for me. I have an iPhone XS running iOS 14.4.1 with latest Roon build 778. When I scroll through my ‘tagged’ albums, for example my ‘Rock’ category, the app crashes almost immediately. The behaviour is, it freezes, and only a reboot of the app will restore functionality. Also, on the same device, sometimes artwork for tagged albums doesn’t display, effectively I have a blank display, I’m not sure what behaviour causes this but will look to reproduce and post an update.