iOS devices crashing shortly after startup [See staff post]

Happening for me too, note was also happening before 1.8 update:

  • If you’re seeing this with a specific action, please describe the actions that reproduce this in detail

Often happens almost straight after opening app (either connection loss, or crash), no specific actions trigger it

  • If the crash happens seemingly at random, how often does it occur

Sometimes within seconds of opening the app, but usually within 20secs of trying to use the app

  • Phone / iPad model

Iphone 8
Iphone 12 mini
Ipad 6th Gen

  • iOS version

All 14.4

  • Core type

Windows 10 Pro, Core I5 4310U CPU, 8GB Memory, 128 GB SSD, Roon 1.8 Build 756 64 bit. Dell laptop.

  • OS language

English UK

  • Roon Language

English UK

Sorry didn’t see this thread, so raised a separate thread here: Roon Remote dropping connection to Core and crashing on all of my IOS devices

Details from other thread below:

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro, Core I5 4310U CPU, 8GB Memory, 128 GB SSD, Roon 1.8 Build 756 64 bit. Dell laptop.

Used to stream from local NAS and with Tidal.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Google Wifi Router (Mesh with 2 mesh units) used as network DHCP server, connected to BT modem PPPoE (no double nat).
Gigabit ethernet network via TP-Link 24-Port Gigabit Ethernet Switch, TL-SG1024D

Core, connected via Ethernet, DHCP but static IP assigned by router
Music library on Synology NAS (shared folder), also connected via ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Project Stream BOX S2 Ultra (ethernet connection to network) → Benchmark DAC 3 via USB
Apple TV (x 2) (ethernet connection to network) using airplay
Naim Mu-so QB Gen1 (x 2) (ethernet connection to network) using airplay
IOS Remotes all connected via wifi:

  • Iphone 8IOS 14.4
  • Iphone 12 mini IOS 14.4
  • Ipad 6th Gen IOS 14.4

Windows 10 Laptop remote connected via wifi
Samsung Tab S SM:T700. Android 6.01 Remote connected via wifi

Description Of Issue

All of my IOS devices when used as remotes, continuously drop connection to the Core (frequency inconsistent - sometimes happens seconds after opening the Roon app, but always within about 20 seconds of using the app).

Sometimes the app reconnects, but often the app completely crashes. Roon pretty unusable on the IOS devices at the moment. This happened before the recent 1.8 release, and continues to happen after Roon 1.8 update was installed.

Affected devices:

  • Iphone 8IOS 14.4
  • Iphone 12 mini IOS 14.4
  • Ipad 6th Gen IOS 14.4

Have tried uninstalling and reinstalling the roon remote app on IOS devices, but no improvement.

The problem does not occur with my non IOS remotes e.g.

  • Windows Laptop (MS Surface pro 4)
  • Samsung Tab S SM:T700. Android 6.01

Non IOS devices stay connected to Core reliably, and do not crash.
Music streams to all audio devices reliably and is stable

Powering down my iPhone 11 Pro did the trick.
I’m on iOS 14.4. Was crashing after 10 secs (idle or navigating).
All good now

Latest OS all devices.
iPhone XS
Crashes randomly
UK English.
33 Gb of 64 Gb used.

Have reinstalled and cold started.

Remains unreliable.

This always worked for me, but after a while the issue returns… so it’s not a solution in my case.


I have done the latest update, did a hard reset on my iPhone 12 Max OS 14.4 and I have had no further issues. There was another update a day after the last one which is 1.8 (Build 756)

Random crashes, regardless of type of interaction with app.

iPhone X
iOS 14.4
Roon Remote 1.8.00756
Roon Nucleus

How do you get the crash log? Roon was stable for a few days on my iPhone and yesterday went nuts. Better today so I assume
It’s maybe something to do with the Roon servers?

Constant random crashes regardless of view (artist, album, search view, genres, settings, everything I’ve tried). About 5-20 seconds before each crash.

iOS 14.4
Roon remote 1.8.00756
Roon 1.8 (Build 756) on Ubuntu, 20.4, i5 4 core 3.2 ghz
iPhone SE2 and iPhone 11

This is a bit disappointing as I’m on the 14 day trial and can’t get a proper chance to try out Roon.

Update: Roon Remote on my older iPad mini 2, running iOS 12.5 doesn’t seem to crash (it’s been running for a couple of minutes now, which is clearly more stable that what I could get on my iPhones, running the lastest iOS). So it seems to be specific to at least iOS > 12.5.

I’d be glad to try out some test builds and send some logs, anything just to get some real Roon experience from this this trial. :slightly_smiling_face:

Hey, @support, I just got a crash log from RoonServer - from a fresh restart (system restart roonserver.service), all the way to the crash of the iOS app, some 1000 lines down the line. How can I send you the log?

One thing I’ve noticed since the update is slow response time on the iOS app on my iPhone 11 Pro Max. Like if I’m playing a song and click on another song from a different album it can take up to 10 seconds or so before the song plays. So it’s been lagging at times. No dropouts during the songs, just a bit annoying. Otherwise I’m loving 1.8. My setup is all wired with an sonictransporter i9. Fiber internet. Music stored on a NAS. I haven’t had these kind of slow response times before. I’ve also noticed the app crashes occasionally and I can fix that by restarting my iPhone.
Hopefully just growing pains with the new update.

You can try and find the logs using this method:

Or as I did, connect the app development software xCode and find logs through it.

My app has worked fine for a while now. Some times it stops responding and I quickly relaunch it and all fine again.

Good luck!

It fine for a day or so. Then goes crazy. Tonight it was quitting after playing for 10-25 seconds. Power the phone down and back on was the only fix.

The app keeps crashing on my iPhone 11 Pro. Is this something happening to others ? I deleted and reinstalled the latest version today but the problem continues.

Same specs here…same crashing every 10 seconds or so when using the updated Roon app on my iPhone X. Renders app unusable and user experience horrible.

When I have the iPad language set to Polish, failures are very frequent. After changing to English, it is rare, but it does happen.

Still crashing…

I reinstalled Roon on my iPhone Xs then it worked, but after a week the issue returned.

Could this be related?

well possible. My iPad crashes have actually increased in 764 over 763

Hi @support any update on this? I’m still having the same issue with the latest version of the ios app - after running the roon ios app on my phone for a while it begins crashing, then continues to crash every minute or so, making it basically unusable (as I previously reported in a separate message that got merged into this thread on Feb 13).

Any update you can provide would be helpful.

Roon Rock on NUC5i5

Ethernet for Roon Core

Roon Remote app crashing every time on my iPhone 11 Pro.
It loads up fine and then 5-10 secs later it just crashes (even when leaving it idle, not doing anything).
The Roon Remote app is working fine on my iPad (or Mac), this is only an issue on my iPhone.
This is only an issue since updating to 1.8. Also, it was fine initially after updating but then a few days later it started to crash.

Same problem here with the following configuration:
iOS 14.4, iPhone 12
Roon App: 1.8 Build 764
Core 1.8 Build 764 running on macOS
RoonBridge 1.7 Build 571 on RasPi 3
No specific action needed, just start the app, after 10.20 seconds it crashes, music continues to play. No log files in iOS analytics found. iOS language is German, but crashes also under English.

My iPad Pro with the most recent iOS with Room version 1.8 Build 756 works perfectly - and I will not update it.