iOS devices crashing shortly after startup [See staff post]

See Roon Staff Post

Original post

I updated both my iPhone app and the core app. The iPhone app crashes consistently in under a minute. Is this a known bug? Thanks.


Same issue here. Running on iPhone 12 Pro.

I have the Same Problems on my iPhone und iPad

Same issue on all iOS 14.4 devices. ipads crash from time to time. iPhone 12 Pro max crashes after 18 seconds automatically over and over without doing anything, iPhone 11 and the iPads don‘t crash automatically but also run unstabile.

1 Like

Mine crashes on any view, and iPhone is no longer listed as a zone either in the Roon core app or in the iPhone app.

iPhone 12 pro max
iOS 14.4
Roon Core Nucleus + Version 1.0 (build 227)
Roon Server Version 1.8 (build 753)

Every 20 seconds it crashes, App delete and reinstall doesn‘t help either.

Reboot of iPhone seemed to help - stupid I did not think about this earlier :grimacing:

1 Like

Thx for looking into it.

Some more details:

  • happens on whatever page/feature I’m visiting. I manage to get for example a song started but within 30sec after opening the app it just closes. Same thing when I’m just browsing. Doesn’t matter if I’m controling sound end points or just playing music locally on my iPhone.
  • not randomn. Just every time. Can’t do a thing with the app
  • I’m running iOS 14.4 on a iPhone 12 Pro
  • Core is a Mac Pro

Had the same problem, rebooting iPhone X did not resolve the issue but deleted the updated app then reinstalled from the App Store which solved the issue.

1 Like

Thanks! I deleted the app (again), rebooted, reinstalled the app, and now it appears to be working. Fingers crossed.

I have had a similar problem for around a week now and it occurred with 1.7 as well as 1.8. Using an iPhone Xr iOS 14.4. Roon core running on a Synology NAS delivering to a mix of end points - Roopie, Bluesound Node 2i, Sonos playbar, PC, Macbook, Oppo 203. Remotes on Macbook and PC perfectly stable. Iphone app seems to lose connection after 20-30 seconds and reverts to start display - but is still running. As previously stated, renders it pretty much unusable unless you select your choice really quickly! Browsing impossible. Having selected a trac/album/playlist it starts playing perfectly but by then the remote switches off.

I have the same Problem with my iPad mini 2, iOS 12.5.1, with my iPhone SE 2020 and my MacBook Pro, iOS Big Sur it seems there are no problems.
I hope, it will help.

I cured the issue with my Phone xr by simply turning it off and turning it on again. Doh!!! Had deleted the roon app, updated to 1.8 - and all it seemed to have needed was a cold boot. Presumably flushed some old nonsense out of the system.

  • If you’re seeing this with a specific action, please describe the actions that reproduce this in detail: first instance of the crash appears to be when scrolling through playlist

  • If the crash happens seemingly at random, how often does it occur: it will happen randomly and then after that will continuously crash after 20-30s of the app being open regardless of what action is being performed in the app until iPhone is restarted.

  • Phone / iPad model: iPhone 11 Pro

  • iOS version: 14.4 (but would happen consistently with older versions, as well as Roon 1.7)

  • Core type: ROCK

  • OS Language: English

  • Roon Language: English

Crashs with gay abandon here on an iPhone 12 Pro Max, English. Unusable really as a control point. Then again it was crashing with Roon 1.7. Have removed and re-installed, same issue.

I have installed version 1.8 and Roon won’t start. I went back to the previous version. The application starts without any problem. What could be the reason.
win10 64bit Core i5

I have had issues with the Roon app on my iPhone for a while. It was inconsistent and would crash randomly. The app has worked great on my iPad Air though. Since updating to Roon 1.8 the app on my iPhone crashes every time within the first 30 seconds. I have tried uninstalling and reinstalling but it does not help and restarting my phone and the core does not help either. Please help, the app is completely useless on my phone.

Phone iPhone 12 Pro Max
iOS version 14.4
Core Nucleus+
OS language English
Roon Language English

1 Like

App just closes after 15 to 20 seconds of just being open. Happens in Roon 1.7 and 1.8 does not happen with my two iPads ever.
iPhone 7 plus
OS 14.4 English
Core: sonictransporter i5
Roon: English
Router: Netgear Orbi

I’m on an iPad Pro iOS version 14.4 and the Roon app has not crashed since the last upgrade with the fix. Been using it all evening without issue.

Thanks for fixing it so quickly.