iOS devices crashing shortly after startup [See staff post]

Constant crashing. Rebooted iPhone. Worked. Then tried to skip tracks. Roon lost control of audio device. Roon is out of control.

I am about 2 weeks away from finding a different solution. Nothing has changed on my phone for months except the Roon build. Total crap for a paying service. Going on 6 months now.

I can’t recall exactly what I did to get over the problem, as it was a couple of months back. I think it was similar to your steps.
I haven’t had any problems for weeks now.

Still crashing on 987. Actually worse

@support what’s the latest on this? I’ve reported this issue several months ago. Not sure if someone’s on the other end of the line though. In case you’re wondering, it’s still happening.

1 Like

Still happening. App sits there for about 10 seconds without me touching anything just crashes.

@noris @support A progress update from someone at Roon would go a long way with the multiple people having issues.

Too lazy to read the whole thread. Sorry if the below has already been posted.

The fix which works for me and others whenever the remote on my iPhone 13 Pro starts misbehaving this way (rare) is to delete the app, power cycle and reinstall the app.

I know it’s not the fix we are looking for but at least it works and I get a few good weeks before it crashes again.

Adding other case of a total mess. Can’t search, browse new releases or do much but hit play and hope to for no crash. And yet, the app always crashes. Happening for months. Hello @support?

iPhone 12 Pro. Latest ios and latest version of Roon core on a 2018 Mac Mini. As core updates keep coming, the app gets more unstable.

Help please.

March 19, 2022 was first reported. Some incompatibility with iOS 15 and Roon. Funny how if I go back to 14.X it never crashes. Not an option yet definitely code bug.

Have the same self rebooting problem with the Roon remote on iPhone.

Found that when I login to another Roon Core ( say during travels, from a home Roon core to a MacBook Roon core), the old home Roon core is still being offered as a core for login into in the iPhone Roon remote.

I expect it to show only one valid core but two shows.

Hope this helps with the troubleshooting

Hello Everyone,

Apologies if it’s been a while since you’ve heard from us on this, but rest assured that this is a high-priority issue internally. Unfortunately due to the complexity of the problem and our inability to reproduce it reliably, it has been a difficult one to nail down.

Due to how locked down iOS is, it is nearly impossible to place any instrumentation around the app so that we can determine the root cause on customer devices. We can see RAM growth in the logs and then an app crash, but the reason why the memory grows in the first place is still unclear.

Based on user reports, we have observed some common clues, which suggest that this may be related to Roon’s interaction with the device’s network interfaces. Of these interfaces, a disproportionate number of users experiencing this issue have some version of IPSec VPN installed.

Based on this clue, we have attempted to reproduce the issue in the lab on a variety of iOS devices, and have even tried iOS devices with IPSec VPNs such as SlickVPN and Surfshark and have not seen the issue occur yet. Since we are unable to see this occur on our end reliably, it makes it quite harder to determine the actual root cause of the issue.

Our investigation is ongoing and it may take some time to uncover the root cause, but once we do so, we will be in a much better position to address it head-on. Thank you for your continued patience here.


Potential Fix:

Since turning off “enable Lock Screen controls” in the set-up tab of settings, the Roon app has 100% stable on my iPhone 12 Pro.

Worth a shot

Thanks for the status update. Communication like this goes a long way. Even a simple “we’re on it, but haven’t found the root cause yet” once every month / couple weeks or so, would put most users here at ease (or at least me).


A screen shot of the “set-up” tab would be useful, I am having trouble finding this in German. Thanks.

I actually didn’t work. Sigh. Back to crashing

1 Like

We plan to issue a build on Monday of next week which includes some code which will help us better troubleshoot this issue and may result in a potential workaround for those of you experiencing these frequent crashes.

This code will be enabled on a per-user basis and you need to opt-in for us to activate it. Once activated you will not have the ability to use ANY iOS device as a Roon endpoint. To be clear this will impact all of your iOS devices, not just the one(s) experiencing frequent cashing.

If you opt-in and later change your mind we can easily revert you back to prior functionality.

If you are interested in having this code activated on your account please reply to this thread and @benjamin will be sure that your information gets added to the list.

We will post more information here after the release is complete AND we have applied the change to those who opted in. Until you see that confirmation you aren’t running the new code.


Same here. Got worse in last couple of weeks. As I’m fully iOS in controls - cant/won’t sign up for test. It’s a bug introduced recently for me.

Fine on iPad OS

Hey everyone,

I wanted to give this thread a bump to bring attention to Andrews post:

Please let me know if you’d like to opt-in for this to be activated on your iOS device. Once activated you will not have the ability to use ANY iOS device as a Roon endpoint. To be clear this will impact all of your iOS devices, not just the one(s) experiencing frequent cashing.




@AMP, @benjamin Sign me up. The only reason I keep the iOS app around is to bugger you guys with the ios crash reports :sweat_smile: Let me know once it’s activated and I’ll try to reproduce it again.