iOS remote losing connection to Core

@dylan -

I get the same thing on my iOS tablet running as Remote. Yet, going to an i3 running Remote or the Core i5 machine finds that everything is OK. My core is connected to via Ethernet and, of course, the tablet is WiFi.

More and more frequently. Rebooting core solves problem until it re-occurs.

The endpoint I use the most is an SMS-200. Don’t know about the others.

I never bring down core or Remotes. I’m thinking memory leak, on the iOS Remote, since it doesn’t happen on the i3 Remote.

BTW - Although it says ‘initializing’ as if that were temporary, it never does initialize.

Hey @xxx — Thanks for the report.

Can you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

How is the i3 connected to the network?

When this behavior occurs are you actively using the remote device? Or is it idle/locked and upon returning to Roon it shows “initializing”?


i3 Remote and i5 core machine use Ethernet. Only iOS tablet seems to have problem.

Hmm, not sure. I would have to say it’s when I come back after Remote being idle.

Hi Slim,

I use an iOS Mini 3 as my usual Control. The response time varies, but is always slower than I would like. Usually the Roon screen pops up, then it connects and refreshes and then it is usable. That process takes 2-3 seconds which is an annoying amount of time compared to other iPad apps. The whole point of a separate Control is convenience of response and anything Roon can do to improve this is development time well spent in my view.

Sometimes, however, the iOS app gets stuck on a grey screen and either takes 10s or so to connect or doesn’t connect at all. This happens infrequently enough that I haven’t been able to identify any particular precursor steps. I usually resolve it by clearing the Roon app from the iPad memory (double click on Home button, flick the Roon screen up offscreen) and reopening it. Sometimes the iPad needs hard rebooting in order to fix a bad state.

Yeah, I don’t know why the Roon app does that. Why it has to refresh itself; no other app acts like that. This initializing thing is different and just started happening. It can only be solved by dropping the core, which is even more annoying. There’s always a display of some hex digits; maybe an address?

Seems like I tried that without success. Next time this problem happens I’ll double check.

Not the end of the world and the only reason I bothered to mention it was that it sounded like the same thing as the other poster was talking about.

Hey @xxx,

A good test would be to see if the same behavior when using the i3 machine over WiFi, if possible. This would help us determine if maybe there is something in the wireless connection or if it’s specific to the iOS device.

Definitely give this a try and let us know when it happens next.

Can you also confirm whether or not you have any “low power mode” or anything like that on the device?

During this time were you using any other apps? Or did the device go to sleep with Roon up and then upon opening you see this initializing message?


1 Like

Ha, I just double checked. My i3 has always been on WiFi. It’s only the i5 core that is on Ethernet. I’ve never had a problem with the i3.

No ‘low power’ settings, AFAIK.

Not sure. I’ll make a note the next time I have the problem.

Yeah, I’ll try restarting the iOS app and see if that makes a difference. I think I’ve done that with no results.

There is always a string of hex numbers, on the iOS Roon display that indicates the Roon app is initializing. Do you want to know what those are?

Thanks, stay tuned. :wink: