iPad can see the Core - "Choose Your Roon Core" and "Looking for Roon Core"

Roon Core Machine Nucleus

iPad OS 15.7.2

Networking Gear & Setup Details

Verizon Fios router, ethernet cable

Connected Audio Devices

Samsung T5 SSD; McIntosh C2700 pre-amp

Number of Tracks in Library

About 11,000

Description of Issue

All of a sudden the Roon Nucleus stopped communicating with my iPad, which has generally worked fine for about 3 years. It says …

“Choose Your Roon Core” and “Looking for Roon Core.”

I tried turning iPad off and on, turning Nucleus off and on, unplugging and replugging Nucleus. This occurred right after I added some tracks to the Samsung SSD and reattached it to the Nucleus.

Any ideas?

Before digging deeper - have you already restarted all network devices (router, access points)?

Thanks for the suggestion. I unplugged and re-plugged the router as well as once again powering off and unplugging the nucleus and my iPad. Still the same result. Still searching for the Roon core.

Next level would be to hook the Nucleus to a monitor or TV by a HDMI cable. At least during startup you should see some messages.

1 Like

When I turn on the TV, I do get basic info

Roon manufacturer, model, OS, serial number, hostname, and a message: Roon can be accessed by opening any Roon Remote product. If you don’t see this device there, check ‘Roon OS devices on your network.’ Roon OS Web UI can be directly accessed at:

I then got a message on the iPad seeking to upgrade the Roon which I did. Then it seemed to think I was looking for a “new” Roon core and it said to click “Go back” to get to my original core, which I did.

Then I got a message:

“Uh oh, something’s not right. Make sure your Roon Core is turned on and that you’re connected to the same network.”

When I click the question mark in the upper right side of the message, it says

“Roon will resume automatically as soon as your Core is available.”


Could your iPad be in the guest WiFi by accident?

No, it’s in the correct WiFi. I just tried removing and reloading the Roon Remote app in the iPad, but still can’t recognize the Roon core.

I should also mention that the Roon apps on my iPhone and Mac similarly cannot locate the core. While I’m not sure those apps are up-to-date anymore, this would seem to indicate that the problem lies somewhere within the nucleus. Wi-Fi is otherwise working throughout the house.

Both: Roon-App → Settings → About

I just tried unplugging all of my components, including the Nucleus, from the wall electrical sockets and replugging them. My iPad (and computer and iPhone) still can’t find my Roon core.

Is there anyone from Roon customer service who can help with this? It has become quite frustrating.

Delete Roon Remote from your iPad and reinstall.

Thank you. Tried it, but iPad still can’t find the core!

Using your internet browser, go to and post a screen shot of that.

Unfortunately all I get is an error message saying “Safari cannot open the page. The error was: ‘The URL can’t be shown.’” Similar message when I try it on Firefox.

Did you try plugging an HDMI cable into your Nucleus and connecting a screen? What does that show? Your M.2 might have died??

My Nucleus is always hooked up to my TV by HDMI. When I turn on the TV, I get the following info:

Roon manufacturer, model, OS, serial number, hostname, and a message: Roon can be accessed by opening any Roon Remote product. If you don’t see this device there, check ‘Roon OS devices on your network.’ Roon OS Web UI can be directly accessed at:

This indicates that the Roon is at least “alive.” BTW I am very grateful for your assistance, but I assume you are not a Roon customer service rep? Do they still help people here? Thanks again,



Yes they do, but the team is small (4 people) and their queue is often long. So that means others in the community chip in if they can.

You’ve established that the Nucleus is running, and is apparently accessible at IP address It is strange that you get a Safari error when you enter that address, which leads me to ask: what is the IP address of your iPad?

What I get from reading through this thread is that

  1. The Nucleus boots fully up, and shows its IP on a HDMI-connected TV screen.
  2. Neither iPad, nor iPhone or Mac computer, supposedly connected on the same WiFi network, can connect to the Nucleus.

Could it be that the Nucleus lost somehow its network connection? How is it connected to your network? Have you tried to unplug and replug the Nucleus from the switch or router where it is connected? Have you tried using another Ethernet cable? If you open the Terminal app on your Mac computer, do you get replies if you ping What do the LEDs show on the Nucleus Ethernet port?

The Nucleus is “hard-wired” to the network with ethernet cable. I have tried unplugging and replugging and restarting pretty much everything, including the Nucleus, router, iPad. I haven’t tried another Ethernet cable. The LEDs on the Nucleus ethernet port are blinking like they previously did. Not sure what the Terminal app is–it isn’t listed in the apps on my Mac.

I haven’t noted previously, but it occurs to me this problem started right after I added a number of new tracks to the Samsung SSD used with the Nucleus. It seems far-fetched, but could that somehow interfere with the Nucleus being recognized by my other wifi devices?

It is in the ‘Utilities’ folder under Applications. You also can find it using cmd+Space and type Terminal in the search field. You can then start a terminal session and try to ping your Nucleus:


It still is possible that your WiFi-connected devices (iPad, iPhone, possibly Mac computer if not hardwired) are on a different subnet that the hardwired devices (Nucleus). This is what @Geoff_Coupe implied asking for the IP of your iPad.

If you start a terminal session on your Mac computer, you can look up the current device network address like this:

ipconfig getifaddr en0

If this doesn’t return anything, try with en1 instead of en0.

Edit: To look up the current IP of your iPad, you can tap ‘Settings’, then ‘WiFi’, and then the blue information icon to the right of the network name. Then tap on ‘DHCP’ to find the IP address.