iPad lose every one minute connection

I had the same problem with my iPad. Disconnects every few minutes. I fixed it by purchasing an inexpensive Netgear router - one that supported wireless N, which my older router did not. Connected the iPad to that. Resolved.

Cannot possibly be the router. I have a $200 Verizon FIOS Quantum Gateway router.

Besides, it was working fine for the whole time until three days ago.

I did everything I could. Uninstalled and reinstalled the iPad app, rebooted router, uninstalled and reinstalled Core on PC.

Issue still persists. I wish I can post a video here, but don’t know how to.

@support

Any solution to this problem? It is becoming unusable. Thank you

I noticed the same problem on my iPad Air 2 yesterday. Never had similar problems before. I hope this will get fixed soon.

Hey guys – we are investigating this issue. It’s possible that certain kinds of networks or configurations are being affected by some recent bug fixes, and we are going to look into that.

That said, I’ve been using an iPad here for the last hour, and thousands of users are running our iOS apps without issue. We’ve also heard about connectivity issues before the recent bug fixes, so my gut feeling here is that if there is an issue in Roon, it’s almost certainly triggered by something environmental – meaning, you may be experiencing different issues from others due to how your network or Core is configured, or which hardware you’re using.

And to be clear, it’s entirely possible that your network or setup is 100% fine and the issue is that Roon is behaving badly in certain environments. This is not an attempt to just say “fix your network” and leave you guys in this state. We need to figure out what makes your setup different, so we can test a similar configuration in house, reproduce the issue, and resolve it. That’s the only way forward here.

So, @thyname @Henry_Larsen @John_Roberts @stevev1 @Petri, as we investigate this, can you all confirm some details for us?

If you haven’t already done so, please let us know:

  • Core platform
  • Core hardware
  • Router model
  • All hardware involved in your network, including any switches, extenders, ethernet-over-power hardware, mesh networks, etc
  • How everything is connected, meaning what’s on wifi, what’s ethernet, what’s using EoP, etc
  • How everything on your network gets an address, meaning are they running DHCP or static
  • The exact details of what you’re seeing, meaning are there errors, what are they, how often do they happen

As soon as we have this information, we can start to look for patterns to direct our internal testing and try to reproduce this in house.

Finally, I would strongly recommend against assuming that any given network hardware is working as expected just because it’s expensive, or because you’re able to load websites. Over the last 10 years, we’ve seen networks fail in unexpected ways due to where you’re sitting on the couch (ethernet cable under the couch leg). We’ve seen $5,000+ home networks that were slower than the $40 dollar router they replaced. And we’ve seen router chipsets used by multiple major manufacturers that were unable to handle basic multicast traffic without crashing.

Point being, in all these cases, the network appeared to be working, but wasn’t able to handle standard traffic, which Roon depends on to work properly. In all these cases, we were able to discover the issue with patient troubleshooting and process of elimination, and resolve it.

I don’t know if there are networking issues happening to some of you, all of you, or none of you, but I can tell you we are on it. The first step is to get the above information from all of you, but we intend to stick with this until we get everyone stable. I appreciate everyone’s patience.

3 Likes

Thank you - I know too well what you mention about networks and their now and then strange behaviour. You should know that I appreciate and admire your willingness to make everything work.

Core platform
Linux Mint
Core hardware
NUC 4th gen, I5, 16 GB ram, with linux and Roon on mSATA disk. NUC attached to Switch (Zyxel gigabit with cat 6 cable).
Router model
ASUS RT- AC66U
attached to the switch, also with a cat6 cable, same with Synology server with music.

All is running DHCP.

Three raspberries, with Dietpi and Roon all on wifi, until yesterday not updated, to last Dietpi and Roon, two with USB Dac, one with I2S dac (Hifiberry). They are all playing rock solid and also were before the update. Same with a PC on wired internet from switch ( With Meridian explorer 2) and on macbook, occasionally linked with USB DAC.

I have checked that all are updated to latest Roon.

I have not seen any problems with the Ipad today (Air model MD788KN/A), (does the update of the pi’s matter??). But as mentioned, since update to 1.3 we have had to restart the Ipad frequently because of blank screen in Roon, or freezing screen. I have also frequently seen that radio stations have disappeared, but arrived again with a restart of the IPAD. I have several times cross-checked with my macbook and with my Android phone ( LG V10, android ver. 6.0) and have seen no problems there.

As mentioned, no problems today - so let’s see.

I’m running Roon Server, HQPlayer and Devialet AIR on a following computer:

  • Windows 10, 64-bit
  • Hardware: i7 6700K, 16GB RAM, 256GB NVME m.2 SSD boot drive, 1TB SSD for music, Geforce GTX 670.

This computer is connected to the Apple Airport Extreme by an Ethernet cable. Apple iPad Air 2 is connected to the Wifi that is created by the Apple Airport Extreme. All are running DHCP.

The remote seemed to loose the connection on every 1-3 minutes. Sometimes it just crashed and I needed to open it again.

Core: NUC5I5RYK, Crucial 8 GB SODIMM DDR3L-1600, SAMSUNG 850 EVO SSD M.2 120 GB running roonserver on Ubuntu 16.04
Remotes: IPad mini 4, iPhone6, retina macbook pro late 2012
Router: new airport extreme IEEE 802.11a/b/g/n/ac
Endpoint: bluesound powernode2, connected to the airport via ethernet cable

nuc is connected to the airport via ethernet cable, no switch on the network

All remotes are on wifi, all DHPC

I have the same problem with my iPad Pro.

The problem started after the update to 1.3.

I thought I’d post an update. I am one of the "complaining " users.

Thursday night, I did two things at the same time:

1 - Took the PC where Roon Core is installed and connected it directly to the router. Previously connected to an Ethernet switch, which was connected to a MoCa adapter.

2 - changed the 5 Ghz band from Automatic to a fixed channel, whatever the inSSider Windows tool recommended. I was using this band for my iPad.

I don’t know which one did the trick, or whether it was just a coincidence, but this fixed the problem, at least for the past 48 hours or so.

I hope this helps

1 Like

Would you mind giving us some of the details of your setup? There’s a list of what we’re looking for in my post above. Thanks!

@thyname – thanks for the follow up – very helpful! Keep us updated and let us know if you have any changes, better or worse.

Everyone else, we are looking over this information to identify any commonalities here, in the hopes of reproducing this issue. We’re doing testing in house, and hoping to make some progress on this soon. Thanks everyone for the feedback, and for your patience!

Sorry about the delay in responding to you.

I have Roon 1.3 installed in a custom made NAS built to the specifications recommended by Roon. The NAS is a 64 bit system, powered by an Intel i7-4790K Quad-Core 4.0 GHz LGA 1150 88W Desktop Processor (16 GB Memory) mounted on a Asus H97M-E/CSM LGA 1150 motherboard. All music is stored on a single Seagate ST8000NE0001 hard drive. The NAS operating system is WHS 2011.

The NAS is connected directly to the router (Apple Time Machine) with a CAT 6 cable. I also have an Apple Airport Express to extend the range of the wifi. The router mode is set at DHCP and NAT and the two DACS (Merging NADAC 8 player and Logitech Transporter) and NAS have been given static DHCP connections.

I have Comcast as an ISP and typically have a 200 to 250 mbps wi-fi connection, even when the wireless remotes (iPhone 7 and iPad Pro) lost the Roon connection. When I am playing music, there are rarely any other devices accessing the wi-fi on the system (with the only exception of e-mailing or texting).

I have already provided a pretty detailed description of the connection drops I have experienced with my remotes. Sometimes they both experience it simultaneously; sometimes one connects when the other doesn’t (but the one that connects, in these instances, it inconsistent). Sometimes it appears that Roon “comes up” when I turn it on, for a flash of a moment, only to get the lost connection screen. Sometimes the lost connection screen persists for several minutes and then gets connected; other times, the iPhone/iPad goes back to sleep before connection is restored. Sometimes, exiting and re-entering Roon (via remote) seems to restore the connnection; others it doesn’t work.

There are two DACs that are connected to the NAS via a Netgear JGS516 ProSafe 16-Port Gigabit Ethernet Switch (JGS516NA). CAT 5E and CAT 6 cables are used as connectors.

There are about 30K tracks in this collection, although Roon claims there are 61K tracks (I think there are a lot of duplicates). The tracks are wav formatted – I used dBPoweramp to rip them from CDs.

After reading about the solution that thyname published, I have changed my 5Ghz band from Automatic to fixed channel (161). [My NAS had been directly connected to router already.] I will report on how this works in a few days.

Let me know if you want any more information about my set-up or the problems I am experiencing.

A couple of days ago, i implemented the “thyname” modification to my set-up. Since I had already connected my NAS to the router directly, the only thing left to do was to change my 5Ghz setting (in my router) from Automatic to Fixed Channel (not really knowing which one to chose, I selected the highest setting, 161).

Beginning immediately and continuing for the past two days, my two remotes are behaving very differently than before. Roon boots up quickly (the longest “lag” has been a couple of seconds … maybe) and refreshes even more instantly. This has been true for both my iPhone 7 and iPad Pro.

I still hear “my inner cynic” telling me that this is too good to be true. However, after 40-50 consistently successful “tests” (including re-boots of my NAS, iPhone, iPad, and Roon (alone), even he is not sounding very convinced.

I am considering my issue with this resolved for now and suggest that anyone else having the same problems with their remotes try this.

For me, the problems with the remotes losing connection has been very frustrating (and humiliating). I am grateful for the generous help and support provided by the Roon community.

Thyname, thanks for the suggestion.

1 Like

Awesome! You are welcome!

Since I posted my (hunch) solution, I have had zero problems.

On another note, I used a Windows tool called inSSider to find out the optimal channel for the 5 G band. This is helpful when there are neighbors around with signal interference.

OSX has a similar tool built right into the OS. Option key and press on your wireless status icon. Open Wireless Diagnostics. From the Window menu choose the Scan window.

It won’t tell you the best channel to choose but gives you the information needed to pick the right channel.

1 Like

Hello everybody,
Also good news from the Netherlands.
Today I had some time to test different things. Inspired by @thyname I checked the use of different channels on 5GHz WiFi.

My core-server and iPad are already connected to the same switch/access point. The core-server wired, the iPad wireless on 5GHz. I changed the 5GHz from automatic to fixed channel. Channel 138 give the best results and the connection is now stable. At the moment the system is now 8 hours running without any problem.

I’m so happy !
Have a nice weekend !

2 Likes

15 posts were split to a new topic: Remote connection issues with iPhone 7 and Gigabyte GB-BKi7-7500

Two weeks further, I’m not satisfied. The disconnections are back, not every minute, not every day but random on different times. The last week I have done a lot of testing, even bought a new router! And now I think I have found the problem which is reponsible for the disconnection on my iPad.
At the moment a workaroud is running. But, I’m running out of time, I must go now. Tomorrow you recieve more information.

I’ve also discovered this bug recently with my iPad Air (early 2014, 1st gen) and latest iOS. Dropouts with very short intervals, like every 1-2 minutes and then it reconnects immediately in 0-2 seconds. This is still superbly annoying and depending on where you browse the library, it might take you back to the beginning of album browse or something similarly annoying when reconnecting. This problem appeared after some of the last few updates to Roon.

Core platform: Win10 64bit with most recent updates

Core HW: AMD FX-6300, 16gb RAM, Gigabyte GA-78LMT-USB3 MB, Gigabyte, Geforce GTX 1050Ti, SSD Crucial MX100 128gb (Roon is installed here), Storage: Western Digital WDC Red 3tb.

Router/wireless: D-Link DIR868L connected with ethernet to my PC (Realtek GBE family controller with most recent drivers) which runs the core. Static ip on the PC which runs Roon core, otherwise DHCP. Audio runs runs through USB to my audio system.

The error is Lost connection which flashes for very short duration, usually under one second and then Roon remote reconnects immediately.

iPad connected through 5ghz wifi and auto channel scan. I tried the earlier fix by manually selecting the channel but it doesn’t help. I’ve rebooted the router, rebooted the iPad, rebooted the PC, installed Roon again on iPad but none of these helped.

Any update @mike ?