iPad lose every one minute connection

For a moment, I thought it was gone. Not a dropout in over five minutes, but then there it came again. I continued experimenting with different wifi channels. I only have four options with my D-Link router, 36, 40, 44 and 48. Now running 40 and it has the least dropouts I think. But it’s still happening frequently. Weird issue…

Anyway, it must have something to do with the recent updates to Roon since I’ve never had this problem before.


Happens with my iPhone 7 also.


I took a video of the dropout on my iPad. Happens after 25 seconds:

Here the screen only blinks for a second but sometimes it throws you to beginning of album view or somewhere else after reconnecting.

If your router has a WiFi region setting, set it to USA.

Assign different SSID for 2.4GHz and 5GHz in your router. Switch your iPad to 2.4GHz SSID. Try channel 1, 6, or 11. See if it behaves differently.

No region settings and all other settings have been on auto previously and everything’s been working good.

2,4 and 5GHZ connections have different SSID’s. I tried with 2,4GHz on channel 11 with immediate dropout then with channel 6 and with that I got almost 10 minutes before dropout but now it happened again while writing this. I didn’t try channel 1 yet, feels pointless to me since this doesn’t feel like a real fix to the problem, only temporary solution.

@mike … So we are 24 hours further, the system is stable; solid as a rock :wink:
The workaround seems to be the temporary solution.

Last week I have build a secondary small network totaly isolated from the core network. This network has a new router (ASUS RT-AC3200). The router was directly connected with the internet, the core and Synology NAS. The iPad Air2 is wirelles connected on 5GHz with this router. Man o man, this is really fast, bloody fast! The average speed between the router and iPad is 879 Mbit.

Unfortunately the problem stays; random disconnections on the iPad.
The router wireless signal is extremely strong. The distance between router and iPad is less than one meter.
Further I see the same thing as in my core network. The profile picture is blinking every minute, the picture disappears 1 second on all my systems. This are three Windows10 clients, two iPads air and four Android smartphones.

Yesterday I saw a post in this topic about problems with the iPhone. I don’t now the name, but this post is moved to a another or new topic. For me was interesting the discussion about the Windows firewall. This was for me the only thing I have not tested yet. So let’s rock and roll !

I decide to switch off the firewall on the Windows10 core-server. I reboot the server and restart the Roon remote app on my iPad. I could not believe; all problems disappeares. No blinking profile pictures on all machines; no reconnection issues on the iPad. Everything is now more than 24 hours fully stable. Now we are talking ! For the fun; I cascading three switches between core server en the router. No problems, the system stays fully stable !

Today all components are back in my core network; fully stable, no blinking profile pictures and no reconnections on the iPad. So, in my environment the Windows10 firewall generate all the problems I had. On the new router I don’t use fixed channels, I change the 5GHz transmission power to low, no problem everything stays stable. I go with the iPad to the garden (50 meters), everything stays stable.

When I switched the Windows10 firewall on; all problems are back.
Don’t forget to reboot the core server and to restart the Roon remote app on the iPad When you turn off the Windows10 firewall.

Next step; why gives the firewall the problems in my environment ?

1 Like

Thank you René, this might’ve been the solution. I disabled the Windows 10 firewall (I have one in the router anyway) and over 20 minutes without dropouts now. I’ll continue testing tomorrow. But still, only a temporary fix since everything worked fine in previous builds.

Try adding Roon to Windows Firewall exception list.

I am now having driving Roon from a Linux server, but on a Windows machine I noticed that it tells me that the firewall is not accepting all calls from Roon - so maybe it is a good general advice to ask people, who are using Windows to be aware of the firewall and add Roon to the exception list.

Well this makes it even more weird since roon.exe and RAATServer.exe were both on allowed list on Windows 10 firewall. I checked before I disabled the firewall.

This morning I did some more experimenting. I turned the firewall back on and tried to look for advanced settings which might’ve had something to do with the dropouts. What I first noticed was that there were total of eight Roon related allow rules under the Windows Firewall -> Advanced settings -> Inbound rules. Four for Roon.exe and four for RAATServer.exe. Most other applications only had two per process. So a duplicate rules for Roon processes. I deleted all the eight rules and re-opened Roon. Now Windows firewall asked during the startup if I want to allow Roon.exe and RAATServer.exe network traffic and I clicked allow. Now there’s only four Roon related rules on the list, just like all the other applications have.

After this process I haven’t had any dropouts at all even with Windows firewall turned on.


Today I did the same test as @patouskii with the same results :slight_smile:

Yesterday I saw also eight firewall rules for Roon for incoming and outgoing traffic.
I delete all rules and add them manual, no results.

Now I deleted all roon/raat rules in the Windows firewall and reboot the core server.
I started manually the roon core software and the firewall cames withe three pop-ups for raatserver.exe and roonappliance.exe.

I’ve checked the firewall rules. Only for inbound traffic are two rules for raatserver.exe and two rules for roonappliance.exe set. Both four rules are active.

So, at the moment the firewall is running with the new automatic rulessettings (4) for raatserver en roonappliance. Everything works good the last two hours :slight_smile:

1 Like

probably notices from the older version of Roon.

So, the problem is back today. More testing with the Windows firewall ahead. Now I only disabled the private network firewall and it seems to have done the job again, no dropouts for a while.

Would be nice to get some feedback from Roon team, thanks.

System is now more than 24 hours stable.
No blinking profile pictures, no reconnections.

System is now more than 3 days stable.
No blinking profile pictures, no reconnections.

Works fine here also, now when I’ve disabled the private network firewall of the Winodws 10 firewall. Still, I think this should be checked at Roon.

Same problem on iPhone 7 and iPad Air 2!!

Wanting to try the firewall suggestion but prior to release 1.13, my iPad never had an issue with this. Now it happens constantly.

So, tried the firewall fix (deleting inbound rules and restarting roon) but the problem persists. The lost connections are not as frequent, but my roon screen on the ipad now goes blank when they do occur. The music continues to stream but the rest is a blank page. :unamused:

Update: Deactivated private network firewall. No change, problem persists.

Did you follow the steps exactly I described?
All rules, in- and outbound must be deleted.

Close down roon, restart the computer with the firewall, it’s important the firewall starts first!
Restart roon, you must get firewall popups. (you can start roon manually).
Check the firewall rules. Only for inbound traffic are two rules for raatserver.exe and two rules for roonappliance.exe set. Both four rules are active. I have no rule for roon.exe.

My system is now more than 10 days stable.
No blinking profile pictures, no reconnections.

What happens when you disable the firewall ?

Hi Rene,

Followed your rules exactly as written but it did not fix the problem 100%. Also with the firewall disabled, I still get random disconnects. In the interim I have also manually set my wifi channels, updated the firmware on my router, and double checked all network settings to see if anything my be set incorrectly, but the problem remains.

Given that everything was working prior to the 1.13 upgrade, I can only conclude that it must be somehow related. Bit stuck at the moment.

@Bacon_Brain what’s your network topology? Those powerline ethernet adapters have also been know to be the cause of issues as an example.