iPad no longer shows many of my album covers even though iPhone does

Roon Core Machine

Innuos Zenith Mk2

Networking Gear & Setup Details

eero Pro 6 mesh
Innuos Zenith Mk2

Connected Audio Devices

USB from Innuos to Ayre QX-5 Twenty DAC; DAC to Ayre KX-5 Twenty preamp via XLR interconnect; Preampto Bryston 3B Cubed amp via XLR interconnect; Bryston to Salk Veracity H2TL speakers via Kimber Kables

Number of Tracks in Library

2000 albums (some are downloads or ripped CDs, most are on Qobuz)

Description of Issue

I use an iPad (8th gen) and an iPhone 12 as remotes.
The iPhone shows all the album covers but many of those album covers are no longer shown on the iPad (although they used to be shown on it). I previously used an iPad 5th gen and for some unkown reason many of the album covers disappeared. Thinking that the cause might have been that the iPad 5th gen had run out of memory, I upgraded to an iPad 8th gen, but those same album covers still don’t show.
In many cases when I click on the space above the Tracks for the album cover of the album I’ve selected to run, the album cover art will show, but it disappears once I go back to the album tracks.

I should add that the eero is connected to the Innous via ethernet cable.

I have similar problem with album cover in new Roon 2.0 Album cover is not show on album table but exist when hit the album. Not only one but several. Here I am attaching screenshoots what is going on.



Look at album for example by Mark Olson, Salvation blues

Thanks so much for the advice! Clearing the cache restored the album cover art.

1 Like

2 posts were split to a new topic: Roon 2.0: Missing Album Art in Library/Browser on Mac

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.