iPad remote can't connect to ROCK Core


I’m experiencing the same and indeed a bit better with the latest update. I’m running Tidal and tried the demo from Qobuz and did not continue with Qobuz because of slow performance.
Now only running Tidal and a local library of 5400 albums. Disabling Tidal is still improving the response.

Ipad interface is still slow in responding (compared to Roon 1.5).

This morning a new problem occured since I’m running Roon (July 2018), the iPad app could not even find Roon Core. I could go to the Roon Rock interface using the webinterface on my iPad where I tried to restart Roon Core. This did not help. Then I did a full Reboot using the webinterface and then the system was running again. Trying the app on my iPhone did also not work.

Roon Rock running on Intel NUC 7i5BNH with 8Gb Ram & 256 Gb SSD - server use only - No DSP enabled
QNAP TS421 with music library
Sonore UltraRendu client
iPad mini (4) as control point
Wired Network (except for Roon control via iPad)

Hi @Benedikt_Gruyaert,

Can you describe your current networking setup?

  • What networking hardware is in use (router, switches, etc.)?
  • How are your devices connected (i.e. to which devices)?
  • Can you confirm that all devices are on the same subnet?

Are other all remotes unable to connect to the ROCK Core?

Hi Dylan,

Devices & connections:

  • My router is from my network provider (Telenet CH7465LG-TN) directly connected to a central DLINK DGS 1100-24.
  • The router has 3 accesspoints (Telenet AP7465CE-TN) with “flow” technology direclty connected to the router to enlarge the wifi .
  • The sonore Ultrarendu is connected to a DGS108 switch connected to the central DLINK (switch only used for Audio Network)
  • The Roon Rock (Intel NUC) is directly connected to the central DLINK
  • The QNAP TS421 NAS is direclty connected to the central DLINK

All devices are on the same subnet.

When the app is not responsive I can reach the Roon server by the explorer (Safari) using the the same (wireless) device.

I have no other devices in use to connect except occasionally from my windows 10 pc (also direct connection to central DLINK swich).

Hope this helps…

Just wanted to chip in that I have a similar issue with my Android. I need to restart the Roon Core Server machine to be able to connect via a Huawei tablet. It’s working without hiccups via my Android phone though. I have now created a scheduled task which restarts the server every day at midnight, for the time being this works.

Hi @Benedikt_Gruyaert,

When the iPad is in this state, do you see the same behavior from the Windows 10 PC or is it only the iPad that experiences this?

Hi Dylan,

I didn’t try when this happened. My pc is not in the same room where use Roon…

Hi @Benedikt_Gruyaert,

Knowing if this affects all remotes or just one remote is definitely a great data point for our troubleshooting. Knowing this info helps us to better pinpoint where this behavior is coming from.

I noticed that the switch you’re using is a managed switch. Generally, we recommend against this type of networking gear because they often require some advanced setup work in order to function properly. You can read more in our Networking Guide. To start, I recommend looking at our info there any adjusting the settings on the switch accordingly. Let us know if this yields any changes here.

Hi Dylan, all settings are as required. I temporary replaced the switch with a non managed switch but I still have the slow response when I search my library with Tidal activated. Searching on my NAS only is very fast.

Hi @Benedikt_Gruyaert,

With this configuration was there any improvement to the iPad connection issue?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.