Is this normal? Roon Qobuz favourites do not show in Qobuz only favourites

Let me try and explain my question…lol.

When using the Qobuz app for example and I add albums to MyQobuz they also get added to my Roon library which is great.

However when using Roon and I add albums to my library which are from Qobuz they do NOT get added back to my Qobuz only favourites list.

Why would I care about this? Because I travel for work a lot so usually streaming Qobuz to whatever rental car stereo I have and to not have a lot of the albums available that I added via Roon is pretty annoying tbh.

Is there a setting for this or any way to “export” my Roon Qobuz albums to my Qobuz only favourites?
Hope I explained that well enough, if not I am sure you will let me know!
Thanks and stay safe.

Hi @kevin_raynard, I suspect you may have mis-explained your issue in the text.

My belief is that when you add a Qobuz album to your library it shows in your favorites. Roon favorites are handled differently, and that’s what you mention in your post title. Reading the 10 posts or so below this one: Can't play next track? Atrociously counter-intuitive - no, thanks might clear things up for you.

What I meant was I wished it was a two way thing.
Adding albums via Qobuz app adds them automatically into Roon.
Adding albums via Roon app does not automaticaly add them into my Qobuz app even though they are Qobuz albums.
This means I have a ton of Qobuz albums saved under Roon that do NOT show in my Qobuz app which is truly annoying.

1 Like

And to those who wonder why I want to bother with Qobuz when I have Roon, that is also explained.the RoonToGo would help I am sure.
When…lol

Probably not a particularly helpful reply, but if I add a Qobuz album to my library, that album also appears under ‘My Qobuz’ in the Qobuz app. I guess it’s possible there’s a setting that needs tweaking in your setup, but I’ve always presumed it was an automatic two-way thing.

Michael

Michael
No it is most helpful indeed as if that is the case then it shows I am missing something as that is exactly what I would like to happen.
So the question is what setting am I missing?
And is it in Roon or Qobuz.
Thanks

The two-way sync should be permanently enabled - there is no setting to turn it off. The only sync setting is to manually force a (two-way) sync to occur. (Roon Settings > Services > Edit Qobuz > “Sync Library Now”.

If it’s not working for you, I suggest you raise a Support case with the Support team over in the Support Forum (Click New Topic, and fill in the template).

I just tried a manual sync force but that did not work either.
All that shows in My Qobuz are the albums I added while actually in the Qobuz app.
Any that I have added while in Roon only shows in my Roon library.

same issue here: I’m wondering how a two way sync could work.
What I expect to see:

  • When I add an artist, album, track to my favorites in the Qobuz app, it should show up in Roon under artist, album, track, and should have the favorite flag set
  • When I set the favorite flag for an artist, album, track in roon, it should sync back to Qobuz and show up there as favorite as well.

I’m in my 3rd day of testing roon and can’t see this happen consistently. Maybe my fault.

Is the behavior I expect according to the design of roon?

This is not the design or how Roon works. A Qobuz favorite and a Roon favorite are two different things.

  1. Making something a Favorite in the Qobuz app will cause the item (Artist, Album or Track) to be added to your Roon Library.
  2. Once in your Library, the item can be marked as a Roon Favourite if desired. See here for what a Roon Favorite means (hint: you can also use it to Ban items)
  3. Removing the item from your Roon Library will cause the Qobuz Favourite indicator to be removed from the item in the Qobuz app.

Unfortunately I have to disagree with #1 at least in my rig.

When I add an album in the Qobuz app and Mark it favorite it DOES NOT show up in my Roon library.
Hence the point of why I created this thread.

Now I have found I can force them to appear but ONLY by shutting my R.O.C.K server down and when it reboots the new Qobuz added albums are now in my Roon library.
Less than ideal solution…

If you go to Settings/ Services/ Qobuz and click the Sync Now link, does it sync? Instead of having to shut down ROCK.

No Daniel it does not.
I would have expected that to work I agree but it was one of my first trials to get this sync to perform smoothly.

1 Like

Have you started a support thread on the topic? If not, I can move this thread over and ping support. Roon support focus’ on the Support section.

No this was my only thread on this subject.
If you could do that I would be very appreciative!
Thank you

1 Like

@support

The above sends a ping to the support staff.

1 Like

I ran into this recently. The problem was not with Roon, but with the Qobuz app. Clear the Qobuz app cache on your device and restart the app. That synced things up for me.

Hello @kevin_raynard,

This is very strange, can you please provide a screenshot of a before and after when you add an album?

Does the album only fail to show up in your Albums browser in Roon, does it show up under Roon Main Menu -> Qobuz -> My Qobuz -> Favorite Albums?

Correct.
It shows up under Roon/Qobuz/Favorite albums but not under Roon album browser.

Hi @kevin_raynard,

Thanks for the additional info.

How are you sorting the Album Browser, if you sort by Date Added it doesn’t appear there?
I just want to make sure you aren’t sorting by Artist and the album is further in the list. Also:

Thanks!