Issue with Windows xcore USB audio driver in Roon playback (ref#F6YYOH)

What best describes your playback issue?

· Roon skips through tracks rapidly

Is there a specific error message you see? If so, please select from the following options:

· "Too Many Failures - Stopping Playback"

Please try to reboot your Roon Server and check to see if this helps.

· Rebooting my Server had no effect, the issue remains

Please try to reboot and unplug/replug in your affected audio device and check to see if this helps.

· Rebooting and unplugging/replugging my audio device, the issue remains

Please open your Roon Remote and select the "System Output" Zone and try to play to it. Do you encounter any playback errors with this Zone?

· I can play back music *without issue to System Output*, it is only the *other zone that has issues*

What method is the audio device connected with to the server (Roon Ready, HDMI, USB, AirPlay, Chromecast, etc.)?

· USB

Is the audio device on the latest firmware version, as per the manufacturer's app?

· Yes

Is there any change in behavior when using a different cable for the connection for the audio device?

· No, using a different cable didn't change anything

Have you reached out to the manufacturer of the audio device regarding this issue yet?

· Yes, but I have not heard back

Does the issue happen with local library music, streaming service music, or both?

· Both local and streaming content are affected

Please try playing content of a lower sample rate (44.1kHz or 48kHz). Do you still have the same issue?

· No, lower sample rates are still affected

What is the model/manufacturer of the affected audio device(s) and the connection type?

· Daniel Hertz Maria 350 - USB connection

Describe the issue

Hi, I am unable to play music using the windows standard xcore USB audio driver. This driver works in windows and in qobuz but fails to play any music in roon.
Windows 11 PC- latest updates applied
Playback to USB dac

Describe your network setup

Using LAN ubiquity dream machine and ubiquity USW-pro-24 switch

@Daniel_Melby, does Roon play to the W11 Roon Server’s system output, or any other output to confirm it is configured correctly? Typically this error message is tied to a network issue. The Switch Pro 24 is a managed switch, and Roon recommends to use unmanaged switches due to some of the management configurations in managed switches possibly interfering with Roon.

Hi, yes Roon from this PC plays fine to all other sources in my house (main PC, sonos, etc). It plays fine to this PC except when I try to use the standard xmos USB driver then it fails. The standard xmos USB driver works fine with other programs like Quboz or just plain windows sounds. This seems to be a glitch specifically to Roon using the xmos USB driver to my dac.

Hi @Daniel_Melby
Thanks for writing in to let us know about this issue. Can you share a screenshot of your RoonServer’s audio settings page?

1 Like

This is the audio setup on the PC.

@Daniel_Melby,
I found this trace in your logs.

RAAT__OUTPUT_PLUGIN_STATUS_FORMAT_NOT_SUPPORTED

Does the play back issue happen with all file types? If not you may be missing the codec you need to play the file type you want.

Hi, yes the same issue occurs with wav, aiff, and dsd files.

Hi, yes all file types cause the same problem. Are there any other options to troubleshoot this issue?

There’s no need for any special “driver” with Windows 11. Standard USB Audio Class 2 support is built-in to the operating system.

Because any of those would be transformed into standard UAC2 PCM packets before being sent out over the USB cable. Can’t imagine this is a codec issue.

I’d suggest looking for any available firmware upgrades for that amp.

Thanks very much for the help. I did a thorough search and found no available firmware updates. A few observations lead me to wonder whether this is a specific issue with roon.

  1. Audio plays normally through windows 11 (YouTube, windows media player, sound control panel test)
  2. Audio plays normally using the standard windows 11 xcore usb drivers in qobuz
  3. No audio playback using the standard windows 11 xcore usb drivers in roon

An issue that came up five or six years ago with some DACs was that their XMOS USB firmware simply copied an example bit of firmware code that didn’t take into account changes in sample rate or sample width, and when such a change occurred, the DAC would just skip over the subsequent tracks. Roon made a change to mitigate this, then most manufacturers updated their firmware to fix it.

The workaround was to tell Roon to upsample all tracks to a standard depth and rate for that device.

I don’t know if your problem is related, but given that Roon seems to be working with everything else, I’d suspect something with the amp or its DAC.

1 Like

Can you share a screen shot of your signal path when the DAC isn’t working?

Also XMOS recommends this driver with your set up and we found this trace in your logs

No audio playback using the standard windows 11 xcore usb drivers in roon

Another possibility is DAC may be expecting 4 channel input. you can try activating the send stereo content as 7.1/5.1 (if setting is available)

Although, from that TUSBAudio driver Web page you point to:

NOTE: The driver described on this page is not for use by end users. It will not help solve any problems you may experience with a consumer device such as a webcam, camcorder, card reader, external sound card, etc. Thesycon’s device drivers are software components intended to be used by hardware or software manufacturers to create end products.

In any case, you shouldn’t need a third-party driver for Windows 11. Earlier versions of Windows 10 did require such a driver, as UAC2 support was added in Windows 10 release 1703.

Thanks for the input. I tried to click on the signal path but it is greyed out and nothing happens when I click on it. See the image above.

-the device setup has no advanced setup available at all so I am unable to access these additional features
-playing 2channel pcm in other apps such as qobuz works good using this same default windows xcore driver
-the manufacturer reports no additional drivers are available, but other users have no trouble except with Roon -
not sure?
-I tried a MacBook and Mac Mini. roon works normally with MacOS using default MacOS drivers in both circumstances. This problem is isolated to Windows 11
Thank you

@Daniel_Melby,
Thanks for getting back to me with this information! Since you are using System Output there are no advanced setup options as you noted. So we need to look at either device properties for the driver or the volume mixer. Something isn’t properly mapping channels here from Roon to the OS and on to the driver, and it looks like Roon isn’t getting that level of control from the OS. Can you provide a screenshot of the driver device properties from Windows settings? I’m hoping there will be an option to downmix there.

Hi, here is a screenshot of the windows sound settings for the xcore driver.

The DAC allows for all input resolutions up to 192kz input. Thank you

If you turn on spatial sound does it give you options to use 5.1 or 4 channel output?