Issues Since Last Update - Library Cannot Connect & Link to Sonos Lost

Roon Core Machine

Rock Optimized Core Kit
Version 1.0 (build 254) production

Networking Gear & Setup Details

BT Smart Hub 2 to Rock via Ethernet

Connected Audio Devices

Currently Sony TV, Google Nest and Sky TV Boxes

Number of Tracks in Library

Around 70

Description of Issue

Another issue since last update, i had waited as i assumed there would be a fix coming through given the no of issues.

Currently cannot see my music library on seagate external drive, drive is working fine as music can be seen when connected elsewhere. Cannot add to storage, was able to add initially but only added 100 albums then stopped

Tidal library visible, but after a couple of days link to Sonos 3 & Sonos connect

All leads checked

Fed up now, not sure what else to do - help needed please

@Jeff_McEniry, how is your (USB?) drive configured, as an NTFS drive or exFAT? If NTFS, there are some approaches in this thread you may want to try:

You will have to help me here, tech skills not the best. It is an external hard drive, with flac files.

Not sure formatting is an issue as it has worked fine for the last two and half years only issues after the last update


surprisingly this seems to have worked, library has loaded, although Sonos links still lost. Any idea on this issue


@Jeff_McEniry, what did you do to help with the hard drive issue? Regarding Sonos, are your Sonos devices connecting directly to your WiFi network as WiFi devices, or connecting using SonosNet? SonosNet seems to have issues more recently with Roon, so many times connecting your Sonos speakers directly to your WiFi network and not by using SonosNet has helped other users.

As you suggested, connected the external hard drive to my desktop, the drive was scanned and then i unplugged via the eject hardware icon, reconnected the drive to the rock, then went into storage and the drive was visible so connected to the folder. Still seems to work

Main Sonos speaker is connected to the router. I have just checked the cable was okay, it was so when i plugged in again it found the speaker. At the moment all seems fine.


1 Like

Glad you are up and running again Jeff.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.