iTunes import not working in Roon 1.2 (Windows 10 Core, arbitrary iTunes XML location)[Fixed]

Previously (Roon 1.1), even when following the command line instructions, iTunes import did not work for me. Now with Roon 1.2, the results are the same, and Roon refuses to import iTunes library.

I am running just-updated Roon 1.2 on Windows 10, with iTunes (version My iTunes library is located on an external drive (D:). XML version of iTunes library is confirmed to exist and update with iTunes library. Basically, the case is still the same as my previous support ticket, except now that Roon 1.2 is available it is supposed to work): iTunes Library on external drive won't import

I should also note that Roon displays “iTunes Library not found in D:\Media\Music\iTunes” (the location of the iTunes Library DB and XML files), but then blinks to “Scanning Now…” and “1 File scanned” but does not actually import anything.

Hey @Quinn_DuPont – we’ve updated our instructions here now that 1.2 lets you browse to your XML location.

So, just to confirm, are you using a symlink or not? Is the default iTunes option enabled in Roon right now?

Why don’t you try this:

  • Disable the default iTunes location
  • Click Add iTunes Library
  • Enter the path to your XML

Assuming the XML you point to is updated when you make changes in iTunes, I think that should work but let me know if not and we’ll take a deeper look.


Hi @mike:
I’m not using the symlink method (now that 1.2 is supposed to support the XML file directly). I’ve disabled all folder locations other than 1 Roon “watched” folder (which does work).
I’ve tried adding the path location numerous times, starting from a fresh restart, and removing all existing folders. I can confirm that the XML file is updated with the iTunes DB:

Roon “sees” the file (if I tell if an incorrect location it automatically recognizes that there is no XML file there), and it even flashes that it found 1 file, but then issues the same error as with Roon 1.1 (see my previous ticket, linked above).

Just sent you instructions for sending us some logs @Quinn_DuPont – sorry for the trouble and thanks for your patience!

Hi @Mike. Perhaps it was the latest update (build 128), but it started importing my iTunes library now. Fingers crossed that this issue is now resolved!

Thanks for update @Quinn_DuPont. Build 128 did contain the fix for your issue.