JBL SDP-55 MQA Distortion

Hi, I am using a JBL Synthesis SDP-55 which I am told by JBL has ‘full MQA decoding’. When I have the SDP set to ‘Decode and Render’, ‘Redner Only’ or ‘Decode Only’ I get full on, 100% distortion.

The only way I can play MQA albums is to have the SDP set to ‘No MQA Support’.

My core is an i3 NUC running Roon Rock. Is my core being underpowered a potential cause?

Any other thoughts?

This should be in the support section perhaps

Hi @jamie_earle,

In order for Roon’s @suppport team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

OK. I saw a mention of roon and this unit. It’s a certain @jamie_earle. Looks like you are already talking to JBL support.

Yeah, waiting for reply from their technical people and figured getting more input here couldn’t harm.

This is JBL confirming MQA capabilities:

“I am happy to say that the SDP-55/SDR-35 has “full MQA decoding,” which means that it does indeed do the final unfold. I have not been able to make it misbehave using Tidal Masters via Roon. If you are experiencing distortion when playing MQA media, please check with Customer Support.”

Here is what sits on my network and is Roon related:

Intel NUC5i3RHY running Rock
US Internet provided fibre modem
Ubiquity Security Gateway
A few different ‘dumb’ switches in various locations
Multiple Cisco WAP361 for wireless AP’s
JBL Synthesis SDP-55 for Roon playback in Rec Room
2 Raspberry Pie w/HiFIberry hats
2 Cromecast Audio pucks
Multiple Apple TV’s
1 Sonos Move

Hi @jamie_earle,

How is the JBL connected in your setup? Are you connecting to it via Airplay, HDMI from the NUC or through one of your Rasberry Pi’s and then via RCA/TOSLINK?

Can you share a screenshot of your Roon Settings -> Audio tab and a screenshot of the Signal Path when you have MQA content playing?

The SDP-55 is connected via Ethernet to my network that has a NUC running Rock on it.


This is the single path when it is at full distortion (I have also had it set to ‘Decode Only’ and ‘Render Only’ with the same bad results.

Signal path to make MQA work:

Quote from JBL Synthesis support regarding MQA and the SDP-55:

Hello @jamie_earle,

The JBL SDP-55 has not been submitted for Roon Ready certification, so we cannot provide support for the device at this point in time.

Based on the Signal Path reporting, it appears that the JBL is breaking when fed a valid MQA stream via the Roon Ready/RAAT protocol. When the device is set to “Decoder and Renderer” Roon simply passes through the bit-perfect MQA stream from the source (in this case Tidal) to the endpoint device. When the device is configured to “No MQA support”, Roon performs the MQA Core Decode (1st unfold) and then removes any MQA headers from the audio, making it appear as a normal PCM stream to the endpoint.

We will reach out to JBL independently to clarify the status of their Roon Ready integration on this device. I suggest that you follow up with their support team with this information so that they can assist you further.

-John

I want to give an update to anyone who might read this. JBL released an update today (V1.22) and it appears to fix all of the issues I was having. MQA tracks work perfectly now with the SDP set to Decode and Render.

5 Likes