KEF LS50 & Roon. Lost control of audio device problems!

Hi guys, hope somebody can help with this as it’s driving me mad!

I’m using my KEF LS50 Wireless speakers with Roon but I keep getting audio dropouts and the message ‘lost control of audio device’. So far the only way of getting Roon to identify the KEFs is to turn Roon on and off again, which obviously isn’t ideal!

The KEFs are connected via ethernet direct to a powerline and Roon is running on my laptop.

Has anyone got any suggestions as I feel like I’ve tried everything but to no avail :frowning:

Are the KEF running the latest Firmware? Is your Roon updated?
http://international.kef.com/product-support

Adding @support to get their attention.

Yes both are running latest firmware.

There’s no set time to the problem either. Sometimes it’ll drop out after a couple of songs, sometimes a couple of albums.

Hoping @support can help with this?

A couple of pictures to get an idea of how I’m setup…


For the 1st picture, when the problem occurs, the KEFs disappear from the ‘Networked’ section and only appears when i turn roon off and on again.

For the 2nd picture. These are the settings I’m using for both Roon and Roon Server. I’ve tried using designated ports and open to all devices but still the problem persists.

As a test have you tried connecting them directly via Ethernet and remove the power line adapters from the equation?

Not an option I’m afraid. Don’t have a 20m ethernet cable lying around the house.
Never had an issue with the adaptors before so don’t expect that to be where the problem lies.

The only time I’ve seen this happen in my system is when the connection between the Roon core and the end point is interrupted. Just because you’ve never had an issue with the adaptors before should not exclude them from the troublshooting.

For troubleshooting you could move the speakers closer to the network switch or router and hook them up. Temporarily of course. This would help identify the source of the problem.

1 Like

I would caution against this kind of thinking – we often see issues with powerline adapters, and while that may not be the case here, ruling that out as a first step makes sense.

I would echo the others in this thread and say that the next step here is to temporarily test with ethernet - if that’s more stable, its a good data point from which to move forward. If things are the same, we know that at a minimum there are other issues here.

2 Likes

Appreciate the suggestion but unfortunately the logistics of moving the KEFs along with the power cables and mains block to power them into the cupboard under the stairs where the router is located is just too much.

I was previously using a Powerline with a Bluesound streamer and never had a dropout in the 6 months I was using it so I’m surprised I’m having them now.

So if the mountain won’t come to Mohammed, perhaps an investment of $20 in an ethernet cable would enable Mohammed to go to the mountain? :grinning:

Eliminating the Powerline adaptors as a test is the best first step in diagnosis, I feel…

Or $12.99 here.

I’m also fairly certain powerline is the culprit. I briefly experimented with Roon and powerline, and it was terrible. Just as an aside, Sonos also recommends powerline gear not be used with its systems. Latency is often the problem in the case of Sonos.

I did keep hearing powerlines were bad news for hifi but after using one with my Bluesound streamer and not having a single dropout, I wondered what the fuss was all about! hence my surprise when I started having issues with Roon.

I’ve just ordered a 20m ethernet cable so will report back when it arrives and I’ve had time to test.

Maybe I’ll even notice a sonic improvement if it’s connected directly!?

1 Like

same problem.
I use 10m ethernet cable CAT 8.

1 Like

Hi Mike,
Installed ethernet cable last night so the KEFS were directly connected to the router, laptop core connected to powerline. 2 hours later and had my 1st dropout :frowning:

Starting to wonder if this a Roon issue now as like I said before, previous bluesound node setup was connected to a powerline with no issues.

Any ideas?

Hi Anthony

Again only as a test can the core be connected to the router directly rather than over the power line?
In my experience routers are not always the best switches so I prefer to use a gigabit switch with just a single connection to the router.

YMMV

Russ

I’ve got the same issue and KEF’s are connected directly via CAT8 cable.