KEF LS50 wireless, firmware 2.6, January 2023, not seen by Nucleus

I just bought a Roon Nucleus & a pair of “Roon Ready” KEF LS50 wireless speakers, which I want to use (duh) wirelessly because there is not an ethernet port in my livingroom. Has anyone figured out how to get the Nucleus & the KEFs to play nicely? Prior posts about KEF lament the lack of Roon-readiness, which is now promoted heavily on KEF site. I also cannot find any place to “add an output device” to my Nucleus so I can’t even try again to get the Nucleus to find them. Thank you. I’m an old-tyme audiophile, not a streaming-music techie.

I would connect your Nucleus to your network using ethernet. You can connect directly to your router or a switch.

EDIT: I didn’t know the KEF’s are wireless. Use WIFI to your network. I’m not sure if you will need a Roon bridge or not.

Are these the current LS50 Wireless II or the original LS50 Wireless? The II version is Roon Ready with the current firmward, and the original are Roon Tested and usable via AirPlay or using the KEF wireless streaming protocol which Roon supports but that cannot be grouped except either to another AirPlay zone or another KEF streaming zone.

If you have the II version with the latest KEF firmware, then they should be visible in the Settings → Audio tab as both an AirPlay endpoint or a Roon Ready endpoint.

@Catherine_Wallace, also as @Jim_F notes, the Nucleus needs to be connected via an Ethernet cable to your home router or home network, it does not support WiFi. Is this cabled connection an option for your Nucleus? The KEFs can be connected wirelessly to your home network, but the Nucleus requires a cabled connection.

Thanks for the prompt responses: I am truly grateful for that. The KEFs are Wireless II and I downloaded latest firmware (ver 2.6). The Nucleus is connected using ethernet cable, and a laptop on wireless only is able to communicate with the Nucleus. Under “Audio” I do not see the KEFs. I also do not see how I can cue the Nucleus to search again for available output devices.

to Jim F, the Pragmatic Minimalist: Can you say more about that idea of plugging some gadget into the UBB port on the KEFs to solve this problem? You are over my head here.

The KEFs are visible on my home network: I can see that. Cate

I have the same speakers. Have you used the Kef app to connect to it? It requires subs setup first.

Also, it’ll tell you whether it’s in sons weird mode. Sometimes I’ve noticed the kef is inoperable and messing with the app solves it

In my experience with my version 1 KEF, once I used my phone to connect the KEF to my WiFi, they needed to be put in “wireless” mode using he KEF remote or the touch panel on the main speaker, then they showed up in Roon “Settings/audio” and I just needed enable them. Once that was done I could play to them as a zone in Roon.

As others have mentioned, hooking an ethernet cable to the KEF drastically improved the performance of the KEF. Kef wireless IME is spotty at best. Although with my version they still could not be grouped with other zones only being Roon tested. I ended up using an RPi with digi+ pro running RoPieee to feed the KEF so that I could group them. Yours being the version 2 and Roon ready you should be able to group yours without the RPi.

Hi, Cate and welcome to the forum!

I have the same speakers. They’re most certainly Roon Ready and with help here, you should be able to get them working just fine.

Don’t do anything with gadgets or things like that, yet. There’s other stuff to try, first.

A few quick notes and questions:

  • You say that you can see the KEFs on your network. That’s good. Are you looking in your router or some network device that allows you to confirm this?

  • You’ve got a Nucleus up and running, right? What device or platform are you running the Roon Remote app on?

  • @bearFNF mentions putting the KEFs into “wireless mode”. He’s right, but this is also a little confusing because there are two places in the KEF app that mention wireless mode. One of them is the input source (which is what you need to set) and the other is the interconnect mode between the left and right speaker, which can be wired or wireless. This screenshot illustrates what it looks like when WiFi is the input (you probably see more inputs on yours - like USB - than you see on mine because I’ve disabled some). If “Wi-Fi” isn’t white, then it’s not selected and you’ll need to do that.

Once you’ve done that, you need to run the Roon Remote app on your phone, Mac, or PC. Go into Settings, then Audio. Hopefully you see your KEFs in the “Roon Ready” section and you can enable them.

You asked how to get your Nucleus to re-scan for devices. Roon is very good at automatically discovering devices. You don’t need to force a scan.

If your speakers aren’t showing up, trying pulling the power plug, wait a minute, then power them back up. Sometimes people have issues with these specific speakers that require a power cycle. I’ve never had that problem but it pops up on the forum every once in a while.

Let us know how it goes!


If the speakers are Roon Ready, connect Nucleus by ethernet and speakers by ethernet and you’re done. Roon will find them and they will show up under Roon - Settings - Audio. Just click on them and do setup.

If you don’t have ethernet where the speakers are located, try WIFI. If that doesn’t work well, use a Roon bridge such as Raspberry Pi 4 connected by WIFI to your network and USB from the RPi4 to your speakers. If your speakers don’t have USB, you would need to add a HAT to the RPi4 to give you the connections you need such as optical, etc.

Hi gTunes, and thanks!

I appreciate your welcome, your confident reassurance and generous help. Alas, none of this worked. Here are answers to your questions and a few potentially relevant facts.

I can see my KEFs on the app for my Eero wireless network, which has a node in a direct line-of-sight to the KEFs. The wireless icon on the speakers is full bars; on the homescreen of my KEF app the wireless connection is enabled. That has always been the case. I had already turned wireless on and off a couple of times and powercycled both the KEFs and the Nucleus. I have TING superfast internet: average wireless upload and download speeds are more than 200 Mbps; hardwired are 950 down and 750 up. Wireless signal in this house is simply gorgeous.

I have the Roon app on a big Mac desktop, a MacbookPro laptop, & an iPhone, all fully updated. The Nucleus is plugged into a bridge that’s plugged both into the desktop & (of course) plugged into an ethernet port: simply plugging the Nucleus into one of the open Ethernet ports in my home office did not allow the Roon app to find the Nucleus. That strikes me as strange/ wrong & annoying, because longterm I would prefer to have the Nucleus in the basement, not taking up real estate on my desk. But for initial setups–and the hard boots those often entail–I find it is most convenient to have devices in physical proximity.

When I go to Audio in my Roon app, my only choices are two: the Firefly I have plugged into the desktop for my little home-office speakers, and HDMI A & HDMI B–which is also weird, because there’s nothing plugged into those ports. In a moment of irrational desperation I tried using the Roon app to link those two ports & play through them but nothing happened.

On a diagnostic basis I am tempted to move the Nucleus to an open ethernet port in another room on the first floor here to see if now the Roon app will find the Nucleus even when it is not sharing a bridge with the computer running the Roon app. My only explanation so far is that my Nucleus is defective: my trouble getting the Roon app to find the Nucleus was the first sign of trouble.

Thanks again.


Have you tried the connecting to the speakers with the KEF app on your phone? What does it say? Can it see it? I’ve found problems with my KEF LS50 Wireless II’s though the app.

It’s not clear yet ( to me at least) whether It’sa KEF problem, a Roon problem or connection/network problem between the two.

What is this bridge device? Is it a regular switch – or is it a router of some kind?

Can you share the IP-addresses for the Nucleus, one of the Roon remote devices and the KEFs? Are you able (even of just for testing) to run a network cable to the KEFs?

(Yet another LS50WII user here – running Roon with zero hiccups).

1 Like

It also looks like you have an issues with just seeing the Nucleus? when you say,

What exactly are you plugging it into? a switch? a port on your computer?
Maybe we need a little more info on your set-up to help?
Maybe fill out a support ticket style sheet?

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

1 Like

Took me about five minute to set mine up last week, totally wireless. Like others have said, start fresh (i.e. reboot), use the Kef app, and don’t faff about using cables etc. Make sure the Nucleus, your remotes, and the speakers are all on the same network. My ROCK core is in my office, wired to a switch that is wired to the Xfinity modem, which has an Asus router cabled to it in access point mode which is what the Kef’s use. Set up was almost instant. Don’t overthink it, and use the Kef app step by step. Best of luck, they’re brilliant speakers for what they are.


Yes I’ve never bothered with Ethernet etc. The KEF app sets it up and go. After that I’d you have problems use the app to diagnose. That’s been my experience. (Or power cycle the speakers.)

The app would be not first go to.

RBM: The devices running the Roon app and the KEFs share an IP address that has the same first seven digits: only the last two digits differ. The Nucleus is plugged into an Airport Extreme router that I had configured as a bridge in order to get a supposedly wireless printer to behave itself on the network. (And all know about printers…). Plugging the Nucleus directly into an open ethernet jack did not allow the Nucleus to be “found” by the Roon app. I think my Nucleus is defective.

Or its your airport express that is the issue, I have seen others with issues with airport extreme and Roon. The “fix” is usually getting rid of the airport extreme.

Talking from personal experience trying to help a family member figure out their network issues (not roon related but printer related). We ditched the airport extreme and all was well with the network after that.