KEF LSX drops, disappears; comes back with Core restart

(Edward Nazarko) #1

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro 64 bit; Intel NUC i5-8259U; Roon v1.6, build 416, 64 bit; set up to not hibernate; hard disk shutoff after 4 hours

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi mesh network, RB50; server connected by Ethernet to Orbi ; connecting to KEF LSX wireless

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KEF LSX speakers, set up as a Roon device

Description Of Issue

I set up the KEF as a Roon device per instructions found here. They sound wonderful… but when listening, after some amount of time, the music stops. Not always consistent amounts of time, while I haven’t measured it’s different enough that I’m sure of that.

Literally, the music just stops. I still see the seconds counting down on the playback bar. If I pause and restart, then no seconds count down. The LSX status light still shows they’re at the ready.

If I click on the “zone” the LSX no longer show up. If I go into Roon Setup, they don’t show up there other than as AirPlay devices. Restarting the LSX doesn’t change things. Restarting the Roon control on my laptop or whatever I’m using doesn’t fix things.

If I restart the Roon Core - close Roon, then open it - the LSX speakers will once again show up, as Roon targets (along with showing as AirPlay targets. No, I do not have both AirPlay and Roon targets selected.)

All of this while streaming Qobuz. I haven’t done long listening sessions from my music server, but the ones I’ve done, I had one drop; same problem, the device disappeared, reappeared when restarted Roon Core.

I’ve not listened much time on AirPlay… did initially, but once I saw I could set up as a Roon target, and heard the sound difference (yes there was certainly a sound difference) I’ve not listened on AirPlay other than a few times for a few minutes while chasing the problem.

(Noris) #3

Hi @Edward_Nazarko,

Thanks for reaching out to us here, I have a few suggestions starting off:

  1. You mentioned that you are using Orbi gear. In the past, we have seen a special configuration option that needs to be set for Orbi router to properly work with Roon, and this setting is as follows:

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings

This is mentioned in our Networking Best Practices

  1. How are the LSX connected to the network? If they are on WiFi can you please try to temporarily connect them via Ethernet and let me know if the issue still persists? I can’t say for sure, but it might be a WiFi communication issue at play here.

  2. I would use the KEF Contorl app to verify that the LSX are on the newest firmware as perhaps there have been some changes in this area.

  3. How often would you say this issue occurs and after what period of length of listening? 1 hour? 1 day?

  4. When the KEFs still show up as Airplay, does the Airplay input on them work for music streaming?

(Edward Nazarko) #4

Thank you. Answers to the questions. I fixed the IGMP item, and will get back if it worked, or didn’t work, once I’ve had some time listening.

  1. I unchecked DISABLE IGMP. I haven’t had a lot of time to listen since them… should get a good test in a few days.

  2. The KEF are connected wirelessly. I’d be stunned if it was a network comm issue. The KEF speakers are the ONLY endpoints I’ve had issues with. We have a lot of things working at once in peak evening hours (when the KEF are less likely to be used) and I see a ton of headroom. Bless that Orbi backhaul. I can’t really do an ethernet to Roon Core connection - the house has only one or two Ethernet connectors. I’d have to run a 30 foot cable across the floor of house, which wouldn’t be good with the toddler who visits a few times a week.

  3. Current firmware on the KEF. I did find an Orbi update that for some reason had not auto-applied, so I ran that.

  4. Truly, random. After having three different drops during a two hour listening session, no more than an hour later I started listening and had zero drops for over 3 hours. I hate chasing random problems.

  5. If I connect via AirPlay when the Roon KEF device has disappeared, it plays fine.

I’ve got a menagerie of endpoints, all wireless, ranging from an Exasound wireless endpoint to an AlloBoss Pi based DAC, with a few others in between. This problem is specific to something with the KEF speakers for sure.

1 Like
(Daniel Blacklock) #5

I wouldn’t be so quick to discount needing to change a setting like this on a router. I recently setup a Harmony Elite Remote on my network and it would not detect the LIFX lights (on my 2.4GHz WiFi network) without disabling what seemed to be two very unrelated settings:

  • Bluetooth Coexistence = disabled
  • Airtime Fairness = disabled

I was in total disbelief when they instantly appeared when doing a scan.

(Noris) #6

Hi @Edward_Nazarko,

Thanks for the update here, do let me know if things have stabilized since making those changes.

(Edward Nazarko) #7

I just got reminded that I wasn’t as precise as I could be. No result from playing yet, but did find another example of what’s happening, and its happened before… and I didn’t include it.

Doesn’t look like changing the IGMP setting changed the behavior. I listened for a little while this morning. Opened up the Roon app on my laptop, chose the Roon zone for the LSX, and listened. Not for too long though, had a few meetings.

Just came home. Had shut the Roon Core server down when I left (so that a cleaning crew wouldn’t dust my keyboard and blow up the server with random key strokes.) Turned the Roon Core server on. Every other endpoint that sits in standby mode showed on the list of zones. But the LSX Roon option did NOT show. On the Settings/Audio menu, the LSX Roon option wasn’t there, although the LSX Airplay option was there (not enabled).

After waiting for somewhere past fifteen minutes, suddenly the LSX Roon zone showed up on the zones list and in the Settings/Audio menu.

So, when I brought Roon up, it remembered and connected with all the other devices in standby mode, except the LSX Roon device, while STILL detecting that there’s an AirPlay option on the LSX. So some form of handshake had to have happened between Core and the LSX speakers or Roon wouldn’t know that there was an AirPlay device that could be enabled… but Roon didn’t notice the LSX speakers could be a Roon endpoint.

After a long period of time passed, somehow Roon Core DID get a handshake with the LSX Roon capability.

(Noris) #8

Hi @Edward_Nazarko,

Thanks for letting me know that additional information regarding the failure state and IGMP setting.

When you are in this state where the Core cannot see the speakers and they are connected via WiFi, can you please confirm if rebooting just the Roon app allows the connection to re-establish? Further, if rebooting just the Roon app does not re-establish contact, does rebooting the Core have any change?

I understand that this would not be the permanent solution, but confirming if WiFi is part of the equation will give us some insight as to which direction to search in. Even if you can temporarily connect the speakers via Ethernet, it would be good to verify if the same behavior occurs or not.

(Edward Nazarko) #9

By rebooting the Roon app - not exactly sure what you mean. I think you mean this:

If I reboot the Roon Core application, it can then see the speaker. I’m NOT rebooting the server, just the application. It always works, although it can take 10-15 minutes before it sees the LSX as a Roon endpoint. It sees it as an AIrPlay endpoint immediately (not enabled, but it offers it as a device that could be enabled.) In fact, it never forgets that the LSX can perform as an AirPlay endpoint.

When I reboot the Core application, and wait for the LSX Roon endpoint to show up, when it does, it shows up as already enabled. So it doesn’t completely forget everything. (I’m assuming that there’s a Roon to device handshake that identifies the device’s existence and capabilities, and that enabling is a separate process. That’s how I’d have architected it.) So when it finally remembers the LSX can be a Roon endpoint it also remembers that it was enabled.

Yesterday I had the speakers playing for many hours. The first couple hours I was listening to Radio Paradise’s lossless stream, with no drops. I switched over to streaming Qobuz, and I had two drops early on - I rebooted the Roon Core app pretty quickly, and the delay in rediscovering the LSX as an enabled Roon endpoint was very, very small. After those first two drops, I had no more drops for the remaining two plus hours I listened. However, most of that time (after about 40 minutes) was in Roon Radio mode after I finished listening to my friend’s new album.

All the drop problems I can remember have been when streaming albums on Qobuz. I do that a lot, along with Radio Paradise’s lossless stream… and with RP, I’ve not had a drop. I can’t tell for sure if this was an accident or a real clue, but when Roon took over yesterday as Roon Radio, no drops. Most of what Roon Radio is selecting is on Qobuz… so you’d think it would drop.

I find it odd that Roon forgets even the existence of the Roon endpoint capability… but when it finally remembers, it remembers it as already enabled.

(Noris) #10

Hi @Edward_Nazarko,

Thanks for providing that additional insight, it is appreciated. I have a few follow-up thoughts here:

  1. Have you by any chance tried the endpoint on WiFi? If so, is the behavior the same or does that change the issue with regards to when the LSX show up?

  2. I would like to take a look at diagnostics. Before I go ahead and enable this mode for your account, can I please ask you to reproduce this behavior once more and note the exact local time + date in your country when it occurs? E.g. At 4:08PM on 8/2/19 I rebooted the Roon Core app and then at 4:16PM on 8/2/19 the KEF endpoint showed up. Please let me know this info and I can take a look to see if there are any further clues in the logs.

(A Badr) #11

Hi there!

Jumping on this thread as I have a similar issue (hope that’s ok @Edward_Nazarko - LSX showing up only on Airplay as of c. a week ago. They never seem to show up as an endpoint for me at all.

I’m running Google Wifi and haven’t changed the setup from a period (months) of solid operation. LSX set up on Wifi and in cable mode (between the speakers).

@noris Happy to share diagnostic, however as the LSX never show I’m not sure how useful that would be.

(Edward Nazarko) #12

As they say on the game shows, “Come on down!”

What I’ve found works. Close Roon Core, then re-start it. Wait 20 minutes, then look way way down at the bottom of the list in the “setup/audio” menu. When the LSX show up as Roon endpoints, it’s all the way down at the bottom. I saw another thread where several people never saw that the speaker showed up as a Roon endpoint because they didn’t see it, but never thought to try scrolling down farther after some wait time.

I didn’t see the note on timing and gathering diagnostics until too late yesterday. My server had restarted, after a power outage, Roon hadn’t restarted. I started Roon… no LSX as a Roon endpoint. AirPlay capability displayed ready to be enabled (which I didn’t.) After about 20 minutes, Roon endpoint showed up.

That said… I listened for two and a half hours with no drops, all Qobuz streaming.

Note to @noris - I remember on another thread there was someone from KEF who posted about the Roon endpoint capability when they introduced it. Have you connected with him? I wonder if part of this could be how they implemented the capability on their end, particularly since we now have another case.

If you could tip me on where I’d find the Roon diagnostic file, I’d like to take a browse through. (My last ten years I was the guy my large computer company’s execs called for when a customer had a problem no one else could solve - so I have some curiosity and love of reading cryptic log files that you could exploit…)

(Noris) #13

Hi @abadr,

Welcome to the conversation and thanks for sharing your experience. I wonder if this issue is due to a recent change, have you both perhaps updated to a newer LSX firmware version? Can you open the KEF Control app and let me know what firmware version is being listed? Also, what is your network setup like - can you let me know the model/manufacturer of your router and any additional networking gear?

@Edward_Nazarko - You can find the Log files by using these instructions but do note that it may be a bit difficult to understand what exactly is happening if you are not familiar with how Roon operates.

The best way that we should proceed in my opinion is logging timestamps and then I can enable diagnostics mode and check for any clues. Please let me know this info and then I can go ahead and enable this mode for your accounts.

(Edward Nazarko) #14

Firmware version p20.4031905270.105243

I got these about five weeks ago, like everything else these days, they said “updates available” and I let that run.

I have two timestamps logged for when I rebooted the Roon Core app. Both times Windows had run an update and restarted the computer so Roon hadn’t loaded.

Sunday, launched Roon Core 158pm. Found the LSX Roon endpoint at 200pm. Showed all other endpoints immediately upon launching.

Today, launched Roon Core (after the server had rebooted in the night.) 842am launched Roon Core app. 846am the LSX Roon endpoint showed up. All other endpoints showed immediately at launch.

Listened for three hours this morning, two hours this afternoon, no drops. All Qobuz streaming.

(Terry Murray) #15

I’m on the same firmware version. I was seeing some of the same behavior. The speakers would show up in Airplay immediately and then take some time to show up natively, whether I used wifi or wired ethernet. I did a firmware recover from the KEF Control app yesterday and all seems to be resolved. I will monitor the rest of the week and update if it recurs.

(Edward Nazarko) #18

Uploading logs. See 8/5 in Roon_Logs.txt . I started the Core app at 842 (by looking at the clock numbers on the screen, so could be any time between 8.42.00 and 8.42.59). I reported that the LSX Roon endpoint showed up at 846 on the screen clock.

According to the logs, Roon app on the server started at 8.42.23.

Search on KEF (for now), because the device is named KEF_LSX1. I see most of my endpoints show up pretty quickly.

Around 8.42.45, the device database returns a “no match for” message for the KEF device in Airplay mode, which makes sense since I had not enabled Airplay mode for the KEF_LSX1.

At 8.46.09 device manager finds the KEF speakers and gets busy setting up the endpoint specs.

For comparison, there are two other Roon endpoints. I’ve got Roon on a Boss DAC (that only does Roon) and an Exasound Sigma endpoint (Sigma1). Both are discovered very early on and for the Sigma it discovers both the un-enabled Sigma1 and the Roon capability.

I had no drops in that session.

I didn’t look at the 8/4 logs.

I wonder if KEF speakers, when sleeping, only announce themselves every N seconds.

I haven’t done log diving without Eclipse in a long time… and now I remember why.

Ping me with a private address I can use to send files to you. I do a bit of computer security hacking and aren’t comfortable with having the log files exposed with server and endpoint names.

(Noris) #19

Hi @Edward_Nazarko,

Thanks for sharing your findings. No need to send the logs over, I have enabled diagnostics mode for your account and what this action does is automatically upload a log set to our servers for analysis. I can confirm that these logs have been received and I have created a ticket regarding the traces from your timestamps.

I do see the issue, but it is not clear why exactly it is being triggered. I discussed your case with the technical team again, and they have noted that we have reached out to KEF for their assistance in this issue, so I will be sure to keep you in the loop as any new information surfaces. Either way, glad to hear that the issue is just with the delay for them appearing and not with any dropouts. Thanks!

(Edward Nazarko) #20

Great. For additional background, I had two short drops yesterday while listening to lossless streaming, and the behavior was very different than before I’d changed the IGMP setting. Music stopped, but after a couple of seconds came back, twice in an hour.

I’m sure the drops yesterday were internet problems - was listening to a lossless streaming station from Finland, and I know that’s likely to hit problems with packet drops and delays. (Not sure where my Qobuz signal comes from, which is what started all this, but I’m sure it could also have problems with drops.) But, this time both Roon and the speakers recovered flawlessly.

(Edward Nazarko) #21

Hey, just had a drop - mid song, at 14:44pm. The LSX just suddenly disappeared. I went looking in Roon and it’s no longer showing in there as a Roon target, just as an Airplay target. Reappeared just now as I am writing this at 14:49.

I don’t get drops on anything else, not even my Allo Boss DAC…

Let me know if you want logs.

(Noris) #22

Hi @Edward_Nazarko,

Thanks for letting me know that new timestamp, I can confirm that the new logs have reached our diagnostics servers and I have attached them to your case.

As I mentioned previously, we are actively discussing a few similar reports and are investigating this behavior with KEF.

I will be sure to let you know once I have any new updates from the technical team and appreciate your patience in the meantime, thanks!