Kef LSX, no audio until restart Rock

Hi @support

Core Machine (Operating system/System info/Roon build number)

Rock is an Intel NUC7i3BNH w/ 4 GB RAM and SSD drive
Files are on a NAS - both connected to a Gigabit Switch, wired.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core, NAS and LSX are on the same network, wired.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Using the LSX with Roon protocol, not Airplay2

Description Of Issue

The speakers are idle most of the time, and after a few days, Roon doesn’t want to push audio, like it is going nowhere (no visual feedback the audio is playing). The same file plays fine on other roon devices, including LS50w.

Spotify plays fine on the LSX when Roon doesn’t work.
A restart of the Roon service on the ROCK solve the problem, wife doesn’t want to do that obviously.

Known issue?

Hello @bitonio,

When the system is in this state, are you able to get playback working using the Airplay zone in Roon for the KEF LSX?

-John

I didn’t enable the airplay protocol in Roon to avoid confusion. I’ll give it a shot next time it happens, that may not be easy to reproduce though.

Hi @john, @support,

I managed to capture the issue in video today:


At 1:01 you’ll see the error message

I turned on the AirPlay and it had no problem to play.

I tried to play on Roon protocol after that same error

Only when I restart the Roon server service on the ROCK I was able to get the Roon protocol working again.

Hi @bitonio,

Thanks for sharing that video, it is helpful to have.

It appears that the issue occurred around 6:04 on 9/11/19 according to your video, can I please ask you to manually upload a set of logs from your ROCK Core by using these instructions so that I can take a look to see if we can gather more clues? The best way to get the logs over to us would be via a shared Dropbox / Google Drive / Send.firefox.com link.

Also, can you please expand further on your networking setup? What is the model/manufacturer of the router, switches, range extenders/etc. you are using? Thanks!

Here are the logs - password is Roon, all lowercased and o’s to be replaced by zeroes.

Network-wise, they are connected with Cat 5e ethernet cables on the same gigabit switch - a DLink LRT214. Not much traffic on the network and I tested with with more than 900 Mbits. According to the user manual the LSX have a 10/100 Mbps.

The LS50w are on the same network don’t show any problem (the fast scrubbing bug was fix thanks to you!)

Hi @bitonio,

Thanks for sending those logs over, I can confirm I received them. I’m looking through them at the timestamp you mentioned and I’m seeing packet loss to the Airplay zone and issues with the Core connecting to the speakers.

What kind of router are you using in your setup, can you let me know the model/manufacturer? I would try bypassing the DLink switch as a test and connecting the LSX to the router directly or via WiFi to see if there is any change in behavior.

@noris

Thank you for confirming you got the logs.

Not sure how the Airplay zone is working I turned it on for troubleshooting purpose, but what level of packet loss are we talking about? How is it reported by the kernel/NIC on the Linux OS or my up in the software itself?

As mentioned everything wired around a DLink LRT214: the core and the speakers. And speakers are wired together.

Could a user being fed up with this quite expensive setup and trying to click a little too much on play/next trigger a packet loss? I have seen horror all my life in networking and software engineering :slight_smile:

Other question: do you have a pair of LSX to test with a ROCK and let it bake for 7 days?

Every single time the Roon issue arise, a restart of the Roon service solve the problem.
It is like a clockwork, over 7 days it chokes again. Airplay has no problem, the LS50w on the same network have 0 problem. On the LSX, the issue happened today again.

I understand this is hard to troubleshoot and time consuming for both of us, appreciate the time, I don’t want to break the network that is working, what I may change is to put the setup in an isolated lab for 7+ days which means the buyer of these Kefs won’t be able to enjoy the setup during that time.

I am happy to take this to Kef as well if you think the problem is more on the Kef side, but since I ran into issue with LS50w/Roon integration in the past, I reach out to you guys first.

Hi @bitonio,

I appreciate your patience while I had a chance to discuss your case with our hardware team.

Yes, we do have a pair of LSX in the lab and the hardware team would be willing to schedule this test, I will be sure to let you know once they have performed it.

In the meantime, you may want to also try factory resetting your LSX speakers to see if it will help with the issue.

Thank you Noris.
I’ll do a full reset of the LSX and reconfigure them, worth a try!

1 Like

Hi @bitonio,

I appreciate your patience here while the lab team had a chance to schedule this test.

They have tried reproducing your findings of leaving the LSX on standby for 7/8 days, but the speakers are still functioning as expected afterwards.

This leads me to believe that this could be an issue specific to your pair of LSXs. Has there been any change in behavior after performing a full reset and reconfiguration?

Hi @noris,

That’s good to know.

I have indeed performed a full reset of the speakers 8 days ago and the setup is one more time broken with the RAAT protocol, but still fine with AirPlay.

I recorded a new screencast to share exactly the experience:

What would you recommend from there, engage with Kef support directly?
(I purchased them from Kef USA store directly).

I just got notified the LSX speakers have a firmware update, I am upgrading to 4.1 and will observe if that solves the problem or not.

Hi @bitonio,

Is there any change in behavior after upgrading to the newest firmware?

Looping in KEF on this issue doesn’t sound like a bad idea. If you wish to reach out to them, please do let me know what they say. Thanks!

So far so good, I’ll give it a week and we’ll see what happens. I was about to send my email to them when the firwmware showed up. 7-8 days is the magic wait time, I’ll give it a new shot this week-end.

1 Like

Hi @noris,

I was working from home today. I fired up Roon Player on my iPhone, and hit the same issue: impossible to play music on the LSX with Roon protocol, all good with AirPlay.

Roon Server Software on the Rock
Running 7 days, 1 hour, 4 minutes, 18 seconds.

I am contacting Kef Support, sharing this thread.

1 Like

@noris, one question for you, during the one week testing, were you testing with Roon + LSX or Roon with LSX and LS50w in the same network. I am think having 2 pairs of Kef speakers is probably not super common, could this trigger the problem I have?

LS50w were added on this network far before the LSX. I can try to remove (unplug) the LS50w for a week.