KEF LSX no longer showing in Roon

Roon Core Machine

MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports)
2.7 GHz Quad-Core Intel Core i7
16 GB 2133 MHz LPDDR3

Networking Gear & Setup Details

Synology RT2600ac
Ethernet cat 6

Connected Audio Devices

KEF LSX over Ethernet
Firmware version p20.5102011250.105243

Number of Tracks in Library

Description of Issue

KEF LSX have performed perfectly with Roon during Semester 1. During last few weeks, they have periodically disappeared from Roon. A few times, a restart of both speakers and Roon Core worked. Now however they seem to be completely gone. They are not visible in the desktop, iOS or Android clients.

Ali I have seen a couple of these threads before.
Have you done the tried and tested power everything down and turn it off again?

Give your router/Wifi points a reboot first.
Then reboot the Roon Core and then turn on the speakers and if that does not help, power the speakers on first and then the Core.

There is no support on the weekends so give this a try first

I have had this problem with myLS50 wireless II speakers as well of late. I also took the step of changing my DNS over to Cloudflare as Roon seems to prefer this over my Comcast service

Hi Michael, thanks for your reply.
Yep. I’ve tried. Core reboot, router reset/reboot.
What happens is that KEF LSX appears sometimes for 10 minutes and then goes away.
And often, they never show.
It was not the case before July 2021.

Thanks for confirming that Ali.
Can someone from @support pick this up for Ali please.
It’s a strange one Ali and I have been potentially looking at some of thee for some close in desk listening.

Have there been any firmware updates, also have you tested on Ethernet to see if it is a WiFi issue with the device…


Have you checked that the KEF LSX is on the latest firmware update? I’m not able to determine this with the information you provided about the firmware, my apologies.

Since LSX is connected via Ethernet can you check the KEF Control app and make sure it is set to “Cabled Mode”?

Lastly, if the above doesn’t help, can you try connecting the endpoint on WiFi? If so, is the behavior the same or does that change the issue with regards to the LSX not showing up?

Thanks! :pray:t2:


Hey @ashley
thanks for your reply.
For now, i can only confirm that my kef lsx are connected through ethernet to the router (and I use ethernet (cable mode) for the left and right kef lsx speakers).
Didn’t change anything in my setup since last march where roon and lsx worked like a charm!

I can try wifi for kef lsx (or maybe, a factory reset) next week.

I will then let you know.
thanks a bundle!


Hi all and @Ali_CHEMLAL,

I am running into the same problem, using the same speakers, the same firmware version, the same routeur, with a wired Ethernet connection to the network for both speakers and Roon Core. So, a very similar configuration and same issue.

Rebooting all devices may or may not solved the problem (randomly) for me. Anyway, the KEF LSX is no longer shown after some minutes when by chance they are found after restart.

So, I’ll follow this post with a great interest. Let me know if I can help.

I ran into the same problem with my KEF LSX over Ethernet version 5.1 and Roon 1.8 latest build.

Problem solved after I unplugged the KEF power cord on the master speaker for about 30 seconds and then plugged it back in.

1 Like

A post was split to a new topic: KEF Roon Tested disappears and leaves only Airplay option