KEF LSX not downsampling 192kHz files in Roon


(Noris) #9

Hello @Philip_Murray,

Thanks for contacting us, I have a few questions here:

  • Can you please provide some examples of albums displaying this behavior?
  • Does the same behavior still occur after a reboot of the Nucleus + Networking Gear?
  • How are the KEFs connected to each other? Are they using wireless communication or do they have an Ethernet link between them?
  • Where are they plugged in, directly to the router or to a switch?
  • Where is the Nucleus connected, to the router or to a switch?
  • What is your network setup like – what is the model/manufacturer of your Router, Switches, Adapters, ect?

As for the Linn Jazz Radio, that is a bug that has been reported and reproduced by QA, we hope to address this in our next build, but please do let me know the above information when you have a chance.

Thanks,
Noris


(Philip Murray) #10

Hi, thanks for replying. It’s every Qobuz 192 KHz file. I don’t think it is a Roon issue but a Qobuz/KEF LSX one. I do get the occasional Roon issue needing the app to be restarted or Roon resetting but I would expect that with every piece of software. This is on my iMac. No issues with my Roon Nucleus. No software can be perfect (even Apple!), as there will always be glitches, incompatibilities with other software etc. I find some of the postings on here rather unreasonable, often blaming Roon for their problems and expecting a perfect piece of software because they are paying a reasonable amount for it. Frequently is the fault of the poster not doing something or using some weird 3rd Party add-on.


(Noris) #11

Hello @Philip_Murray,

Thanks for the feedback here.

Just to make sure I understand you correctly here, you are able to play 192Khz files without any issues from the Nucleus and this issue is just affecting your on OSX?

How is the iMac connected to the network? Is it on WiFi or Ethernet? If it is on WiFi is the behavior the same? I am thinking that it might just be a bandwidth issue if the iMac is on WiFi, but I am open to taking a closer look at the issue.

Thanks,
Noris


(Philip Murray) #12

Using iMac OS 10.14.2 WiFi 300mbits/sec. Roon core is a Nucleus. Bought KEF LSX last Saturday. Playing Tidal MQAs 192kHz are appropriately downsampled and play through the KEF LSX. Qobuz 192KHz show no downsampling in the signal path and stutter ++ and are unplayable. Lower quality Qobuz files play fine.


(Noris) #13

Hi @Philip_Murray,

Apologies for the delay in getting back to you here. You can set the Maximum Sample Rate in the KEF’s Device Setup menu by right-clicking the Zone (next to the Volume icon) -> Device Setup -> Advanced -> Max Sample Rate (PCM). Please let me know if that helps.

Thanks,
Noris


(Philip Murray) #14

Hi. Using Diana Krall ‘Turn Up The Quiet’ FLAC 192kHz 24 bit on Qobuz as an example album. It already was on the maximum sample rate (192). When I put it to 96 it stuttered but less (NB. I am not running an ethernet cable between the speakers), but at 48 it was perfect. On both 96 and 48 the signal path showed it was downsampling, on 192 there was no down sampling i.e 192 straight to KEF LSX. Playing the same album on TIDAL FLAC 48kHz, 24 bit MQA 192 kHz no issues with downsampling on the signal path. So I am assuming using the Qobuz album the speakers cannot handle the FLAC at 192kHz (probably it would handle FLAC 96 if I had connected the speakers with an ethernet cable) and with my limited knowledge I am getting confused between TIDAL MQA 192 kHz and Qobuz FLAC 192 kHz. So it would seem from this the speakers will not play FLAC 192 kHz properly BUT when I listen to JB Radio 2 it plays perfectly FLAC 192 kHz 16 bit with no downsampling on the signal path. So by a process of elimination it must be that the Qobuz FLAC 192 kHz is the problem. Still can’t work out why the FLAC 192 is working with the internet radio station.


(Noris) #15

Hi @Philip_Murray,

That’s a bit strange that the Radio works but the FLACs do not.

We have a few changes in the KEF LSX area in our next release that might help out with the issue, I can’t say for sure yet but we can circle back to this once the release is published and take another look.

I would also make sure that you are up to date on the KEF firmware, you can use the KEF Control app to check this info.

– Noris


(Philip Murray) #16

Thanks. I have the latest KEF LSX Firmware V3.0.


(Noris) #17

Hello @Philip_Murray,

We have just released Roon v1.6 build 401 which contain some changes in the KEF LSX area:

Roon 1.6 (Build 401) Is Live! Software Release Notes

Hi everyone! A new maintenance release is now rolling out for all platforms, with bug fixes, performance improvements, and updated designs for some of the UI changes in Roon 1.6. Today’s release includes a number of refinements for the footer and the Now Playing screen. We’ve heard a lot of great feedback on the changes in Roon 1.6, and we think the changes made over the last few weeks are big improvement. We hope you agree and we’re looking forward to hearing from everyone! We’ve added the m…

Please give the update a try and let me know how it goes!

Thanks,


(Philip Murray) #18

Still stutters on Qobuz FLAC 192. Plays for a second, stops for 3 seconds, plays for a second, stops for 3 secs and so on. Apart from that it looks a great update. Unless I am doing something different the search facility is greatly improved. Normally to find all the albums of one artist I would have to do the search in many different ways (for the same artist) and each time find different numbers of albums. That was incredibly frustrating and annoying. Now it appears that on one search I have all the albums of that artist - Library, Tidal and Qobuz.


(Noris) #19

Hello @Philip_Murray,

Thanks for letting me know that info. I am not sure if I have asked you this before, but how are the LSX connected to the network? Are they on WiFi or Ethernet? Are they connected to each other using Ethernet or the KEF wireless protocol?

I ask this because I have also tested LSX speakers and noticed similar behavior to the one your reported regarding higher sample rates, but then was unable to reproduce this issue in the lab where the network is configured a bit better and the speakers were connected by Ethernet.

Can you please give that a try (even if temporarily) and let me know if it changes anything? Also, I would double check that your network also meets our Networking Best Practices Guide.

Thanks,
Noris


Issues with Hi-res Qobuz
(Philip Murray) #20

Hi, I tried it before and now tried again and the same issue even with the ethernet cable between the two speakers. I think my network meets your Networking Best Practices Guide. Virgin Media 300Mbps, Ubiquiti UAP-AC-PRO Cloud Managed UniFi AC1750 Dual-Band WiFi PoE Access Point, plus the Nucleus is ethernet connected.


(Noris) #21

Hello @Philip_Murray,

I would like to try a test here, can you please download one of the 192kHz files from the 2L Label (http://www.2l.no/hires/index.html) and try to play it back from your Core on the KEFs? This should give us some insight weather it is just Qobuz that is affected by this issue or if this is all 192kHz files.

Thanks,
Noris


(Philip Murray) #22

I downloaded two samples. Much better but not perfect. No stuttering for the first 30 seconds then a slight stuttering for a split second every 10-15 seconds. Despite Virgin Media 300Mbps, Ubiquiti UAP-AC-PRO Cloud Managed UniFi AC1750 Dual-Band WiFi PoE Access Point, and the Nucleus is ethernet connected, the cable modem is in my study next to the KEF LSX, but the Roon Nucleus is downstairs in the front room. 2L%20FLAC%20192


(Noris) #23

Hi @Philip_Murray,

Thanks for performing that test.It is still not clear to me how the KEFs are connected to your network here, you mentioned that you tried to add an Ethernet between them for communication but it is not clear if you have tried connecting them to the router via Ethernet instead of using a WiFi link to the router, I suspect the WiFi link might have something to do with high-res streaming.

I’m going to request that the hardware team try to reproduce this issue again in the lab but just to make sure that the environment is the same, can you please try connecting the KEFs to the router via Ethernet and let me know if you still experience this issue?

Thanks,
Noris


(Philip Murray) #24

Hi, I connected the Master speaker directly to the cable modem with an ethernet cable and … no difference. Sorry.

Regards

Phil


(Noris) #25

Hi @Philip_Murray,

Thanks for letting me know those results. The hardware team is looking into this issue and we might have to involve KEF if this report becomes reproducible in the lab. As soon as I have more information to share I will be sure to let you know.

Thanks,
Noris


(Dan Brown) #26

I saw this in the “Kef LSX introduction” thread from @Ben_Hagens

I think this relates to plugging in the speaker inter-connect lead rather than plugging in an Ethernet cable back to the router, however, I wonder if the LSX need to be ‘told’ to connect via wired Ethernet to a router after being plugged in, or if they do it automatically…?


(Noris) #27

Hi @Dan_Brown,

You are indeed correct here, you would need to enable “Cable Mode” in the KEF Control app for them to communicate over the Ethernet link otherwise they would still be using WiFi, even though the Ethernet link is connected. This would be another good place to check @Philip_Murray just for any possible issues in that regard.

Thanks,
Noris


(KEF Product Training Specialist) #29

Yup, this is the interspeaker connection, which needs the Cable Mode enabled.

For the network, Ethernet automatically takes priority over WiFi. This doesn’t need any settings changes in the app.