Last.fm Scrobbling

Hi @support,

Since updating to 1.6 this morning almost all of the scrobbles are being duplicated.

Here is an example

I have checked yesterday’s and all looks fine. I currently have both Tidal and Qobuz attached to my account, and many of albums are favourites in both.

I just tried playing the same few tracks firstly from my library (red), then Qobuz (blue) and finally Tidal (black), it only seems to be Qobuz that is duplicating.

image

Also playing the same Evanescence album from Tidal is not duplicating.

Thanks
Nigel

1 Like

Hey @Nigel_Pettitt – it looks like Qobuz is submitting plays in Roon to Last.FM.

We’ll see if we can do better here, but for now you should be able to avoid the duplicate scrobbles by unlinking Last.FM from Qobuz (or from Roon).

Hi,

Yup that seems to have sorted it out for now, thanks for the fast response. I forgot you set this on the account rather than within their applications!

Thanks
Nigel

Hi @support … Any updates on this? Duplication’s still happening with the latest 1.7 build. Thanks.

Hi @jasonheyd,

We looked into this and, based on how Qobuz integrates with last.fm, this is the expected behavior. Roon will send all plays in the app to last.fm. If you’ve also connected last.fm to Qobuz, they will send all plays as well, including plays from their API. Since their API plays are included, these plays will get counted twice because Roon is also counting the plays.

The best option is to disable last.fm scrobbling in one of the locations so the plays aren’t doubled.

Hi @dylan. Thanks for getting back to me, but I disagree. Or, rather, that should not be “expected behavior” given a robust implementation.

I do use Qobuz other than through roon. After all, I can’t really use roon outside of my local network (at least not without some serious hurdles). In light of that, I’d rather not lose my non-roon Qobuz scrabbles.

A better solution might be to give us an option in roon to toggle scrobbling for library, Tidal, and Qobuz plays respectively (or at least disable them for Qobuz to let Qobuz itself handle the scrobbling).

2 Likes

Hi @jasonheyd,

This isn’t something that is currently possible in Roon, but I would definitely recommend opening a topic in #roon:feature-requests about this. Our product team keeps a close eye on that category and it’s a great place to get feedback from other members of the community about a particular topic.

Thanks!

Will do & thanks again!

1 Like