Latest update locks out Tidal

Core Machine (Operating system/System info/Roon build number)

Nucleus V1.7 build 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chord Dave USB

Description Of Issue

Just installed the latest update - notified today. Now Roon will not allow Tidal - “You aren’t currently signed in to Tidal”, then directs me to the tidal site where I log in no problems…and then just repeats.
I have rebooted, etc to no avail.
Can only play local files.

Have you tried going to “settings” then “services” and signing in there.

1 Like

Sure have - to no avail. Thanks.

Have you updated the remote app? It seems to use a different sign in for Tidal on my phone and some weblink to Tidal popped up that I needed to use. Before I did that it would not login. The weblink stayed active though even though it was logged in.

Sounds a bit like this issue, but the remote app is latest as well. Thanks.

A post was split to a new topic: No login to Tidal via Roon possible after latest update

I had the same issues last evening (around 7pm GMT). Essentially there are a couple of moments where it is supposed to redirect, and it seems that if that hasn’t happened automatically, Roon does not see the new login. So initially it wouldn’t accept my login. Then it did but did not redirect correctly. Finally it did redirect back to Roon and the pink warning message went away. This may well be just because the system is busy with all of the new login attempts as people update their Roon software. The whole process took me well over 30 minutes including a couple of reboots.

Had an issue with the Tidal login after the 521 upgrade in Feb. Login to Tidal from my PC IE browser worked and the login from Roon on PC remote got a successful response from Tidal but Roon didn’t recognize it. Support suggested I try using Chrome as my browser. Did not have Chrome but I did have Firefox. Switched the default browser from IE to Firefox then the login to Tidal through Roon worked.

This sounds like the same issue but could be something else.

A post was split to a new topic: Trouble logging in to TIDAL after update

Hi @Mark_Stewart,

Can you describe your networking setup?

What remote device are you using to log in? What browser are you using?

Hi Dylan.
Modem to dedicated switch to Synology NAS and Nucleus - all via Cat 7.
I have tried Safari and Firefox on a MacBook Air (10.15.3). Tried Safari after your question - only difference in browsers is that Safari shows the Captcha which Firefox does not support.

I had the same issue after updating Roon today. What a nightmare. I had numerous prompts to enter my Tidal password which wasn’t accepted. Rebooted core. Updated app. I then got the new Tidal login system where it opens a website. My password was accepted but when I got redirected to Roon where I was asked for the Tidal password again!!! Endless loop for about 10 iterations of entering password in safari, getting redirected to Roon. Finally rebooted core a second time and the password stuck.

What a horrendous user experience. Roon needs to do rigorous testing to make sure the upgrade process is bug free for Tidal users.

In general I am happy with Roon software and would rate my satisfaction 9/10. For the upgrade process I would give a score of 0.001/10. It is garbage. Please stop doing upgrades unless you can make the process stress free for your customers.


Totally agree. Great product but poor QC…and at least also provide us with the ability to roll back when issues appear.

Hi Dylan, what is happening here please? Clearly from posts others are having the same issue.


A post was split to a new topic: Problems with TIDAL logins

@dylan. Can I have status on this please?
Thank you

Hi @Mark_Stewart,

The team is looking into this and in most cases the issue appears to be related to the Roon remote using an older version than the Core machine. Since that doesn’t appear to be the issue here we’ve enabled diagnostics on your account and the team is looking into this further.

Additionally, we were hoping you could use the directions found here and send us over a set of logs using a shared Dropbox link.


Hi @dylan, I can access the Nucleus management screen via the IP address, but it appears to give no access to Data.
Using the “Finder Explorer” as per Roon instructions does not work as it will not allow searching of the network.
I can access using smb via a browser but it asks for a username and password - Roon docs say to use my Roon details, but this is not accepted.
Please advise.


Hi I intially had this issue as well. On my android phone I quit Roon, started it again, went into the “services” tab and logged out of Tidal. I then logged back in again, and my Tidal service was restored.

Hi thanks. I couldn’t get into the Nucleus other than to the one page headed “System Status”…but then I tried as a Guest and got straight to the Data file!
Interesting that the username/password requirement is only required if you are registered??